WordPress.org

Ready to get started?Download WordPress

Forums

Custom Fields problem with 2.5rc2 (20 posts)

  1. Nebuloso
    Member
    Posted 6 years ago #

    While trying to Write a post, I do the following (in this order):

    • type in Title (eg NAME OF POST)
    • type Post
    • write tags
    • check categories
    • add a (pre-existing - using the drop box) custom field entry (hitting "Add Custom Field" after entering the info)
    • add a second (pre-existing) custom field entry (again, clicking "Add Custom Field afterwards)
    • Publish

    When I go to the "Manage Posts" page, I see the following:

    (published) NAME OF POST
    (published) Older post
    (published) Previous post
    (published) Post before that
    ...etc...
    (unpublished) NAME OF POST
    (unpublished) Draft created on DATE at TIME

    Clicking on the name of the post to edit it reveals the following:

    For NAME OF POST (the one that was published):
    All the info entered appears, except the only custom field entry displayed is the last one entered

    For NAME OF POST (the one that was unpublished):
    All the info entered appears, with the exception of the category and custom fields entries.

    For Draft created on DATE at TIME (unpublished):
    NONE of the info appears (the title was changed to "Draft created on DATE at TIME")....EXCEPT for the first custom field entry.

    If I go back and edit NAME OF POST, it will accept additional custom fields with no problem.

    At first, I thought I was doing something screwy (and I remain open to the possibility that may still be the case), but this seems like pretty odd behavior if it was just some setting I needed to adjust.

    For what it's worth...
    I'm using Firefox 2.0.0.13 and Windows XP (Media Center Edition).
    I don't have similar problems while using WordPress 2.3.3

    Any help would be MUCH appreciated.

    Thanks!

  2. Nebuloso
    Member
    Posted 6 years ago #

    On a hunch, I went back and created another new post but this time I attempted to add 3 custom fields instead of 2.

    Doing this resulted in two "Draft Created on DATE at TIME" (same date and time) unpublished posts.

    The NAME OF POST (published) and NAME OF POST (unpublished) posts remained the same as I described above.

    One of the two "Draft Created on DATE at TIME" (unpublished) posts contained only the first custom field information.

    The other "Draft created on DATE at TIME" (unpublished) post contained only the second custom field information.

    :S

  3. fitztrev
    Member
    Posted 6 years ago #

    I experienced something very similar to this earlier today. I couldn't reproduce it, though. (I forgot what I had done.)

    So I can verify the behavior.

  4. chimo
    Member
    Posted 6 years ago #

    I am also experiencing this exact problem. it adds a draft for every custom field entry.

    So when i make a post and use 3 custom fields I get the original post plus 3 drafts.
    Img of drafts page

  5. MichaelH
    Member
    Posted 6 years ago #

    Just FYI this is reported for 2.5 via Trac Ticket 6457

  6. Devilsoulblack
    Member
    Posted 6 years ago #

    hi this ist the video off that bug
    http://www.vimeo.com/842369
    http://www.vimeo.com/842723

    any idea how to solved ?

  7. moikirsch
    Member
    Posted 6 years ago #

    This is not a fix but a workaround for the moment:

    Before creating your custom fields SAVE your post.

    After that everything should be Ok.

  8. lazyme
    Member
    Posted 6 years ago #

    you`re right, thank you very much, the workaround works. :)

  9. yashraj12
    Member
    Posted 6 years ago #

    yeah im facing the same problem with the 2.5 edition....its quite irritating

    my theme requires me to use 2 custom fields
    if i add both together while publishing the post, the CF that is added last gets saved and the other one is discarded.

    I have to edit the post again to add the second CF ....

    i havent really seen what happens to the drafts, ....though there r many such extra drafts created, as @Nebuloso said, i do agree with him, maybe they r becuz of the CF problem..

    Thanks for the Turn around @moikirsch

    will use it

    hope a patch comes up soon

  10. yashraj12
    Member
    Posted 6 years ago #

    still no revert on the problem
    it sure gets irritating

    n time consuming
    especially if u have a blog where u have to update 10-20 stories a day at one time.....

    wp gods save up

  11. Lumpysimon
    Member
    Posted 6 years ago #

    i am getting the same problem (clean install of wp 2.5.1). i tried guillep2k's patch but it does not appear to solve it.

    in addition, if i delete the draft posts, the custom fields then disappear from the published posts, and those keys are no longer available in the drop-down on the 'write post' screen.

    it's very frustrating as i am using wordpress as a directory, where each post has 8 custom fields, so i now have a lot of drafts!

  12. yashraj12
    Member
    Posted 6 years ago #

    still no proper reply
    isnt this bug bugging others?

    is it only with us?

  13. msnaughty
    Member
    Posted 6 years ago #

    I'm also getting a bunch of drafts, sometimes two or three for each post. I'm getting drafts that consist of only a title since the autosave kicks in and saves it halfway through. I'm also getting drafts with headings like: "Draft created on May 31, 2008 at 5:30 am"

    On top of that, my drafts section is now full of 61 useless drafts and I have to delete them one at a time. If I check more than one box I get an "Error in Deleting" message.

    So it may be that my problem isn't related to the custom fields since the drafts get made well before I get a chance to use them.

    I'm really hoping someone fixes this soon, it's very annoying.

  14. arminbw
    Member
    Posted 6 years ago #

    I would be nice if deactivating the annoying autosave function would be possible. Manually deleting all those drafts is quite a tedious task.

    Unfortunately deleting wp_enqueue_script('autosave') in post-new.php isn't a solution regarding the custom field issues.

    At least ticket 6457 is set to priority "highest omg bbq"..

  15. arminbw
    Member
    Posted 6 years ago #

    I would be nice if deactivating the annoying autosave function would be possible. Manually deleting all those drafts is quite a tedious task.

    Unfortunately deleting wp_enqueue_script('autosave') in post-new.php isn't a solution regarding the custom field issues.

    At least ticket 6457 is set to priority "highest omg bbq"..

  16. arminbw
    Member
    Posted 6 years ago #

    milestone changed from 2.5.2 to 2.9.

    Ouch.

  17. nfong
    Member
    Posted 6 years ago #

    A FYI (WordPress 2.5.1 - Firefox 2)

    Create a New post.

    Add a custom field (pre-existing) to the post.
    Draft gets saved.
    Postmeta entry created with post_id 68

    Add a custom field (pre-existing) to the post.
    Draft gets saved.
    Postmeta entry created with post_id 69

    Add a custom field (pre-existing) to the post.
    Draft gets saved.
    Postmeta entry created with post_id 70

    Save post.

    Post is now id 70, but of course lost custom fields attributed to draft id 68, 69.

    As previously mentioned. Workaround is to save then add custom fields.

    ---
    guillep2k's Patch didn't help

  18. nfong
    Member
    Posted 6 years ago #

    Per suggestion. Retested and 2.6 does fix my problem!

  19. arminbw
    Member
    Posted 5 years ago #

    Looking at posts in this forum, WP 2.6 brings a bunch of new bugs. They might be fixed in the next version, but I am thinking about staying at version 2.5.1 and fixing the bugs I already know.

    Unfortunately ticket 6457 doesn't give any hint on how the problems with the custom fields were actually solved. How many files had to be altered and which?

  20. arminbw
    Member
    Posted 5 years ago #

    Anyone?

Topic Closed

This topic has been closed to new replies.

About this Topic