WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Custom Fields field missing from Page edit screen (6 posts)

  1. effectivesitemarketing
    Member
    Posted 3 years ago #

    Hey,

    I'm working on a theme which is missing the Custom Fields section on the Page edit screen (I click to edit or create a new page and I can see all standard fields to enter page text, see comments, etc but no custom fields field).

    I don't believe it's a plugin disabling it. The theme designer disabled the creation of posts, etc. so I think he must have also removed the custom fields.

    Does any one know which php file would contain the code to show custom fields there? Once I find it I'll copy over the code from a site which does have it running, but I can't find which file it is.

    Thank you very much for any ideas.
    Peter

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or PhpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    - increasing the memory available to PHP?
    http://wordpress.org/support/topic/253495#post-1017842

  3. effectivesitemarketing
    Member
    Posted 3 years ago #

    Thanks esmi

    I'll try increasing the memory. I'm 99% sure it's not the plugins since I've tested all of the plugins it has on another website and it didn't remove the custom fields box.

    The problem is that this site gets a few thousand people a day and generates many of our leads so my boss would kill me if it went down for a while, so I don't really want to risk uploading a bunch of new files but if it comes to that then I will and just be careful about backups.

    Ideally if I could find the page that controls aspects of the page publishing page then I'll just modify that. I'll post if if it's ever found!

  4. effectivesitemarketing
    Member
    Posted 3 years ago #

    OK I feel stupid. Just needed to click screen options top right, then I could select to see it or not....

  5. dlawton
    Member
    Posted 3 years ago #

    @seositemarketing Thanks for the help! For some reason after migrating to 3.1 my custom fields disappeared, I wasn't even aware of the screen options until I saw your post :)

  6. Leo Plaw
    Member
    Posted 3 years ago #

    Same here. I also upgraded to 3.1 and it had also hidden my custom fields along with a number of other boxes. So I'd also like to thank seositemarketing for pointing that out. Its obviously a bug in the new WordPress to just ignore and overwrite your admin display options.

Topic Closed

This topic has been closed to new replies.

About this Topic