WordPress.org

Ready to get started?Download WordPress

Forums

Postie
Custom fields (9 posts)

  1. opleyer
    Member
    Posted 1 year ago #

    Hi there,
    I scrolled through the support-forum for postie but didn't really get lucky.
    When writing a new post on WP I use a couplpe of predefined custom fields that I would need also when using postie to add posts via email.

    so far postie works great an does almost everything what I need it to do, but I didn't find out how to use the custom fields.

    Also I've used the date-function to define the post-date. I would need also to use a function to define the time of the post, as the articles I add are both date and time related.

    Hopefully I can get help here?

    http://wordpress.org/extend/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    You could using the "postie_post" filter as described http://wordpress.org/support/topic/request-auto-gallery-feature?replies=6#post-3707833 to add your custom fields.

    I've updated the date command in 1.4.22 to accept time values as well.

  3. opleyer
    Member
    Posted 1 year ago #

    Thanks for this.

    I downloaded the update.

    However I tried to get along with the filter. I must admit that I am definitely less than a beginner in this area and I have absolutely no clue in which php I would have to add and where to insert this. I found out a lot by just playing around and trying, but obviousely I don't want to screw up the existing config :-)

    Maybe there is somebody out there in the world that can give me the hint?

    I am using 5 different custom-fields that I need to be able to match with the email.

    custom-field1 = [Loc]
    custom-field2 = [address]
    custom-field3 = [quantity]
    custom-field4 = [engine]
    custom-field5 = [notification]

    Many thanks in advance.

  4. opleyer
    Member
    Posted 1 year ago #

    one more thing.

    since the update, the date-function seems to me not working anymore...

    Is this correct or do I something wrong?

  5. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    As far as i know the date is working. How are you using it?

  6. opleyer
    Member
    Posted 1 year ago #

    Hi,

    in the body
    :start
    date: 2013-01-09

    text
    text
    text
    text
    text
    text
    :end

    That was before you published the new release and worked fine.

    After the new release I tried to modify in different ways the date-parameter, but nothing worked...
    for example
    :start
    date: 2013-01-09 17:55:00
    :end

    :start
    date: 2013-01-09

  7. opleyer
    Member
    Posted 1 year ago #

    Seems to be working now again...

    Now I need to check how to implement the custom fields

  8. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    I'm glad it is working for you.

  9. Hotcoffee
    Member
    Posted 11 months ago #

    Opleyer, just wondering if you ever made any progress with your custom fields... any suggestions would be appreciated.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic