WordPress.org

Ready to get started?Download WordPress

Forums

Gecka Submenu
[resolved] "Current page's top parent" option doesn't work with 3.5 (9 posts)

  1. devon
    Member
    Posted 1 year ago #

    I just updated to WP 3.5, and my sidebar menus have disappeared. I was using the great "Current page's top parent" option in the "Custom Menu [advanced]" widget, but it stopped working after the update.

    http://wordpress.org/extend/plugins/gecka-submenu/

  2. bridgetwes
    Member
    Posted 1 year ago #

    I am having the same issue on all my sites that use this options for submenus. It happened when I upgraded all sties to WP 3.5 yesterday.

  3. feneblog
    Member
    Posted 1 year ago #

    The same issue on my sites with WP 3.5.

  4. scheurta
    Member
    Posted 1 year ago #

    Same issues here with 3.5.

  5. Gecka
    Member
    Plugin Author

    Posted 1 year ago #

    It should be fixed with 0.7-beta3 we just released.

  6. devon
    Member
    Posted 1 year ago #

    Works again, thanks!

  7. 1-krn
    Member
    Posted 1 year ago #

    To Gecka:
    The sidebar menus of our website are disabled right now because this plugin doesn't want to work with PHP 5.4.9 (that our host upgraded to without us knowing). We were using version 0.5.3 of this plugin, we are running WordPress 3.1

    In a different forum a user suggested fixing it by "removing the leading ampersands ("&") from the function calls (not the definitions)", because "Call-time pass-by-reference has been deprecated since PHP 5.3, and has been removed from PHP 5.4"

    Can you fix this? Or was this already fixed in a newer version (or the Pro version)? We need to get this resolved ASAP.

  8. feneblog
    Member
    Posted 1 year ago #

    "removing the leading ampersands ("&") from the function calls (not the definitions)", because "Call-time pass-by-reference has been deprecated since PHP 5.3, and has been removed from PHP 5.4"

    I modified Version 0.7-beta3.
    Download from: http://www.fene-blog.de/wp-content/uploads/gecka-submenu.zip

    It works for me!

  9. stianjaco
    Member
    Posted 1 year ago #

    I have the same problem and I'm using the pro version. Funny thing, I found out that I did't get any login after buying the pro version. So I cant auto-update or manually download updates...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.