WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Current equivalent of $table* globals? (3 posts)

  1. iand
    Member
    Posted 7 years ago #

    I am looking to upgrade from 2.0.10 but a couple of the plugins which I use are listed in 'plugins that don't work' for 2.1 (so I assume they will not work for 2.2 either).

    The reasons for both not working is shown as 'Extensive use of $table* globals.'

    Presumably $table* is depreciated now, so, what should I be looking at changing $table* to for the new versions?

    [Plugins in question are drop down categories and customisable post listings].

  2. whooami
    Member
    Posted 7 years ago #

    look inside wp-settings.php

    $wpdb->posts          = $wpdb->prefix . 'posts';
    $wpdb->users          = $wpdb->prefix . 'users';
    $wpdb->categories     = $wpdb->prefix . 'categories';
    $wpdb->post2cat       = $wpdb->prefix . 'post2cat';
    $wpdb->comments       = $wpdb->prefix . 'comments';
    $wpdb->link2cat       = $wpdb->prefix . 'link2cat';
    $wpdb->links          = $wpdb->prefix . 'links';
    $wpdb->options        = $wpdb->prefix . 'options';
    $wpdb->postmeta       = $wpdb->prefix . 'postmeta';
    $wpdb->usermeta       = $wpdb->prefix . 'usermeta';

    for instance,

    $tableposts becomes $wpdb->posts

    hope that helps!

  3. iand
    Member
    Posted 7 years ago #

    That looks promising - I think I will be doing a lot of find and replacing!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.