WordPress.org

Ready to get started?Download WordPress

Forums

Current 3.6.1 doesn't find 3.7 update (8 posts)

  1. sleemandude
    Member
    Posted 7 months ago #

    We currently have WordPress 3.6.1 installed and running on an intranet, and we would like to upgrade to version 3.7. Everything runs fine, except for the "updates". The same problem is present with the plugins. I know some plugins have newer versions, but it won't find them. It keeps telling me everything is up-to-date... I have deleted the _site_transient_update_core (and plugins) keys in the wp_options table, but it didn't solve the problem.

    We are behind a proxy (FortiGate) and all the configurations have been added to wp-config.php.

    define('WP_PROXY_HOST', 'x.x.x.x');
    define('WP_PROXY_PORT', '8080');
    define('WP_PROXY_BYPASS_HOSTS', 'localhost, x.*');

    With the proxy interface, I see the request to api.wordpress.org and nothing is being blocked!

    I have enabled wp-debug, but no errors are being showed or logged...

    Current configuration:
    version 3.6.1
    Wampserver 2.4
    No multi-site
    default theme
    all plugins disabled

    Any help would be greatly appreciated!

  2. sleemandude
    Member
    Posted 7 months ago #

    At least, if someone knows how to trace this kind of problems, it would be very helpful!

    There must be a way to trace what is happening inside this little box!?

  3. With the proxy interface, I see the request to api.wordpress.org and nothing is being blocked!

    On the web proxy you should see the log of the request. Try this: take that request and manually enter that URL into your web browser (after you have configured your web browser to use proxy host and port).

    When you do that do you see any messages from the web proxy? Also what URLs do you see in your proxy log for updates?

  4. sleemandude
    Member
    Posted 7 months ago #

    Thanks M. Dembowski for responding!

    Actually, I configured the proxy (as I have an admin access to it) to not restrict any request related to the server's IP/MAC address. The only problem I could see is that our proxy is behing another proxy, which I do not control, but that is mainly there to control/shape traffic and check for viruses and legit access.

    When I enter the requested api.wordpress.org address directly in the browser, I get straight to the web page (WordPress.org API - Maybe we should fill things out here)

    In the proxy, I only see 3 http requests to api.wordpress.org (66.155.40.249) and the bytes sent/received:
    - 2.44KB/233B
    - 2.08KB/817B
    - 394B/1.18KB
    in that time order.

    Is there any documentation I could follow to understand the exact process it's going through for the updates?

    It'd be really great to solve this!!

  5. sleemandude
    Member
    Posted 7 months ago #

    One tought: The current installed version is French. Could this be related?

    I do not see a "re-install" option. When exactly is this option visible?

  6. sleemandude
    Member
    Posted 7 months ago #

    I installed a "normal" (English US) 3.6.1 version and I get the exact same problem: It does not find the new 3.7 version. I can send emails, search and visit the plugins' pages and it seems to be doing something when searching for updates, but nothing more. It keeps telling me it is up-to-date

    Also, I don't see the "re-install" option.

    Anyone has a clue?

  7. sleemandude
    Member
    Posted 7 months ago #

    Ok... a little further in the tracing now:

    update-core.php succesfully calls function core_upgrade_preamble. The value inside $wp_version is "3.6.1". It then calls get_core_updates() which returns an array containing: "a:0:{}"

    It then calls dimissed_updates(), which also returns an Array of "a:0:{}"

    I believe this is my problem, but why??? Anybody has a clue?

  8. sleemandude
    Member
    Posted 7 months ago #

    I just don't get it. I activated multisite mode, just to rule it out of the equation.

    Basically, it seems it can't retrieve the current version from the internet, but yet is not throwing any errors.

Reply

You must log in to post.

About this Topic