WordPress.org

Ready to get started?Download WordPress

Forums

CloudFlare
[resolved] curl probs (5 posts)

  1. Ovidiu
    Member
    Posted 1 year ago #

    the cloudflare plugin claims:

    You cannot toggle development mode because cURL is not installed for your domain. Please contact a server administrator for assistance with installing cURL.

    But phpinfo() says:

    curl
    
    cURL support	enabled
    cURL Information	7.21.0
    Age	3
    Features
    AsynchDNS	No
    Debug	No
    GSS-Negotiate	Yes
    IDN	Yes
    IPv6	Yes
    Largefile	Yes
    NTLM	Yes
    SPNEGO	No
    SSL	Yes
    SSPI	No
    krb4	No
    libz	Yes
    CharConv	No
    Protocols	dict, file, ftp, ftps, http, https, imap, imaps, ldap, ldaps, pop3, pop3s, rtsp, scp, sftp, smtp, smtps, telnet, tftp
    Host	x86_64-pc-linux-gnu
    SSL Version	OpenSSL/0.9.8o
    ZLib Version	1.2.3.4
    libSSH Version	libssh2/1.2.6

    What's wrong here and who's lying? ;-)

    http://wordpress.org/extend/plugins/cloudflare/

  2. jchen329
    Member
    Plugin Author

    Posted 1 year ago #

    I'm more inclined to think that neither is lying, but one is more or less misinformed.

    It turns out that some installations of PHP have this attribute called "short_open_tag" turned off by default, which causes the block of code that displays whether or not cURL is installed was being outright ignored.

    I'm testing a potential fix, and should be able to push something out later.

  3. Ovidiu
    Member
    Posted 1 year ago #

    spot-on. short php tags are indeed off on my system :-)

  4. jchen329
    Member
    Plugin Author

    Posted 1 year ago #

    No problem, I figured it was worth changing it so that long tags are used in that section. It should be changed at this time.

  5. Ovidiu
    Member
    Posted 1 year ago #

    Thanks, works now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic