WordPress.org

Ready to get started?Download WordPress

Forums

TubePress
[resolved] cURL Failed error (22 posts)

  1. chibichiii
    Member
    Posted 1 year ago #

    Hi there!

    I'm using the latest version of TubePress on an Artisteer Template with WordPress 3.4.2 also newest version.

    Untill today everything was working fine, I didn't have any problem. Today every shortcode results into cURL failed. Also the widget is not working also says cURL failed.

    As I didn't change anything over night I'm kinda wondering what could have caused the problem? Perhaps Youtube made a change?

    To test the Playlist ID's I use another Plugin called Youtube Channel. Their widget is still working normally and showing the playlist.

    Anyone got any idea what to do to get Tubepress working again?

    I already deleted the plugin, reinstalled it but the same problem remains.

    http://wordpress.org/extend/plugins/tubepress/

  2. ritun
    Member
    Posted 1 year ago #

    Me too getting cURL failed error. Everything was working fine till recently.

  3. Eric
    Member
    Plugin Author

    Posted 1 year ago #

    This error means that TubePress is unable to make network connections - some hosts add controls that prevent PHP scripts from making outbound connections. I would open a support ticket with your hosting provider explaining the situation. They should be able to point you in the right direction.

    Let us know what you find!

  4. chibichiii
    Member
    Posted 1 year ago #

    Alright thanks I'll send an email to my hosting to see if they have changed anything.

    Kinda makes me wonder though because this would mean, several hostings have changed the same thing around the exact same time.

    I did notice youtube made several changes again. So it would not surprise me if the error hangs together with youtube again.

    I'll get back to ya when my hosting responds. Thnx for the suggestion!

  5. chibichiii
    Member
    Posted 1 year ago #

    My provider is asking me if the plugin uses perl or cgi script. Perhaps you can help me out with that question k2eric?

  6. Eric
    Member
    Plugin Author

    Posted 1 year ago #

    No perl or cgi script. Just plain PHP making HTTP connections over port 80 to gdata.youtube.com and/or vimeo.com.

    Hope that helps...

  7. chibichiii
    Member
    Posted 1 year ago #

    Unfortunately no luck :( My provider says apart from adapting perl and cgi scripts they have not changed anything. And I've been trying practically everything I can't seem to get my Tubepress to work again.

    I love this plugin I don't wanna do without :'(

  8. Eric
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have a link to your site that you could share? I'd be interested in taking a look at your TubePress debug output. The other thing that would be good to see is the output of phpinfo()

  9. chibichiii
    Member
    Posted 1 year ago #

    Sure here's a link to my site 'http://merlin.chibichiii.nl/' I'm not sure how to do this phpinfo your mentioning. Can you explain how to do it or what information you need to look?

  10. Crisium
    Member
    Posted 1 year ago #

    I too am receiving this error message.. everything has been running fine until now.. what is going on? I have not changed anything.

    Peter

  11. Eric
    Member
    Plugin Author

    Posted 1 year ago #

    @chibichiii, are you all set now? I visited your site and TubePress seems to be operating normally.. Let us kno.

    @Crisium do you have a link to your gallery that you could share? Thanks

  12. chibichiii
    Member
    Posted 1 year ago #

    I managed to fix it, by going under the Advanced options of Tubepress and deactivate the cURL completely. It said only to do so when you know what your doing, but I guessed I could not break it any further anyway so what the heck. And checking the deactivate cURL fixed the problem :)

  13. Crisium
    Member
    Posted 1 year ago #

    @chibichiii I'm afraid you solution isn't one I can use.. it does resolve the problem but the website takes to long to load now.

    so I need a better solution... I think something has changed and tubepress needs to be updated.

    Peter

  14. cinitriqs
    Member
    Posted 1 year ago #

    New updated version does not have the option of "deactivate cURL" no more so please, do not update to the newer version if you want your playlists to keep on working

  15. Crisium
    Member
    Posted 1 year ago #

    I have changed plugin to "Simple Youtube" which does basically same and doesn't have the curl error.

  16. cinitriqs
    Member
    Posted 1 year ago #

    Good to know about "simple youtube" might decide to go with that one when I find the time to reorganize ;) I just downgraded to an older tubepress plugin for now that I know works without the cURL error. Problem is, this is the second time I ran into trouble with this plugin, and it has impacted my visitors at both times which is not something I like to see happening. Either way, I have started a new "thread" because this issue is in no way resolved and should be looked into further by the tubepress developers. Granted, I am not a paying tubepress user so the support can be very minimal but I assume this also has an impact on those who do pay for the pro version of this plugin.

  17. Eric
    Member
    Plugin Author

    Posted 1 year ago #

    Hi folks,

    I'm sorry that you're still experiencing trouble with cURL. We try our very best to make sure that TubePress works on all server configurations, but obviously we aren't 100% bug free. I would still very much like to solve this issue once and for all.

    We don't mean to blow off reports about this bug. To be a bit frank, it has been low priority because 1) thousands of sites are using cURL with TubePress without any trouble and 2) it's been impossible so far to reproduce reliably. I know that doesn't make it any better for you, but hopefully this adds some context to the situation.

    So, how do we fix the bug? Best case would be shell and/or FTP access to your site. That would allow me to run some tests to find out exactly what's failing. Is it the network? PHP's configuration or version? The hosting provider? If you feel that you could provide this, please feel free to contact me privately over at the TubePress Community site. My username there is "eric".

    Thanks for your understanding and I look forward to nailing down this issue once and for all!

  18. chibichiii
    Member
    Posted 1 year ago #

    Okay first I was shocked when I read too late about the disable cUrl was taken out of the advanced options. But I checked my site and all my playlists seem to be working fine still -phew- so I suppose the cUrl error somehow fixed itself?

    My hosting provider said nothing was installed or changed on the server side when the error occured so it leaves a server side error out. Also I had not updated the plugin, nor wordpress recently when the error appeared. So that leaves it actually to a Youtube orientated problem. I don't think you guys should be so hard on k2, Youtube was taken over by Google and ever since it's started upgrading security, policies and know what all. Causing nothing but problems, dissapearing videos from the net after months sometimes years, playlist Id's changing etc...

    So here's some information from my side k2eric, my server uses port 80, my files are all 755 indicated in filezilla on the ftp, I use both id's on my page both with and without PL in front both of them are fully functioning atm.

    Thnx for trying so hard, I'm hoping the issue will stay resolved with me :)

  19. cinitriqs
    Member
    Posted 1 year ago #

    Couldn't PM you on the forum so I left a message as a thread on the tubepress forum. greetings.

  20. Eric
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks to the generosity of cinitriqs, I believe we may have found a fix for this bug.

    Please see http://community.tubepress.org/topic/1790-curl-failed/?p=6314 for the details. It's a one-liner.

    If you would report back with your results, and assuming it seems to work for everyone, we'll release an updated version of TubePress that includes the patch.

    Thanks!

  21. Ramzii
    Member
    Posted 1 year ago #

    Out of the blue this error also appeared. Any ideas?

    I tried replacing on line 99:

    $this->_handle = curl_init($request->getUrl()->toString());

    No luck.

  22. Ramzii
    Member
    Posted 1 year ago #

    I installed 3.0.1 RCA beta and it solved my cURL issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic