WordPress.org

Ready to get started?Download WordPress

Forums

WP DoNotTrack
[resolved] Curious behavior (14 posts)

  1. iltrev
    Member
    Posted 1 year ago #

    I just installed WP DoNotTrack on a couple sites, and it seems to be working. Well, almost.

    What it appears to be doing is that it works just fine for visitors, but not at all with my own visitst (I mean, when I am logged in as admin).
    Just to be more clear: I am using Ghostify on Safari, and what I see is that WP DoNotTrack works perfectly when I visit my sites as a non-logged-in user, disabling the generation of the code contacting secure.quantserve.com, but it doesn't work at all in sessions where I am logged in as an admin.

    I tried both black- and whitelist mode, and none of them seems to be helping.
    Well, ok, I am perfectly happy with it as it is, but... Is there anything I can do to *completely* stop Jetpack from doing that?

    Thanks in advance

    http://wordpress.org/extend/plugins/wp-donottrack/

  2. futtta
    Member
    Plugin Author

    Posted 1 year ago #

    Morning Iltrev;
    Are you using normal, forced or superclean mode?

    frank

  3. iltrev
    Member
    Posted 1 year ago #

    Tried both, no change.

  4. iltrev
    Member
    Posted 1 year ago #

    As a side note: I also just installed Jetpack 1.9.1 - is there any way it could be due to that?

    Another thing: the url it contacts when I am logged in is https://secure.quantserve.com/query.js , as opposed to http://edge.quantserve.com/query.js. Any chance it is related to that?

  5. futtta
    Member
    Plugin Author

    Posted 1 year ago #

    Can you set wp donottrack to "whitelist" and "superclean" and try again?

  6. iltrev
    Member
    Posted 1 year ago #

    Nothing changes (see this screenshot)

  7. futtta
    Member
    Plugin Author

    Posted 1 year ago #

    Very weird. I'll investigate and get back to you on this.

  8. iltrev
    Member
    Posted 1 year ago #

    Well thanks for now

    Have a nice day :)

  9. futtta
    Member
    Plugin Author

    Posted 1 year ago #

    remains weird; tested on my development instance and can't reproduce (i.e. no calls to quantcast to be seen in firebug). what Jetpack features are you using?

  10. iltrev
    Member
    Posted 1 year ago #

    Sorry for the delay...
    I am using just stats and subscriptions.

  11. futtta
    Member
    Plugin Author

    Posted 1 year ago #

    could you create a user with limited rights (contributor, author or editor) on your blog, so I can log in and see what is going on? you can mail details to futtta at gmail dot com.

  12. futtta
    Member
    Plugin Author

    Posted 1 year ago #

    OK, quick recap of what we discovered for anyone who would stumble on this post;

    • wp donottrack was not active in the admin-pages (for the tech-heads; no output buffering in wp-admin). i'll fix this with a release today/ tomorrow
    • the quantcast tracking was triggered by jetpack notifications, which loads an iframe from jetpack.wordpress.com, which in turn contains the quantcast tracking code. you'll have to manually disable jetpack notifications to stop this, as wp donottrack cannot act on the content of iframes.

    a general remark about jetpack; i'm glad i don't use it myself, it's pretty invasive.

    thanks iltrev for posting & helping out!

    frank

  13. iltrev
    Member
    Posted 1 year ago #

    Thank you, it's been a pleasure helping out (and being helped)

  14. futtta
    Member
    Plugin Author

    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic