WordPress.org

Ready to get started?Download WordPress

Forums

CubePoints Buddypress Integration
CubePoints Buddypress Integration stopped working after buddypress upgrade (26 posts)

  1. rlcarbo
    Member
    Posted 1 year ago #

    I upgraded buddypress to 1.7 and CubePoints Buddypress Integration stopped working. When you go to any of the points pages (sitewide points, users points, or legend) you get a page not found error. I tried deactivating everything including CubePoints Buddypress Integration and the core cubepoints plugin and reactivating but nothing worked. Points seem to be adding fine (ie points were added for creating a new group)

    http://wordpress.org/extend/plugins/cubepoints-buddypress-integration/

  2. chriscurran
    Member
    Posted 1 year ago #

    I'm experiencing the same issues! Hopefully a fix will be out soon? Users on my site can spend their points so the statement is essential.

  3. rlcarbo
    Member
    Posted 1 year ago #

    I had to push my install back to 1.6.5 and everything is working again

  4. chriscurran
    Member
    Posted 1 year ago #

    Can you provide instructions on how to push install back?

  5. farvgnugn
    Member
    Posted 1 year ago #

    Hey - not sure if it'll work for you, but i had a similar issue - the cube points showed up in the admin bar, but i got a 404 when i clicked the link and the "Points" menu was gone from my profiles.

    This is how i fixed it:

    Open bp-cubepoint-core.php

    Go to line 44, it originally looks like this:

    global $bp, $wpdb;
    
    	$bp->cubepoint->id = 'cubepoint';
    	$bp->cubepoint->table_name = $wpdb->base_prefix . 'cubepoints';
    	$bp->cubepoint->table_name = $wpdb->prefix . 'cubepoints';

    change it to this:

    global $bp, $wpdb;
    
    	//The following 3 lines fix the 1.7 upgrade
    	if( !is_object( $bp->cubepoint ) ) {
    		 $bp->cubepoint = new stdClass;
    	}	
    
    	$bp->cubepoint->id = 'cubepoint';
    	$bp->cubepoint->table_name = $wpdb->base_prefix . 'cubepoints';
    	$bp->cubepoint->table_name = $wpdb->prefix . 'cubepoints';

    I haven't noticed any other errors since I made that change. Hope it helps.

  6. rlcarbo
    Member
    Posted 1 year ago #

    farvgnugn that worked perfectly THANK YOU

    chriscurran - I had a backup of my site that I pulled down to restore 1.6.5

    If you have the 1.6.5 download, delete 1.7 and re-install 1.6.5 or just apply farvgnugn's fix, it worked great

  7. funmi omoba
    Member
    Posted 1 year ago #

    @farvgnugn,
    Thanks so much, your code fixed it for me too

  8. marksayers
    Member
    Posted 1 year ago #

    Thanks farvgnugn, that worked a treat!

  9. koreancandy
    Member
    Posted 1 year ago #

    Thank you that worked beautifully :)

    I'm having an issue with the intergration still though. When I change any of the amount I wish the members to gain or get taken from their account, nothing changes, it just stays as the default.

    For example, I have changed it so members gain 50 points to their account when creating a group, however it stays as the default and gives the members 100 points instead. I changed it so that members get 15 points taken away when joining a group, but instead it takes away 30.

    Is anyone else having this issue?

  10. leonalion
    Member
    Posted 1 year ago #

    Thank you, farvgnugn! your code fixed it for me too!

  11. otaibia_traveler
    Member
    Posted 1 year ago #

    Thanks farvgnugn , it is working , but not compatible with catch box theme , it seems there is a problem as the side bar is appearing below the points logs , and things are untidy, any help ??

  12. GSJ
    Member
    Posted 1 year ago #

    Hi, thanks that code helped, but I am finding that for Awards, it is always showing at least 1 Award available and 1 Award earned, even when no Awards have been created?
    When I do create an Award it shows as 2 Awards available and earned.

  13. AutomatedKid
    Member
    Posted 1 year ago #

    @farvgnugn ditto w others, ur mod worked just as u described. thank you!

    if others r wondering, i'm using..
    bp 1.7.1
    bbpress 2.3.1
    wp 3.5.1
    cubepoints 3.2.1
    cpbi 1.9.8.9
    mu setup

    can anyone answer a few questions?

    1. how do i get the points to show in the bp profile area? it's blank for me.

    2. would anyone be willing to share a site link to show how a more developed site looks like using the points system and bp?

    thanks, and special thanks to farvgnugn for the fix.

  14. interglobalmedia
    Member
    Posted 1 year ago #

    @farvgnugn you so rock. it worked beautifully for me too! thanks so much for sharing!

  15. interglobalmedia
    Member
    Posted 1 year ago #

    @Automated Kid I have a pretty good setup, but my only problem right now is that only one page of my point history is showing up on my profile (I use the BuddyBoss theme, so that might have a bit to do with it), and the total points don't show up in the profile nav menu, but they show up where all my other info is because of the BuddyBoss theme. I'm trying to figure out which code would work to paginate my points history pages so I have more than one. I'll let everyone know if I come up with something.

    Maria

  16. AutomatedKid
    Member
    Posted 1 year ago #

    hey maria, thanks for the update! i've got it deactivated for the moment, still trying to put everything together, and might just use a widget if need be to show point activity even though it's not ideal. but i'll keep an eye out for ur next post. :)

    btw, how do u like the buddyboss theme? i'm still searching for a theme that shows more real estate when using the forums, cleaner look, and one that includes the ability to use it on a regular wp setup as well. bb only offers 1 theme, for bp only, which rules it out for me. still curious how u like it.

  17. interglobalmedia
    Member
    Posted 1 year ago #

    I have it deactivated at the moment too. I'm trying out Achievements, and so far so good. I have also just installed Buddystream because of Achievements, and so far have been able to post to Twitter, but will see what comes in to my side over the next couple of days. I also have Tweet Blender installed, and that takes up a lot of activity energy, so I'll see what happens. Like that one too much to deactivate (TB).

  18. AutomatedKid
    Member
    Posted 1 year ago #

    @interglobalmedia - if u remember, please post back on how achievements works out for you. paul is pretty active w/ the plugin, so issues like with cubepoints probably won't happen at all. if not, i wish u luck and i'll probably see u over at the threads in the next few weeks or so.

  19. interglobalmedia
    Member
    Posted 1 year ago #

    Definitely!

  20. twoelevenjay
    Member
    Posted 1 year ago #

    @farvgnugn

    Thank you your code fixed this for me as well and saved me from hours of a needle/haystack adventure.

  21. hkcharlie
    Member
    Posted 1 year ago #

    Holy Goly - good job.
    Can I ask if anyone else finds that the Donate module is not working ?

    BTW - @farvgnugn - Thank YOU!

  22. xbladerunner
    Member
    Posted 1 year ago #

    @farvgnugn, thanks for the code fix, worked perfect! Needs to be in the next update...

  23. interglobalmedia
    Member
    Posted 12 months ago #

    farvgnun, you are brilliant! Thanks so much for the code fix! it now is working beautifully, and I'm on BP 1.7.3!

  24. wilfil
    Member
    Posted 6 months ago #

    Thanks farvgnugn

    This fix to Cubepoints works a charm - be nice to see the plugin updated at some point

  25. ddart
    Member
    Posted 6 months ago #

    Here in this thread I have given all the code that corrects these errors ust find my post below >
    http://wordpress.org/support/topic/warning-creating-default-object-from-empty-value-9?replies=13#post-5037825

    Regards :)

  26. jsgrenon
    Member
    Posted 5 months ago #

    Thanks a lot it's work perfectly!!!!!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.