WordPress.org

Ready to get started?Download WordPress

Forums

Ninja Forms
.csv not displaying properly (27 posts)

  1. madebytincans
    Member
    Posted 11 months ago #

    When sending the completed email to the admin, I have the option to send the .csv checked. However the .csv only contains a date.

    If I view the submissions and download the .csv it displays fine. (Although it could be better formatted. If there's a way to do this please let me know.)

    Using v 2.2.3.

    Thanks

    http://wordpress.org/extend/plugins/ninja-forms/

  2. James Laws
    The WP Ninjas
    Plugin Author

    Posted 11 months ago #

    Thanks foe the heads up. We'll try and reproduce and report back.

    As far as formatting I'm not sure what you mean. It's a comma separated list which are devoid of formatting. If you would like to clarify we'd be happy to hear any suggestions.

  3. madebytincans
    Member
    Posted 11 months ago #

    Thanks for the fast reply. I can see that you guys have excellent support.

    As for the formatting it was simple a request from a client. No worries on that one as I assumed it's out of the plugin's control.

    Again, many thanks!

  4. James Laws
    The WP Ninjas
    Plugin Author

    Posted 11 months ago #

    You are very welcome. As soon as we track the CSV issue down we will report back. Thanks for using Ninja Forms. :)

  5. Kevin Stover
    The WP Ninjas
    Plugin Author

    Posted 11 months ago #

    I've done some testing with version 2.2.3, and I can't recreate the issue you're experiencing. Could you shoot me an email with an export of the form you're using? my email is kevin@wpninjas.com.

  6. madebytincans
    Member
    Posted 11 months ago #

    Will do, thanks.

  7. Kevin Stover
    The WP Ninjas
    Plugin Author

    Posted 11 months ago #

    Just tested out your form on our server, and I get the CSV file populated with all the field data in my email. What version of Ninja Forms are you using?

  8. madebytincans
    Member
    Posted 11 months ago #

    Thanks for testing that.

    I'm using version 2.2.3. Also using the Layout & Styles addon if that matters.

    Tried it on a different form on the site as well and I just get a .csv with the date in the first field only. I'll try reinstalling the plugin. Unless you have other suggestions? Could this be a server issue? permissions? Current setup is in a subdomain on a testing environment.

  9. Kevin Stover
    The WP Ninjas
    Plugin Author

    Posted 11 months ago #

    I'm not sure what's going on there. There shouldn't be any server settings that would cause that. If you export an individual CSV file, does it download correctly?

  10. madebytincans
    Member
    Posted 11 months ago #

    Yeah if I go to submissions and download it it's perfect.

    Let me disable other plugins and try some other stuff. If you have any other suggestions throw them my way. Thanks for your help!

  11. madebytincans
    Member
    Posted 11 months ago #

    No luck with disabling other plugins. If I do figure out what the deal was in my situation I'll share it here to hopefully help others in the future. Having the .csv on submit isn't a deal breaker for this one so I'm okay with that. I'll be reinstalling WP and all plugins when this site goes live so maybe that will help.

    Love the plugin and your support is great!

  12. Kevin Stover
    The WP Ninjas
    Plugin Author

    Posted 11 months ago #

    Thanks. I'm sorry that isn't working for you. I honestly don't know what would change on the server to make CSV output not work. The same function is called when you download a CSV file directly, so I don't have many ideas. :\

    If you do find something out, please let me know!

  13. madebytincans
    Member
    Posted 11 months ago #

    Update: New install of WordPress, fresh database, new install of plugin, imported my form and still just a .csv file with only the date. Even tried it on a new form. So the only things that remained the same are the server.

    Question, could this have anything to do with my php.ini file? I edited it to make it work for my longer form as stated on your forums. Used this:

    ; increasing max input for ninja forms
    max_input_vars = 10000

    No clue why I can't get this going. Will try a new server soon.

  14. madebytincans
    Member
    Posted 11 months ago #

    Further information: Tested on a different server. New WP setup, new plugin install, new form. Nothing from the old server/site. Same issue.

    I get the same .csv file that only contains one field with the date in it.

    The only common link is it's the same hosting company which is Media Temple. https://www.mediatemple.net/

  15. madebytincans
    Member
    Posted 10 months ago #

    Update:

    I tested this on a non MT hosting account and it works fine. I'm really unsure why the hosting company would matter, or if that's even the issue, but it works.

    So while I hope this isn't an issue that others come across. It is an issue that I can't figure out why it's not working. So to reiterate:

    Server 1 (MT Hosting): .csv contained in email with date only
    Server 2 (MT hosting, fresh blank WP and plugin install): same issue
    Server 3 (non MT hosting, existing blog been up for years): works fine.

    Hopefully this feedback will help you guys determine the issue?

  16. James Laws
    The WP Ninjas
    Plugin Author

    Posted 10 months ago #

    I wonder if you could reach out to mediatemple and explain the issue if they could offer some insight from their server perspective. Although I agree, I can't think of why the server would cause this issue right off.

  17. madebytincans
    Member
    Posted 10 months ago #

    Just got off of chat with them. They seemed puzzled as well.

    They suggested this: https://kb.mediatemple.net/questions/151/MIME+Types Which didn't work.

  18. amarzka
    Member
    Posted 10 months ago #

    I'm using Dreamhost as my webhost and having the same issue.

  19. madebytincans
    Member
    Posted 10 months ago #

    Hmm perhaps it has nothing to do with hosting then.

  20. Kevin Stover
    The WP Ninjas
    Plugin Author

    Posted 10 months ago #

    Hey guys,

    I haven't been able to find any reason for this behaviour. The oddest thing is that it works when you click to download manually, but not when it attempts to email the CSV file.

    The only difference between the two methods is that the emailing saves a temporary copy of the CSV file to your server's tmp directory. Perhaps the server isn't allowing this to be accessed?

    If the same exact code works on one host, but not another, then it has to be some kind of server setting that's causing the problem.

    In the next week or so, I'll make some changes and see if they affect anything in relation to where it saves the CSV file temporarily.

  21. madebytincans
    Member
    Posted 10 months ago #

    Thanks Kevin, sorry for the weird issue and thank you for your help. If you can think of anything that we might be able to test just let us know.

  22. BrenFM
    Member
    Posted 10 months ago #

    I can confirm I'm having exactly the same issue on a dedicated server with Hostgator.

    I am only using the csv as a backup as one admin user tells me they are not getting a full report of ALL fields - but I'm thinking that is likely to be their ISP rather than your plugin as myself and the two other admins say they can see all the fields in their copy of the email.

  23. madebytincans
    Member
    Posted 10 months ago #

    I reinstalled on yet another server and the .csv isn't working.

    @BrenFM, that's an interesting thought, but I check the same email address on my computer when I tried my tests.

    @amarzka, Dreamhost is actually one of the servers I tried where it DID work for me. MT servers as well as Network Solutions servers both didn't work for me. Although I'm thinking this isn't a server issue....but how knows.

    FYI, I've also tested different email addresses which doesn't seem to matter either.

  24. roumpos
    Member
    Posted 10 months ago #

    Hi Guys,

    I am actually having the same problem. We use Crucial Hosting in Australia.

    The CSV file in the email only contains the date.

    When I download the CSV from within WordPress it works fine :S

    Additional the CSV file in the email is typically 40bytes but when I download the file within wordpess it is 900bytes.

    I look forward to your response :)

    Cheers

    Dimi

    *Just to add I'm using Version 2.2.9 + Ninja Forms - Layout & Styles

  25. roumpos
    Member
    Posted 10 months ago #

    Hi Guys,

    Just wondering if there's an update on this?

    Cheers

    Dimi

  26. madebytincans
    Member
    Posted 10 months ago #

    No word yet roumpos, however I did see that they prefer contacting them here:

    http://wpninjas.com/members/support/

    An update from my testing. I did a test on yet another server and it did not work. No clue why it worked on the 1 server and not the others.

  27. James Laws
    The WP Ninjas
    Plugin Author

    Posted 10 months ago #

    Just doing some quick housecleaning. If you are looking for assistance from us, the creators of Ninja Forms, please read this thread about how we handle support on our own site and not here.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.