WordPress.org

Ready to get started?Download WordPress

Forums

CSS stylesheet admin.css not working in firefox - weird output (30 posts)

  1. onlyyourspiyu
    Member
    Posted 4 years ago #

    Hello,

    I have installed wordpress earlier and I know the steps but have never faced this sort of an issue. Its a firefox based issue. WordPress has been installed at todaylending.com/blog

    The blog and everything else workd fine except the admin panel. The admin panel when opened in firefox comes all broken up and it seems the styles have not been applied at all.

    You can have a look at the screenshot here:
    http://www.todaylending.com/blog/firefox-wpadmin.jpg

    The admin panel works fine in IE and Chrome. Only firefox is creating issues. I have tried installing it twice but to no success. The screenshot is of a basic installation without any extra themes or plugins installed. Please help me out with this issue at the earliest.

    Thanks in advance.

  2. Samuel B
    moderator
    Posted 4 years ago #

    try disabling the admin plugin as it's messing with you

  3. onlyyourspiyu
    Member
    Posted 4 years ago #

    admin plugin? which one is that? Currently I have the default installation with no plugins installed or activated.

  4. Samuel B
    moderator
    Posted 4 years ago #

    my apologies
    the screen shot looked like the Oz admin plugin
    try re uploading the /wp-admin folder

  5. onlyyourspiyu
    Member
    Posted 4 years ago #

    Tried that. Deleted and re-uploaded /wp-admin folder, no luck!

  6. onlyyourspiyu
    Member
    Posted 4 years ago #

    Any help guys? :|

  7. Carolina Vigna-Maru
    Member
    Posted 4 years ago #

    Having the same problem with several wordpress 2.8.4 installs, only in Firefox. I've upload and re-uploaded, reinstalled, deleted the whole thing and uploaded again and still the same problem.

    http://twitpic.com/gub4n

    Help?

  8. henkholland
    Member
    Posted 4 years ago #

    What versions are you on? WP 2.8.4 and FF 3.5.2 are no problem for me.

  9. henkholland
    Member
    Posted 4 years ago #

    Was'nt there something about a Firefox addon that screwed up? Sorry, I am pressed so use the search.

  10. Carolina Vigna-Maru
    Member
    Posted 4 years ago #

    I've used the search. No results in WordPress.org, google, and so on.
    And no, it's screwed up in several different installations of firefox (reports from different authors of same blog).
    It is an actual problem and it doesn't have a solution yet.
    Any help welcome. It is not a plugin problem (I've disabled them all to test) and it is not an addon problem (several authors with different firefoxes).
    PLEASE HELP!

  11. remus007
    Member
    Posted 4 years ago #

    I have the same problem as described above, need also help! PLEASE

  12. Carolina Vigna-Maru
    Member
    Posted 4 years ago #

    samboll, are you there?

    please help!

    It still looks weird. I've reinstalled WP, disabled plugins and addons... I'm willing to try anything. I hate explorer and it's not working on Firefox.

    Can't find related posts, forum answers, tech blogs, nothing on google.

    samboll, anyone?

  13. eljlstudio
    Member
    Posted 4 years ago #

    I am having the same problem in both Firefox and Safari. Any one come up with a solution yet? I've re-installed three times (full and just the wp-admin folder), but it has made no difference.

  14. eljlstudio
    Member
    Posted 4 years ago #

    I even went back to Firefox 3.0 and it is still messed up. It must be an actual WordPress error.

  15. eljlstudio
    Member
    Posted 4 years ago #

    Okay, so I think I fixed the problem. Here is my fix:

    1. Go to the wp-Admin folder and open up admin-header.php.

    2. Look for the following tags:

    <head>
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php echo get_option('blog_charset'); ?>" />

    3. Directly after the close of the meta tag place the following:

    <link rel="stylesheet" type="text/css" href="css/dashboard.css" />
    <link rel="stylesheet" type="text/css" href="css/global.css" />
    <link rel="stylesheet" type="text/css" href="css/farbtastic.css" />
    <link rel="stylesheet" type="text/css" href="css/media.css" />
    <link rel="stylesheet" type="text/css" href="css/theme-editor.css" />
    <link rel="stylesheet" type="text/css" href="css/widgets.css" />
    <link rel="stylesheet" type="text/css" href="css/plugin-install.css" />
    <link rel="stylesheet" type="text/css" href="css/theme-editor.css" />
    <link rel="stylesheet" type="text/css" href="css/theme-install.css" />
    <link rel="stylesheet" type="text/css" href="wp-admin.css" />

    All this is doing is circumventing the code that's supposed to be pulling in and placing the css links automatically.

    Please note: THIS IS A HACK, but it seems to work. Please feel free to add on to this or make adjustments as needed.

    Hopefully this will be properly fixed at some point soon, but in the meantime...

  16. s_ha_dum
    Member
    Posted 4 years ago #

    I can't duplicate this and I've got FF on six different machines running three different OSes. I've noticed FF to be very picky about stray characters in stylesheets. Other than the hack eljlstudio posted, have any of you edited the admin stylesheet?

  17. Samuel B
    moderator
    Posted 4 years ago #

    hmmm...seems my reply above has disappeared

    I, also, can not reproduce this

  18. eljlstudio
    Member
    Posted 4 years ago #

    Well, my hack, it appears, is not the complete wonder solution I thought it was. While it does fix the issues of formatting the admin screens, there are several panels/functions in the screens that do not appear to work (i.e. adding new categories and tags to posts).

    I am not sure if these were pre-existing problems (although, I tend to think so as all I adjusted was the way the styles were accessed), but they are there now. I am starting to wonder if there is some type of incompatibility between the latest version of WordPress and the PHP version that is running on my hosts server.

    I will be upgrading to 2.8.4 on another site I have that lives on a different hosting service to see if the problems continue on that installation.

  19. Peter A. Gebhardt
    Member
    Posted 4 years ago #

    The same problem here. WP 2.8.4 & FF 3.5.3 not honoring @import together with PHP-URI.

    Provider 1&1 (Germany) reports spurious issues like mentioned here with other websites as well, but refuses to acknowledge beeing the culprit.

    All websites I maintain run fine in Opera 9.64 & IE8 - BUT also show same Problem with Opera 10.00

    Tried recommended HTACCESS hacks like:

    AddType text/css .css

    to no avail. Still head-banging ...

  20. Peter A. Gebhardt
    Member
    Posted 4 years ago #

    Solution found - but no explanation. Maybe someone more knowledgeable in the .htaccess area may be able to shed some light on this behaviour.

    http://gallery.menalto.com/node/27061

    Put a line into yout .htacces file (or create one if not already there):

    ../yourdomain/wp_yours/.htaccess
    
    AddType text/css .css

    Tested: Changing Permalinks (with WP editing this .htaccess) won't change this setting.

    Adding this line to ../yourdomain/.htaccess did NOT work.

    To check if your WP site is recognized properly afterwards, use:

    http://browsershots.org/

  21. tenganmade
    Member
    Posted 4 years ago #

    Hello

    I'm using WPMU 2.8.6 and I've found that the source of the problem for me was compression of the output.

    The quickfix: comment out lines 140-149 in /wp-admin/load-styles.php.

    /*if ( $compress && ! ini_get('zlib.output_compression') && 'ob_gzhandler' != ini_get('output_handler') ) {
    	header('Vary: Accept-Encoding'); // Handle proxies
    	if ( false !== strpos( strtolower($_SERVER['HTTP_ACCEPT_ENCODING']), 'deflate') && function_exists('gzdeflate') && ! $force_gzip ) {
    		header('Content-Encoding: deflate');
    		$out = gzdeflate( $out, 3 );
    	} elseif ( false !== strpos( strtolower($_SERVER['HTTP_ACCEPT_ENCODING']), 'gzip') && function_exists('gzencode') ) {
    		header('Content-Encoding: gzip');
    		$out = gzencode( $out, 3 );
    	}
    }*/

    By commenting out line 8 Firefox gives an error of faulty compression.
    //error_reporting(0);

    My ZLib in PHP should be workning but something goes wrong here. So this is the correct fix for me.

  22. tenganmade
    Member
    Posted 4 years ago #

    The same of course applies to /wp-admin/load-scripts.php.

    Comment out lines 130-139 to get the JavaScript for the admin pages working.

    /*if ( $compress && ! ini_get('zlib.output_compression') && 'ob_gzhandler' != ini_get('output_handler') ) {
    	header('Vary: Accept-Encoding'); // Handle proxies
    	if ( false !== strpos( strtolower($_SERVER['HTTP_ACCEPT_ENCODING']), 'deflate') && function_exists('gzdeflate') && ! $force_gzip ) {
    		header('Content-Encoding: deflate');
    		$out = gzdeflate( $out, 3 );
    	} elseif ( false !== strpos( strtolower($_SERVER['HTTP_ACCEPT_ENCODING']), 'gzip') && function_exists('gzencode') ) {
    		header('Content-Encoding: gzip');
    		$out = gzencode( $out, 3 );
    	}
    }*/
  23. PJ Brunet
    Member
    Posted 4 years ago #

    Same problem here.

    I don't think editing admin-header.php is a real solution either.

  24. PJ Brunet
    Member
    Posted 4 years ago #

    OK, this fixed it for me.

    Add this line to wp-config.php

    define('SCRIPT_DEBUG', true);

  25. VampiricPadraig
    Member
    Posted 4 years ago #

    @KnowingArt_com

    THANK YOU! THANK YOU! THANK YOU!!!

    *hugs*

    I have been searching around the web to fix this for EVER!! I am happy to be a WordPresser ^^;

  26. Stuckster
    Member
    Posted 4 years ago #

    Thanks for the solution (yet to be tested)

    Just thought I would say that this problem is not exclusive to Firefox. Was happening concurrently on Firefox and Chrome for me. IE untested cause I hate using it for dev work :0

  27. Stuckster
    Member
    Posted 4 years ago #

    THANK YOU
    Totally fixed on both FF and Chrome.

    Happy :)

  28. meerablu
    Member
    Posted 4 years ago #

    THANK YOU EVERYONE... i was almost on verge on tears last night... could not solve the issue.. I presume i was hacked... the wordpress folder had files all changed ... so now it is also fixed...

    thank you !!!! you are the hero
    i used your code eljlstudio :0 :)

  29. Lakoswolf
    Member
    Posted 4 years ago #

    @ KnowingArt_com THANKS A TON!

  30. Gary Eckstein
    Member
    Posted 4 years ago #

    What worked for me was creating a .htaccess file in the root and adding the below to the newly created .htaccess (the .htaccess script/instructions as below is used for canonical but seems to help with this CSS issue):

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

Topic Closed

This topic has been closed to new replies.

About this Topic