WordPress.org

Ready to get started?Download WordPress

Forums

CSS not being applied (5 posts)

  1. craigtb
    Member
    Posted 4 years ago #

    Hi all,

    I am new to creating wordpress themes. I have created a layout and in the progress of testing and such I put the code to display posts where my content will be placed but when i go to activate it the css is not applied to the page and it all it shows is the fake links i have placed and the posts. You can see it better by going to my blog (www.auburn.edu/~bridgct/clientside/wordpress). Any idea how to make the CSS get applied and what not? Technically its supposed to look something like this http://auburn.edu/~bridgct/clientside/wordpress/wp-content/themes/project/layout.html

    Any help is greatly appriciated.

    Thanks

  2. s_ha_dum
    Member
    Posted 4 years ago #

    Relative links are peculiar in WordPress. Use bloginfo('stylesheet_url '); instead of the relative link. Here is the codex page for the function.

  3. craigtb
    Member
    Posted 4 years ago #

    Do you mean like <link href="<? bloginfo('style.css'); ?>" rel="stylesheet" type="text/css" /> ? If so that still did not work.

  4. muthukswamy
    Member
    Posted 4 years ago #

    Use this:
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />

  5. craigtb
    Member
    Posted 4 years ago #

    awesome! that did it, thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.