WordPress.org

Ready to get started?Download WordPress

Forums

CSS Edit page Redirects to Home page (6 posts)

  1. ravenousravendesign
    Member
    Posted 3 years ago #

    When I use the Appearance editor in the admin panel I am redirected to the home page of my blog as soon as I press save. This has never happened before and of course its very frustrating because it doesn't even save any code I have added to the css document.

    I did some research in the forums and found this older question from a user. Same Question from 2009

    Due to what I read there, I think it may have to do with the WordPress Firewall 2 Plugin as well because I also installed it. I also get an email from firewall plugin after I save the file. If this is the problem, how do I fix it?

  2. David
    Member
    Posted 3 years ago #

    I've had that problem with that plugin, if you whitelist your ip in the firewall settings it will work fine. Get your ip address here if you don't know it whatsmyip.org/

  3. ravenousravendesign
    Member
    Posted 3 years ago #

    Well, I just tried that and i get the following error while trying to put in my IP. I tried adding quotes around my IP and that didn't work. uhuhuhuh. Thanks for the help by the way ^_^

    Error
    Warning: unserialize() expects parameter 1 to be string, array given in /home/content/27/7849927/html/wp-content/plugins/wordpress-firewall-2/wordpress-firewall-2.php on line 567

  4. David
    Member
    Posted 3 years ago #

    you can contact the developer directly, when I had my issue I emailed him, it took about a week but when he got back to me he seemed happy to get some feedback as he is anxious to work out any bugs

  5. ravenousravendesign
    Member
    Posted 3 years ago #

    Oh, I did that already. I directed him to this topic. Thanks a lot for your help ^_^

  6. pavy
    Member
    Posted 3 years ago #

    Hi,

    I'm not familiar with this error, and I haven't been able to reproduce it. I also reviewed the question from 2009, but I'm afraid that wasn't much help.

    First, ensure that your IP is in fact whitelisted. Navigate to the WFF2 settings page, and check to see that your IP is in two places: 1. it should be saved in one of the text boxes (it should show up there whenever you navigate to this page) and 2. it should match your current IP, which is seen at the bottom of the Whitelisted IPs section.

    Also, could you forward me the warning email you receive when this happens? It'll help me figure out what's going on. (see my email)

Topic Closed

This topic has been closed to new replies.

About this Topic