WordPress.org

Ready to get started?Download WordPress

Forums

Css Color Code : Confused (6 posts)

  1. derblauereiter
    Member
    Posted 7 years ago #

    Hello. Thank you for taking the time to read this.

    I have a k2 blog at http://halcyonrealms.com

    I understand that the triple Hex color code ie #XXX is a shorthand form of the 6 color version, so black would be defined as #000 instead of #000000.

    So my question is this : My background color ( the main body of my blog ) is black, and I have been trying to figure out where the attributes are defined in my style.css but I can't for the life of me figure where ( #000 ) that is.

    Any help would be greatly appreciated. Thank you so much.

  2. Bull3t
    Member
    Posted 7 years ago #

    Black and white can also be written in a stylesheet as the word, as opposed to the Hex colour code. I would advise that you search for "black" in the style.css file and see if you find anything.

    What part of your blog are you looking to change? I may be able to guide you on how to change the colour.

    After taking a look at the code of your blog, I noticed straight away that you are using the Vader scheme. This means that anything that sets your blogs colours will now be inside:

    http://halcyonrealms.com/wp-content/themes/k2/styles/hrealms/vader.css

    As well as your main K2 stylesheet. I would suggest you check for the colour in there aswell.

    If you are looking to change the page background colour then edit the file above (from your FTP client) and search for:

    body {
    	background: #111;
    	color: #bbb;
    	margin: 0;
    	}

    Change "#111" to any Hex colour you wish.

    Or if you are looking to change the content background colour then search for:

    #page, ul.menu li.current_page_item a, ul.menu li.current_page_item a:hover {
    	background: black;
    	}

    Change "black" to any Hex colour you wish.

    I hope this helps you.
    Bull3t

  3. derblauereiter
    Member
    Posted 7 years ago #

    Hello Bull3t and thank you for your fast reply. I have searched for the word "black" in my style.css file but it doesn't seem to exist.

    I would like to change ( or rather, understand where the attributes are defined ) the background colour for my main body ( main content, basically the entire block that follows the header image ) and sidebar, right now both are black.

    Thank you so much for taking the time to read this.

  4. Bull3t
    Member
    Posted 7 years ago #

    Okay, I was in the proccess of editing my post as you were replying, so re-read my post and you will see that I have now explained how to change the entire content block.

    I am heading to school now, so I will post my next reply at about 15:30 GMT (if you need one).

  5. derblauereiter
    Member
    Posted 7 years ago #

    Hello and thank you so much for your detailed explanation. I have followed your instructions and have been able to change the colors successfully. I was under the impression that all the style properties were defined in one style.css and had completely overlooked vader.css.

    I have 2 more questions actually, if you you don't mind;

    The first one is actually a following up from above :

    Is there a specific reason for having 2 css files ? Doesn't breaking up the css file into 2 parts entail more work during customization and make things confusing ?

    My 2nd question is about the alignment of text in my archives page : Right now the top text ( which basically explains how a reader can access the archives ) is aligned in the center ( I would like it aligned left ) and looks really ugly. I have tried searching for the text attribute which defines this both in style.css and archives.php, but can't seem to find anything that I can use to edit it.

    Thank you once again for your invaluable help.

  6. Bull3t
    Member
    Posted 7 years ago #

    I am glad that I could help you.

    1st question: The reason your blog has two stylesheets is because you (or someone else that has administrator access to your blog) has set the scheme for K2 to Vader, not to worry though as this is simple to fix.

    Head over to your WordPress Dashboard (on your blog) go to Presentation > K2 Options, scroll down to where it says Custom Scheme and select No Scheme from the dropdown menu. This will now remove the second stylesheet (meaning that you will have to make edits to the main K2 stylesheet in order to acheive the colour scheme you want or re-enable it.

    2nd question: Not sure why your text should be aligned in the centre, but it does not seem to be for me (if I am looking at the right page: http://halcyonrealms.com/k2archives/). Not sure whether that is the case though.

    Good luck.

Topic Closed

This topic has been closed to new replies.

About this Topic