WordPress.org

Ready to get started?Download WordPress

Forums

Oxygen
CSS changes not showing up (19 posts)

  1. Gabi123
    Member
    Posted 1 year ago #

    Hi,

    I am making changes to my CSS and I dont think they are showing up. I was able to edit it before. I have a child theme and I want to change the .wrap to white. When I inspect the elements and mess with them in chrome the changes show up so I'm not sure why they wont on my own CSS.

    Any thoughts?

    Thanks!

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Sounds like maybe you have a syntax or other error in your CSS - try validating it -

    http://jigsaw.w3.org/css-validator/

  3. Gabi123
    Member
    Posted 1 year ago #

    Sorry I'm new to CSS. Does that mean that the CSS im using isnt correct. When I enter it into the validator it says error, but I'm not sure what would be wrong with it. Here is what I am using below. Thanks for your help!

    .wrap {
    background-color: white;
    margin: 0 auto;
    max-width: 940px;
    padding: 0 30px;
    position: relative;
    }

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    That CSS is okay, some other error may be interfering with that working. Unfortunately, it's really quite impossible to help with CSS without seeing the site live - can you post a link to your site?

  5. Gabi123
    Member
    Posted 1 year ago #

    http://rawdenimmag.com/

    basically i want a white background behind all my content infront of the tiled image.
    Thanks again!

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Can you take down "coming soon" for a few minutes ;)?

  7. Gabi123
    Member
    Posted 1 year ago #

    I used to have a coming soon page up and I just took it down so you can see but It looks like its still up. I'm not sure why that is either?

    ...sorry about that.

  8. Gabi123
    Member
    Posted 1 year ago #

    It was a plugin that I just uninstalled.

  9. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Still up - looks like you have SuperCache enabled - which may also be why CSS changes aren't working :). Clear that or deactivate it while you are working on the site.

  10. Gabi123
    Member
    Posted 1 year ago #

    hmm not sure why it is still showing up. Would you recommend I delete the plug in all together? Or does it sometimes take awhile to show the changes?

    thanks

  11. Gabi123
    Member
    Posted 1 year ago #

    O! ok sorry for so many on going questions...

    I clicked the delete Cache button but that didnt seem to do anything. Is there something else I should do to clear it?

    thanks

  12. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Try deactivating both those plugins.

  13. Gabi123
    Member
    Posted 1 year ago #

    That doesn't seem to be working?

    i found these directions. Would you recommend trying all this?

    To manually uninstall:

    Turn off caching on the plugin settings page and clear the cache.
    Deactivate the plugin on the plugins page.
    Remove the WP_CACHE define from wp-config.php. It looks like define( 'WP_CACHE', true );
    Remove the Super Cache mod_rewrite rules from your .htaccess file.
    Remove the files wp-content/advanced-cache.php and wp-content/wp-cache-config.php
    Remove the directory wp-content/cache/
    Remove the directory wp-super-cache from your plugins directory.

  14. Gabi123
    Member
    Posted 1 year ago #

    Actually I can't even find those files on my hostserver... so nevermind.

  15. addisonw13
    Member
    Posted 1 year ago #

    Make sure you clear your browser's cache also. Some of the visual adjustments may be made by the function.php script that does certain image sizing and other things. Try adding a post after you make changes so things the scripts are rerun on the new content.

  16. Gabi123
    Member
    Posted 1 year ago #

    YES! It's working. thank you thank you!

    One last question. What good does the SuperCache plug in do? And since i deleted it if I have this problem in the future should I just clear my browsers cache.

    Thank you again!

  17. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Leave SuperCache off while you are working on your site. Then yes, you can just clear it when you make a change or post something. Clearing your browser cache does not affect SuperCache.

  18. Gabi123
    Member
    Posted 1 year ago #

    ok wonderful. You've been so helpful! thanks.

  19. kaiserawilum
    Member
    Posted 5 months ago #

    I had a similar problem.

    I de-activated SuperCache, but whenever I checked the cache directory on the wp server it kept showing up. If I remove it physically, the next I accessed to the web it showed the changes but only that, and the cache directory was, again, created.

    The solution:

    • FIRST activate the SuperCache plugin;
    • SECOND switch off the SuperCache (in settings>SuperCache);
    • THIRD de-activate the supercache plugion (in plugins)

    Hope this helps!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic