WordPress.org

Ready to get started?Download WordPress

Forums

CommentLuv
Cryptic error about problem contacting API URL (6 posts)

  1. Ken
    Member
    Posted 2 years ago #

    Commentluv 2.9.7

    Logged in to site, viewing a post and preparing a comment, un-check and recheck the commentluv box and I see the following cryptic error:

    It appears that you are offline or another error occured contacting the API url, have you set it to use www or missed the www off the api url?? check the technical settings and add or remove www from the api url.

    Turns out I see the same error when not logged in and I enter a URL in the website field to comment. There's briefly an activity graphic that appears above the commentluv badge and then the message above.

    Aside: This error appears to be for the admin but is presented to the blog reader and is very unhelpful to them. This message really should be made more appropriate for the blog reader given the context in which it is displayed. But back to the problem at hand...

    I've reset settings with no effect. I'm using a multi-site config and the API url appears to be correct.

    I did just notice the following error in the server log which I believe is not related to this issue. It is a problem for a site that wishes to lock down directory access though for security purposes:

    Directory index forbidden by Options directive: /var/www/html/wp-content/plugins/commentluv/images/, referer: http://no-shortcuts.qwkxen.pumastudios.com/wp-admin/options-general.php?page=commentluv-options

    Looking for errors related to the API access that is being attempted, I only find a successful entry:

    "POST /wp-admin/admin-ajax.php HTTP/1.1" 200 33 "http://no-shortcuts.com/2011/06/27/orange-ginger-curd/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1"

  2. Andy Bailey
    Member
    Plugin Author

    Posted 2 years ago #

    this error happens when your site is using www but the settings have set the API url (which is in your wp-admin directory) to not use www

    eg.

    if your site is set to use http://www.site.com and the API url (found in the technical settings of the commentluv settings page) is using http://site.com/wp-admin/admin-ajax.php then you need to change the API url so it has www (http://www.site.com/wp-admin/admin-ajax.php)

    or - if your site is set to NOT use WWW but the api url IS using www then you need to take the www bit off the api url.

    that's what the

    check the technical settings and add or remove www from the api url.
    means

    your error log relating to directory index forbidden just means that someone or something (a bot maybe) tried to access that file but couldn't (which is correct)

  3. Ken
    Member
    Posted 2 years ago #

    Have you tested this plugin in a multi-site config? I've been doing some research this morning and I think the AJAX problem is related to the redirection of admin pages using the domain mapping plugin. Haven't confirmed yet. There's a forum article discussing the handling of admin-ajax.php.

    Regarding the error log about directory index, I'm pretty confident these messages correlated to when I was using the commentluv admin screen. The referrer URL indicates that the access is not from a bot but from the admin screen for commentluv. It appeared that the plugin is doing a directory lookup to find the available images. Or maybe there's a coding error that is causing images src to not be completed. I'll have to re-test to see if it still appears and will open a new issue if it does.

  4. Ken
    Member
    Posted 2 years ago #

    The directory index issue might be related to this:

    fixed : default image display in settings page was not showing after resetting settings

  5. TourAbsurd
    Member
    Posted 2 years ago #

    I'm having this issue and it doesn't matter what URL (with or without the www) is entered. Happens on other sites I visit, too, again with a message that seems aimed at the site admin rather than the user.

    Have to check and uncheck on several sites. Sometimes works, sometimes get the error. I suppose it's possible my URL has been blocked for some reason, but the inconsistency leads me to believe it could be a version issue with the plugin.

  6. Andy Bailey
    Member
    Plugin Author

    Posted 2 years ago #

    if you're having an issue with your url then it is best to let me know what your url is and where you're seeing the problem so I go there and try and replicate it.

    without your url and the urls to the sites you're having a problem on then it is very difficult to diagnose what the problem is.

    please submit a support ticket at http://support.commentluv.com , I don't check these forums often

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags