WordPress.org

Ready to get started?Download WordPress

Forums

Cross Browser Trouble, IE versus Firefox (18 posts)

  1. modestkate
    Member
    Posted 5 years ago #

    Hello! I am just starting out with wordpress. I designed my blog using Firefox and of course thought everything was fine, before I found out about cross-browser compatability. Yikes! Can anyone explain to me what steps I should take in order to make my site (http://www.areyoumodest.com) display more correctly in IE? I think it's mostly just the title that is showing up incorrectly, as well as some white-space issues. Also I just tried using validator.w3.org, and it says that I have a few errors but it looks as though they may mostly be pertaining to the same area - I am just a little confused as to how to go about fixing them correctly and whether or not this will change how it shows up in IE, or if it is just incorrect code that I should fix no matter what.

    (I did search the forums about this before posting, but I feel that I still need it explained a little bit better before attempting to mess with all my code.)

    Sorry for being such a beginner at this, but i am certainly trying to learn! Thanks for any help in advance.

  2. whooami
    Member
    Posted 5 years ago #

    Can anyone explain to me what steps I should take in order to make my site (http://www.areyoumodest.com) display more correctly in IE?

    step 1: validate

  3. modestkate
    Member
    Posted 5 years ago #

    Okay! everything is all validated. It still is not showing up correctly in Safari or IE though. Any ideas or suggestions?

  4. modestkate
    Member
    Posted 5 years ago #

    actually, now that its all validated its even a little screwy in FF. there are some strange spaces in between posts, and my widget on the left is just showing a link instead of an image. eek!

  5. whooami
    Member
    Posted 5 years ago #

    the validation issues/fixes probably have nothing to do with that image. Look at the source:

    <a href="http://ffffound.com/image/b80600ea2219ab532be35b0dca4fa15ff4a3a248" title="Olle Hemmendorff’s Nike Air Max 90 Burger – today and tomorrow"><img src="b80600ea2219ab532be35b0dca4fa15ff4a3a248_xs.jpg" alt="Olle Hemmendorff’s Nike Air Max 90 Burger – today and tomorrow"></a></li>

    Now according to what i just pasted, that image is right here:

    http://areyoumodest.com/b80600ea2219ab532be35b0dca4fa15ff4a3a248_xs.jpg

    what do you see? I certainly dont see the image in the associated url -- the sandwhich shoe.

    as far as anything else being 'off' your site is so minimalistic, its really hard to see problems. Youre probably going to to need to dumb it down and explain in detail for those of us that dont know it as well as you.

  6. DavidEllzey
    Member
    Posted 5 years ago #

    I appear to have a similar Firefox/IE issue. It was created in Firefox and look great in that browser. However when opened in IE most of the site is blank.

    http://redgypsy.com/blog/

    Following whooami's advice I tried validator.w3.org but it came up with no errors. Assuming I used the tool correctly.

    Any ideas?

    Dave

  7. modestkate
    Member
    Posted 5 years ago #

    Thanks very much for your help so far, whooami. the image is showing up now, i changed something in the style sheet so it started working. however the problems that are occuring are that the title "modest" is much smaller than it should be, and "modern design" is supposed to be to the right of the title, with a small vertical line separating it. the other problem is that there should not be so much space in between the thin line beneath each post and where it has the post information, "posted at 7pm..." etc. There is also that strange square dot that's showing up, but I'm not as worried about that right now.

  8. modestkate
    Member
    Posted 5 years ago #

    Here is an image of the template i am using if it helps! (though there have been a few modifications so far) http://farm4.static.flickr.com/3020/2550658005_f375a2999d.jpg?v=0

    i am trying to revert my title back to something along those lines. im using the trial and error method but having no luck! thanks again.

  9. modestkate
    Member
    Posted 5 years ago #

    its still looking terrible in IE and not that great in safari. any ideas anybody? thank you!

  10. modestkate
    Member
    Posted 5 years ago #

    bump?

  11. modestkate
    Member
    Posted 5 years ago #

    bump bump

  12. modestkate
    Member
    Posted 5 years ago #

    bump bump bump? come on, anybody?

  13. iridiax
    Member
    Posted 5 years ago #

    What is this doing in your stylesheet???

    #header .inside{
    	padding: 3em 0px;
    }script src="js/jquery-1.2.6.min.js" type="text/javascript" charset="utf-8"></script>
    <script type="text/javascript" charset="utf-8">
    	$(function(){
    		$("#page-wrap").wrapInner("<table cellspacing='30'><tr>");
    		$post").wrap("<td>");
    	});
    </script>
  14. modestkate
    Member
    Posted 5 years ago #

    i have no idea!!! i dont even know what it means. should i remove it?

  15. modestkate
    Member
    Posted 5 years ago #

    bump again

  16. modestkate
    Member
    Posted 5 years ago #


  17. modestkate
    Member
    Posted 5 years ago #

    i really need help with this!

  18. iridiax
    Member
    Posted 5 years ago #

    You need to fix your code errors, especially the unclosed div tag (add a </div> where the div listed in the error should logically end).

Topic Closed

This topic has been closed to new replies.

About this Topic