WordPress.org

Ready to get started?Download WordPress

Forums

cropping featured image (11 posts)

  1. TSemmes
    Member
    Posted 10 months ago #

    When I place a featured image and want to control how it looks, don't I go to the Media Libray, select the image, click "Edit Image" then use the crop tool with Apply Changes to: Thumbnail applied? This doesn't work for me. Am I doing something wrong? I tried deleted and replacing the image but that doens't work either.

  2. esmi
    Forum Moderator
    Posted 10 months ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    What version of WordPress are you using?
    Always include as much information as possible

  3. TSemmes
    Member
    Posted 10 months ago #

    I am using the most recent version of WordPress. I tried switching to the default theme which did not make any difference.
    I see the correct thumbnail when I go into Media Library > Edit Image.
    Is it possible that a featured image and thumbnail are two different things?
    Is editing an image limited to a specific use?

    (SIDE NOTE: When I switched back to my theme, the custom CSS I had created for it was deleted along with my design work of several months. So I have bigger issues right now than Image Edit. But it would be nice to know. I have rarely been able to edit an image inside WordPress and have it work. And I have been working in WordPress for several years now. It mystifies me. )

  4. esmi
    Forum Moderator
    Posted 10 months ago #

    I tried switching to the default theme which did not make any difference.

    And the other steps suggested above?

    When I switched back to my theme, the custom CSS I had created for it was deleted along with my design work of several months.

    Where did you download this theme from? Any decent theme would have saved this in your site's database so that it was available on re-activation.

  5. TSemmes
    Member
    Posted 10 months ago #

    Esmi
    I haven't tried the other steps since I need to focus on getting my site back working again. Are you sure that these will work though? Do you know the answer to my question about whether edit image affects Featured Images.

    The theme was SCRN and was purchased at themeforest. Should have done a backup before I switched themes, I guess.

  6. esmi
    Forum Moderator
    Posted 10 months ago #

    There is no magic bullet in these situations. This is just the start of basic troubleshooting and is a process of elimination deliberately designed to locate the root cause as quickly as possible by first removing the most obvious and common culprits via a series of (often) temporary steps. Your theme & plugin settings are saved in your database and should be retained for future use.

    As you are using a commercial theme, I'm sorry but you need to seek support from the theme's developer/vendor. We do not support commercial products here.

  7. TSemmes
    Member
    Posted 10 months ago #

    Thanks for you help. I did not expect you to help support me issue with the theme. I was just sharing the situation I found myself in. I think what I will do is to do a test on a totally clean site using the default WordPress theme with no plugins and see if the situation is any different. Then I will post back here what I find.

  8. TSemmes
    Member
    Posted 10 months ago #

    I did a complete new installation of WordPress using the Twenty Thriteen theme.
    Added a feature to the sample page. The went to Media Library, selected the image, cropped it, saving crop to apply to thumbnail. Update image.
    The thumbnail in the media library changed.
    But the appearance of the feature image on the page does not.
    I tried again this time cropping the image to apply to all image sizes.
    Still no change.
    then went to sample page and deleted featured image and added it back again.
    Still no change

    Tried on several browsers and refreshing cache.

    Are you able to get this work yourself? If so can you tell me the exact steps you did that made it work?

    Here is the test page:
    http://test.tomsemmes.com/sample-page/

  9. 108graphics
    Member
    Posted 5 months ago #

    I have tried this feature on a number of sites and it does not work. It would be handy for galleries if it did.

  10. Ilovethesea
    Member
    Posted 4 months ago #

    After cropping, you will have to regenerate the thumbnail for this individual image.

    This plugin lets you do that: http://wordpress.org/plugins/regenerate-thumbnails/

  11. sandor.lrr
    Member
    Posted 1 week ago #

    a simple work-around that worked for me (20/11 theme):

    I can crop images I set on my homepage
    I cannot crop images I set for any other page
    To do:
    - add the image you want to the homepage and crop
    - select the original image for your homepage again
    - go to the page you want and select edit
    - tick the cropped image in the media library
    et voila!

Reply

You must log in to post.

About this Topic

Tags