WordPress.org

Ready to get started?Download WordPress

Forums

Crop-Thumbnails
[resolved] Crop-Thumbnails Settings gets a php error with WP 3.5 (3 posts)

  1. lellobot
    Member
    Posted 1 year ago #

    Hi,

    I'm using Version 0.7.2 of Crop Thumbnails with WordPress 3.5. I guess 3.5 isn't supported yet, but I've come across an error when trying to update the Sizes and Posttypes. It doesn't seem to matter which posttype or size I select, I'll still get this error.

    Warning: Invalid argument supplied for foreach() in /home/devallen/public_html/wp-content/plugins/crop-thumbnails/functions/settings.php on line 175

    Warning: Cannot modify header information - headers already sent by (output started at /home/devallen/public_html/wp-content/plugins/crop-thumbnails/functions/settings.php:175) in /home/devallen/public_html/wp-includes/pluggable.php on line 881

    Any suggestions?

    Thanks!

    Liz

    http://wordpress.org/extend/plugins/crop-thumbnails/

  2. Volkmar Kantor
    Member
    Plugin Author

    Posted 1 year ago #

    Hi lellobot,
    i am sorry to hear that. For the 0.7.2 i worked with warnings an notice disabled so i dont get these warnings. I promise to do it better next time.

    You may turn of debug in your wp_config.php and wait for the next version.
    Insert this code in your wp_config.php (or search if WP_DEBUG is set already and change 'true' to 'false').
    define('WP_DEBUG', false);

  3. lellobot
    Member
    Posted 1 year ago #

    The warnings seem to actually prevent the updates from being saved, so masking the errors might not be enough.

    However, it seems there are a few changes with wordpress 3.5, so perhaps one of these changes is causing these warnings?

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.