WordPress.org

Ready to get started?Download WordPress

Forums

FeedWordPress
[resolved] Cron not working? (10 posts)

  1. Insomniacs
    Member
    Posted 1 year ago #

    I followed the instructions included to set up a cron job using cpanel. The command is as follows:

    0**** /usr/bin/curl --silent http://mywebsite.com?update_feedwordpress=1

    cpanel is running the job (i checked with my webhost and they said it is running on the hour), but the feeds aren't updating. I still have to manually update, which means the feeds I'm following are coming in blocks, instead of nicely mixed up according to the date.

    do I need to change the /usr/bin/curl portion to match where the plugin is located?

    http://wordpress.org/extend/plugins/feedwordpress/

  2. Gurpreen
    Member
    Posted 1 year ago #

    I found a fix, instead of writing 0**** /usr/bin/curl --silent http://mywebsite.com?update_feedwordpress=1 in the command box,

    only write /usr/bin/curl --silent http://mywebsite.com?update_feedwordpress=1

    and for frequency you can change using "Common Settings"

    Let me know if this works!

  3. Insomniacs
    Member
    Posted 1 year ago #

    That's actually how I originally set it up. Still not doing what it's supposed to. The cron job is running, it just isn't doing anything.

  4. 3x7
    Member
    Posted 1 year ago #

    this works fine. Check your settings in the fwp, make sure it is set to manual.

    Gurpreen, would you know how to update all sites in multisite installation with one cron command?

    I have multiple sites but hosting provider allows only 2 cron commands...

    Thanks

    Cheers!

  5. Insomniacs
    Member
    Posted 1 year ago #

    Well it isn't working for me. It is set to cron or manual updates. Again, my webhost checked, the cron job is running every hour on the hour, it just isn't doing what it's supposed to do (ie update my feeds).

  6. 3x7
    Member
    Posted 1 year ago #

    it should be working... does it update if you click on the link provided in the settings... the link is ending with "update_feedwordpress=1"

    if it does, then it works, it is just the question why the link doesn't run with cron...

  7. Su
    Member
    Posted 1 year ago #

    Same here, across three separate WP installations.
    The cron job is running, and curl is functioning(fine with a different URL).

    Requesting the FeedWordPress update URL manually with curl at the command line results in a completely blank response(0 data transferred, etc.) and no new content pulled down.

  8. Insomniacs
    Member
    Posted 1 year ago #

    Clicking the link updates it, but the cron job still isn't running. My initial question still stands, do I need to edit the /usr/bin/cron portion of the command to something else?

  9. Insomniacs
    Member
    Posted 1 year ago #

    In case anyone was wondering, I FINALLY figured out how to get it to work in cpanel. Going to add it here, in case anyone has the same issue and needs some help.

    curl --user-agent USER_AGENT_NAME http://mywebsite.com?update_feedwordpress=1

    A list of User Agent names can be found here: http://www.useragentstring.com/pages/useragentstring.php

    For example, Chrome/29.0.1547.2, or Googlebot/2.1.

  10. lazyym
    Member
    Posted 10 months ago #

    Hostgator support solved this for me and mine appears to be working now.

    Add a forward slash behind the .com. Also make sure your time is formatted with the */ symbols before the number in cpanel.

    This command solved mine.

    /usr/bin/curl --silent http://yoursite.com/?update_feedwordpress=1

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic