WordPress.org

Ready to get started?Download WordPress

Forums

Postie
Cron job not working (24 posts)

  1. eveslage
    Member
    Posted 1 year ago #

    Hello,

    since a few days postie is not polling mails as before. I allways have to run postie manually. What is strange, i always get the message:

    "Succeeded in setting up cron task."

    When i open the postie settings dialog.

    Any ideas? How is the cron thing handled? through crond?

    i use wordpress 3.5.1 and postie 1.4.35.

    Thanks in advance
    Ingmar

    http://wordpress.org/extend/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    WordPress has its own cron. If your site doesn't get much traffic then WP cron doesn't run very often.
    See http://postieplugin.com/forcing-an-email-check/ if you want a guaranteed Postie check.

  3. eveslage
    Member
    Posted 1 year ago #

    i seams that postie is registering again and again as a wp cron job. and it didn't stick as a wp cron job. can i check anywhere, what is registered as a wp cron job?

    i use the local crond in the meantime. but the wp cron job was less intrusive. perhaps we get it working again.

  4. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    >it seams that postie is registering again and again as a wp cron job.

    Postie double checks from time to time to make sure it is registered with the wp cron.

    You can use a plugin like "Cron GUI" if you want to see what the wp cron is doing.

  5. tradeasy
    Member
    Posted 1 year ago #

    Have the same problem.
    My site has traffic, but still no cron seems to run since a couple of weeks.
    Cron View plugin does not show any job related to postie!!

  6. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    @tradeasy
    Does clicking "run postie" work? Does clicking "save" add the cron?

  7. tradeasy
    Member
    Posted 1 year ago #

    Manually run works,
    Saving does not add any job to cron

  8. eveslage
    Member
    Posted 1 year ago #

    Same here: Manually run works, but no wp cron job is visible.

    I think the Problems started since i updated BackWPup to Version 3.0. But this could be a coincident.

  9. eveslage
    Member
    Posted 1 year ago #

    The log file shows, when i open the config dialog:

    [Wed Mar 06 10:05:13 2013] [error] [client **] Postie: Failed to set up cron task., referer: http://**/wp-admin/options-general.php?page=postie/postie.php
    [Wed Mar 06 10:05:13 2013] [error] [client **] Postie: Succeeded in setting up cron task., referer: http://**/wp-admin/options-general.php?page=postie/postie.php

  10. astera
    Member
    Posted 1 year ago #

    Hello,

    same problem for me. Working since years with Postie but since 1.4.35 the automatic cron job is not working. Found another way to get all my mails in with plugin Run External Cron Settings.
    follow this cronjob article to know how it works.

    cheesr Astera

  11. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for all the reports. I have a couple of things that might help for the next release. However, please remember that Postie doesn't have any control over the WP cron, it just gets called when WP thinks it should.

  12. astera
    Member
    Posted 1 year ago #

    Hello Allen,

    did that fix in 1.4.36 resolve that problem?

    cheers Asterios

  13. eveslage
    Member
    Posted 1 year ago #

    Something changed. When i now enable the postie cron, there is no message "Succeeded in setting up cron task." anymore. Nothing happens and there is still no wp-cron entry.

    and i only find this in error.log
    [Fri Mar 08 12:10:06 2013] [error] [client **] Postie: Failed to set up cron task., referer: http://**/wp-admin/options-general.php?page=postie/postie.php
    [Fri Mar 08 12:10:07 2013] [error] [client **] Postie: Failed to set up cron task., referer: http://**/wp-admin/options-general.php?page=postie/postie.php

  14. astera
    Member
    Posted 1 year ago #

    Hello eveslage,

    what do you mean with:

    When i now enable the postie cron,

    Where do you enable this cron?

    cheers Astera

  15. eveslage
    Member
    Posted 1 year ago #

    I mean, in the posties settings dialog i set "check for mail every" to a value different than "check manually".

    then postie should setup a wp cron job. but nothing happens.

  16. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    @eveslage
    I assume you are using something like Cron GUI to view the cron settings, is that correct?

    I've been looking at the cron setup code a bit today and it is getting called way more than it should. Not sure if that is the issue, but I will be fixing that.

  17. eveslage
    Member
    Posted 1 year ago #

    yes, i used cron gui to look for planned wp cron jobs.

  18. roconnell@rwu.edu
    Member
    Posted 1 year ago #

    I am having a similar problem since the last update of WordPress 3.5.1.

    It is annoying and I'm getting complaints from the users of our curriculum website. The Postie app is used in a form that generates the email that gets posted to the site. There's no point in anyone testing this from outside because, unless you have an email address that is in the user base, no email generated post will get posted at the WordPress site.

    I see that there is an update to Postie... I hope this will solve the problem.

  19. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    roconnell@rwu.edu
    If you want to guarantee that Postie runs you need to use an external cron. See http://postieplugin.com/forcing-an-email-check/

  20. roconnell@rwu.edu
    Member
    Posted 1 year ago #

    I'll check on that, but I just installed the updated Postie and things appear to be working again.

  21. tradeasy
    Member
    Posted 1 year ago #

    Here's still not working, or even showing in cron jobs...

  22. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    @tradeasy
    I'd like to look at your system to see what is going on. If you are willing to do that please contact me at postie-help@devzing.com

  23. eveslage
    Member
    Posted 1 year ago #

    the latest version seams to fix the problem. thanks for repairing the problem.

  24. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    That is great!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.