WordPress.org

Ready to get started?Download WordPress

Forums

creating site description (3 posts)

  1. gfxtwin
    Member
    Posted 1 year ago #

    After launching my site and redirecting all of the 404 pages to the working main page, everything is pretty much great except that my site's description says this:

    "A description for this result is not available because of this site's robots.txt"

    How can I change this to a more acceptable description (something you'd expect from an official website, like "welcome to the official site for ________", etc.) ?

  2. singhnsk
    Member
    Posted 1 year ago #

    Well seems like you've hidden your posts from Search Engines. Otherwise WordPress always creates a description from the post's excerpt.

    Goto WP-Admin> Settings> Reading and uncheck the checkbox in front of Discourage search engines from indexing this site

  3. gfxtwin
    Member
    Posted 1 year ago #

    Hmmm. About 30 minutes ago I made it to where it allows search engines to index my site but I still get this description in google: "A description for this result is not available because of this site's robots.txt"

    Is it because more time is needed for google to index the site?

Topic Closed

This topic has been closed to new replies.

About this Topic