WordPress.org

Ready to get started?Download WordPress

Forums

JSON REST API (WP API)
Creating Posts on PHP-FCGI, Authentication doesn't work (2 posts)

  1. impuls-wa
    Member
    Posted 7 months ago #

    Hi,

    my Server runs PHP 5.3 over CGI. If i try to create a post, the userdata is not transferred into the $_SERVER Variable.
    I would like to use this ( http://www.besthostratings.com/articles/http-auth-php-cgi.html ), but i don't know how to apply it to the htaccess Rules that WordPress makes.

    Can you help me?

    http://wordpress.org/plugins/json-rest-api/

  2. tribalmixes
    Member
    Posted 2 months ago #

    thanks alot for this!! i spent maybe 2 days trying to figure out what is wrong with this plugin, then me, then several of my sites and hostings, and yes, all of them, apparently, use php as fast-cgi, and damnit....

    but thanks for this post, even that is never received any continuation. if you're still interested, i have applied it to the plugin and it works like a charm now!!

    all you need to do is edit .htaccess as it explains in that link you posted, and use one of suggestions that has "remove" in it.. or just try each one. and insert the code they give in class-wp-json-server.php around 100th line, in function check_authentication(), before the second empty return;

    OAuth, no matter how i tried, didn't work for me either... but that is a different story,,.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.