WordPress.org

Ready to get started?Download WordPress

Forums

SEO Ultimate
creating huge files in php error log (9 posts)

  1. Corey Ellis
    Member
    Posted 3 months ago #

    My client has this plugin installed and the 404 module is causing issues. It is trying to write huge lines to the db, which fail because they are so huge. As a result they are then added to the php error log which then grows out of control. We have disabled the 404 logging for now but would love to figure out how to fix this.

    https://wordpress.org/plugins/seo-ultimate/

  2. Jeffrey L. Smith
    Member
    Plugin Author

    Posted 3 months ago #

    Hi Corey:

    So, is it just the file that is the issue or are the genuine 404's in that magnitude that requiring redirects?

    Jeffrey

  3. Corey Ellis
    Member
    Posted 3 months ago #

    It doesn't appear as if the magnitude of the 404s are the issue but I could be wrong in that. But the issue was causing site performance issues because of the php error log file. It has grown to over 20 gb

  4. Jeffrey L. Smith
    Member
    Plugin Author

    Posted 3 months ago #

    We will look into this, but, I would check for other issues for the error log to determine what else could be generating this.

    Checking from our side.

    Best,

    Jeffrey

  5. Corey Ellis
    Member
    Posted 3 months ago #

    I'm more than willing to send you the error log. I have it zipped down to 235mb. Our sys admin is who reported the issue. when I disabled the 404 logging the php error log definitely stopped getting hit as hard.

  6. Jeffrey L. Smith
    Member
    Plugin Author

    Posted 3 months ago #

    At this time Corey that is not necessary, my suggestion is try to determine what other factors are contributing (e.g. updating all other plugins) or sequentially disabling them until you can isolate the issue.

    This is the first ticket of this nature, so, unless we can recreate, it's a variable of some component or combination of some script (which remains to be determined).

    Jeffrey

  7. Corey Ellis
    Member
    Posted 3 months ago #

    Hey Jeffrey. I have confirmed that turning off the 404 logging makes the problem go away.

    Here is the exact issue the sys admin reported. He has it narrowed down to this plugin:

    The SEO Ultimate plugin is having trouble with a 404, and the error message is so huge, the plugin could not save it's value into the WP database. So, instead that 404 error from SEO, turned into an error in PHP, so it's logging it to its logfile (php53_error.log). And that is happening *very* frequently.

    The SEO plugin has a setting for handling 404's and different types of them. Omar has unchecked a few options in the hopes that it will subside the types of errors causing the logs to fill up. I have no idea what the result will be.

    THE DIFFICULT QUESTION - What is SEO Ultimate trying to save to the database that is so huge. Looking at the php error log, it looks like SEO saves it's own log to the database and it got so huge, it won't work.

  8. NEdwards
    Member
    Posted 2 months ago #

    I just wanted to post here to bring some attention to this issue.

    It appears as though a site I've been working with experiences this as well. Each line of the PHP error_log is about 1mb... this adds up quick.

    I figure it is probably resulting from one specific URL that is 404ing, but has had 25546 hits. The url in question is a JS file linked in the head of the theme, so it logs a hit every time a page loads anywhere on the site.

    The data that the 404 plugin is trying to log to the database is probably inflated as a result of the numerous hits. Corey, if you actually check your 404 log page, are there any particular URLs that have had a significantly larger number of hits on them? This is just speculation, but I'm looking for situations that most people won't encounter, since it appears not many people are having this issue.

    In the meantime, I'll be resolving that specific URL (and leaving the 404 monitor turned on) to see if this will resolve the issue.

  9. BigDogSF
    Member
    Posted 2 months ago #

    I do not have the 404 module enabled. Here is the error code:

    [18-Jun-2014 04:55:48 UTC] PHP Warning: mktime() expects parameter 5 to be long, string given in /home/collecto/public_html/wp-content/plugins/seo-ultimate/modules/titles/titles.php on line 200

    It is coming from the titles module

Reply

You must log in to post.

About this Plugin

About this Topic