WordPress.org

Ready to get started?Download WordPress

Forums

create_users capability not working (6 posts)

  1. pabline
    Member
    Posted 3 years ago #

    Hi,

    I think I've discovered a bug in the 3.1 RC. If I add the various capabilities to create and manage users to a user role, the option to add a user doesn't appear in the left hand admin menu, but a the button does appear on the user listing page. However, when you click it you get the "You do not have sufficient permissions...." message.

    I'm adding these capabilities to the editor role and I can see that they're correctly in the wp_user_roles option in the database, so the problem must be when the capabilities are checked.

    I've used exactly the same code on a 3.04 installation and it works correctly, I think it's a bug. I'm happy to help fix it. Can anyone suggest a good place to start looking?

    Cheers,

    Paul.

  2. Which RC are you on? Can you upgrade to the latest SVN?

  3. hadyn
    Member
    Posted 3 years ago #

    I have the same problem here. I'm on the latest build, just installed it a few hours ago. I've customised my blog so that editors gain permission to create new users, which worked fine on previous releases of WordPress (ie 3.0.4) but has become broken after installing 3.1 (RC4).

  4. hadyn
    Member
    Posted 3 years ago #

    That may have been my mistake; the problem appears to have been with the "promote_users" permission, which I (apparently) hadn't enabled - or perhaps it became disabled when I upgraded. Regardless, setting that permission got the whole thing working for me.

  5. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

    promote_users was a new permission in 3.0. I'm checking to see if there are any inconsistencies with how we deal with the two permissions in the admin.

  6. Andrew Nacin
    Lead Developer
    Posted 3 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.