WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Create template page Twenty Eleven with no sidebar (9 posts)

  1. jojoheyns
    Member
    Posted 2 years ago #

    I am having some issues with twenty eleven.

    I have created a page template using a child theme for one page that requires no side bar.
    The other pages in our theme all require the sidebar and this works fine based on the layout option I have selected - content on the left.
    The page layout option (content on the left) is overriding the page template I have created and it is still adding a side bar to the page that I would like to display with no sidebar.

    Is there a set work around for creating new page templates in the twenty eleven theme?

    Thanks
    Jo

  2. alchymyth
    Forum Moderator
    Posted 2 years ago #

    in Twenty Eleven, pages don't have a sidebar by default;
    which alterations have you done to show the sidebar?
    does the new template have a line with 'get_sidebar()'?

    please paste the full code of your new template into a http://pastebin.com/ and post the link to it here, so someone might have a look...

    a link to your site might help to illustrate your problem.

  3. jojoheyns
    Member
    Posted 2 years ago #

    Thanks for your response. I cannot show you the site as I'm working on the template locally. I'm going to try articulate this as best I can. As the TwentyEleven theme currently stand you have a 'theme options' page under the appearance menu. On this page you are given three 'default layout' options: sidebar to left, sidebar to right or no sidebar. One of these options must be selected. This is ok if you want all your pages to appear the same. However, if you would like all your pages, bar one to have a sidebar, it gets tricky.

    For the page without the sidebar, I have created a template page. It uses the exact coding for a normal page but omits the get_sidebar() code. As far as I know, when you select this as your template under page>attributes>template this template should override the above mentioned page options. However, the opposite is true and the page still appears with the sidebar.

    I have also tried creating an empty second sidebar with it and used get_sidebar('2'). However this has not worked either.

    I hope this makes it clearer. Any help would be appreciated.

  4. alchymyth
    Forum Moderator
    Posted 2 years ago #

    are you referring to 'static pages' or web pages?

    wordpress has a very particular use of the word 'page' i.e. static page.

    as I said before, static pages do not have a sidebar, however, there is a page template available for a static page with sidebar.

    if you want to control index pages or archive pages, edit the corresponding templates; you will also need to add some code to functions.php to correst the body_class() which controls the layout.

    what child theme are you working with?

  5. jojoheyns
    Member
    Posted 2 years ago #

    Ok, I'm creating a template as such: http://codex.wordpress.org/Pages#Page_Templates

    I'm pretty much copying the index.php file

    and adding: Template Name: Bookings Template to the top

    I then omit: <?php get_sidebar(); ?>

    Once this is done, I can then select this template as my template of choice under page attributes alongside the 'Showcase Template' and the 'Sidebar Template'.

    However, the page STILL displays a sidebar. I figured this is down to the TwentyEleven 'Theme Options' under 'Appearance'. I cannot figure out how to stop the default layout options applying to this one page. Default Layout Options are found in the dashboard under Appearances>Theme Options. One can select one of three options: content on left, content on right, one column - no sidebar.

    So,all my pages are static pages. No blog page. All pages must have a sidebar except for this one specific page which I'd like to have just the content column.

    I hope this is understandable now.

  6. alchymyth
    Forum Moderator
    Posted 2 years ago #

    All pages must have a sidebar

    are you using the 'Sidebar Template' for all these pages?

    if not, how did you add the sidebar to all pages?

  7. jojoheyns
    Member
    Posted 2 years ago #

    I am using the sidebar template i.e. content on the left in the theme options.

  8. Solflux
    Member
    Posted 2 years ago #

    If the page you are using is set as your front page, you can edit the index.php template file to omit the sidebar.

    Having just done this myself, I can say that it works for certain. If it fails in all other instances, this may be your only choice.

  9. jojoheyns
    Member
    Posted 2 years ago #

    Thanks for your help @solflux & @alchymyth.
    In the end I changed the layout of the site.

Topic Closed

This topic has been closed to new replies.

About this Topic