WordPress.org

Ready to get started?Download WordPress

Forums

Events Made Easy
[resolved] Create RSS Feed (12 posts)

  1. jseth
    Member
    Posted 1 year ago #

    I have read the documentation for the RSS feed, and it does not make sense to me. Could someone please provide an example of what code I am supposed to use, and where I am supposed to put it? Sorry for my ignorance, but stating that eme_rss_link is a template tag and it takes the following parameters really isn't much help. Thank you for any help!

    http://wordpress.org/extend/plugins/events-made-easy/

  2. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    First, see the general doc at http://www.e-dynamics.be/wordpress/?cat=8
    Then, the doc about the rss link: http://www.e-dynamics.be/wordpress/?cat=35

    Now, to use it (as with any other wordpress shortcodes): just create a regular page and put the following in it:
    [events_rss_link]

    For the options, see the doc above. I included some examples in it now (like for most other shortcodes)

  3. jseth
    Member
    Posted 1 year ago #

    Awesome! Thank you for adding the examples for us less intuitive folks!

  4. jseth
    Member
    Posted 1 year ago #

    I created a regular page and put [events_rss_link limit=20] in it. I get the error message "Internet Explorer cannot display the page. This feed contains code errors". Is there something else that I need to do? The calendar and the eme widgets work fine.

    I would like to display the RSS feed from this calendar on another website but am not sure how that works. At this time I am just trying to get it to display on the same site on which the calendar is hosted. Thank you again.

  5. jseth
    Member
    Posted 1 year ago #

    In Firefox, it displays more helpful information. The error that appears is:
    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://www3.eastech.org/publicsite/?eme_rss=main&scope=this_month&order=ASC&category=&author=&contact_person=&limit=0&location_id=
    Line Number 3, Column 1:<?xml version='1.0'?>
    ^

  6. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    Hmmm ... according to your feed, 2 empty lines are included before the "<?xml" part starts. This causes the error.
    I'll look into the code ...

  7. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, it's your theme: if you take your main page http://www3.eastech.org/publicsite and look at the source code, you'll see 2 empty lines as well.
    Look at your theme to figure out where those empty lines come from and remove them.

  8. jseth
    Member
    Posted 1 year ago #

    I do see that. I'm using a child theme of Twenty Ten. I don't see two spaces in the header.php, but I'll keep looking around until I find it. Thanks so much for your help.

  9. Franky
    Member
    Plugin Author

    Posted 1 year ago #

    Which theme are you using? Maybe I can take a look as well.

  10. jseth
    Member
    Posted 1 year ago #

    I created a child theme from Twenty Ten. I activated the original Twenty Ten and there are no extra lines at the top of the page, so it must be something that I put in somewhere in the custom css, because when I try your rss link in the original Twenty Ten theme, it works, so it is my fault. I don't see anything in my header.css, but I'll compare the code until I find it. Thanks again.

  11. jseth
    Member
    Posted 1 year ago #

    Apparently I need to do some sleuthing... http://www.jacorre.com/tutorials/blank-line-top-of-html-for-wordpress/ describes the issue I'm having. Happy hunting!

  12. jseth
    Member
    Posted 1 year ago #

    Found it - I just went through all of my custom css files and closed up every space before and after every php tag, tried it again and it's all good now. Thank you again so very much for your replies and assistance.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.