WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[resolved] Create Database Backup has no effect - backup folder is set to 777 (17 posts)

  1. perryb
    Member
    Posted 1 year ago #

    I can't get the database backup option to work.

    If I click the backup button the page goes blank. No database backup is sent via email if the option is checked.

    The backup folder is set to chmod 777 and is currently empty.

    http://wordpress.org/extend/plugins/better-wp-security/

  2. Handoko
    Member
    Posted 1 year ago #

    Many users has reported fail to make the database backup feature works. The chances of success depends on many things like sizes, available memory, server settings. You can tried to search the forum for more informations.

  3. perryb
    Member
    Posted 1 year ago #

    That's a fair point, though I have checked.

    My php.ini and wp-config.php memory settings are all at the maximum. I can't find any clues in this forum about what other server settings I should look at.

  4. perryb
    Member
    Posted 1 year ago #

    I went and bumped my memory limit in php.ini from 128 to 500 and the database backup now works.

    Obviously needs a lot of juice!

  5. Handoko
    Member
    Posted 1 year ago #

    Not very sure, but if I'm not wrong some webhosts do not let users to configure memory limit. Yes, you can set it using php.ini but it has no effect.

    Many webhosts also have max script time, so if the total files you're going to backup is huge, it may fail to backup.

    I personally use BackUpWordPress plugin. It can backup files only, database only, or both. We also can set schedules for backup.

  6. chiron34
    Member
    Posted 11 months ago #

    Handoko,

    I have not received a copy of a database backup file for a few weeks now. I am using BWPS 3.4.10. The plugin still says that my last databae file was generated yesterday and the next will be created tomorrow, as expected. The files attached to an email just never turn up in my inbox.

    I just tried to manually create a database back up file and got this error message:

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/bizdocs/public_html/wp-content/plugins/better-wp-security/inc/backup.php on line 92

    I am a novice in the webdev field so I don't fully understand the implications of the error message. If this is in your area of expertise, I would appreciate some pointers as to how to fix this problem.

    As far as I can tell, other BWPS plugin functions seem to be working because I keep getting regular File Lockout Notices. But then these other functions may not be working properly. I don't know to check these other functions and there is no built-in self test.

    Lastly, from your experience, can I run both BackWPup and Better WP Security at the same time without any problems.

    I would like to commend you for the way you try to help people. I personally wonder why we bother to support the developer here, when there seems to a total lack of customer service on giving advice on the very basic BWPS operations. I actually posted this problem three months ago and am still waiting for a reply. It's probably on forum page 30 plus by now, so it will never be addressed.

    kind regards,

    chiron34.

    sincerely,

    chiron34

  7. Handoko
    Member
    Posted 11 months ago #

    You mentioned you haven't received your database backup. Did you mean from Better WP Security or BackUpWordPress?

    If you mean from Better WP Security, I only can say this backup feature sometimes doesn't work, it has been reported several times, and so far as I know it's still not fixed yet.

    Maximum execution time of 30 seconds ...
    It means just as what it said. Many web hostings especially shared hostings, set max time limit for process execution. The factors of your case, I guess: the total files (or sizes) of them is too huge so if your server has waited too long, it will fail. Or perhaps your web host set the limit too low, you might need to find other better webhost.

    My suggestion for the case above:
    - Try other backup plugin
    - Check the total files of them, if it's more than hundreds of MB, it mean your website is huge, you may need to backup it manually using cPanel or FTP
    - Ask your web host to set max execution time longer
    - Move to other better web host

    ... run both BackWPup and Better WP Security at the same time without any problems.
    Yes, you can. I'm using both of them together on a single site. No problem so far. You just need to make sure to disable the backup feature on Better WP Security.

    I personally wonder why we bother to support the developer here...
    They're nice, make a plugin and give it free. They did give good supports, but recently, the developer said they're busy doing something and planning to start a new better way for supports, paid support. If you browse the forum you will know, lots of new posts show up everyday. This plugin is really awesome. I like it, so I will come back to answers some questions every several days.

    I would appreciate some pointers as to how to fix this problem.
    I'm not a professional webmaster, but I like to build websites, solve problems and help others. If you have problems (even outside this plugin), I would like to help. You may email me if you want, I will be glad to have friends around the world. Someone ever asked me, how much he should pay me? Answer: zero. This world will be better if we're helping each other (www.kiva.org/lender/handoko).

  8. chiron34
    Member
    Posted 11 months ago #

    Handoko,

    Many thanks for your very useful and prompt reply. I do agree with your philosophy. I will get in touch outside of this forum. Perhaps there is some way that I can help you (and of course others).

    sincerely,

    chiron34

  9. szepe.viktor
    Member
    Posted 11 months ago #

    Please do some error checking in /inc/backup.php:117
    //save file
    //zip the file
    //delete .sql and keep zip

    ..those could go wrong

  10. chiron34
    Member
    Posted 11 months ago #

    szepe.viktor,

    Thanks for that info. I appreciate that you have taken the trouble to look at this problem for me. Unfortunately, my computer skill levels are not good enough to carry out these checks on my own. I really need a checklist to do tasks of this nature because I am over 70 years young (unkind people say 'old') and therefore, I was not brought up on a diet of computers and the 'interweb'.

    kind regards,

    chiron34

  11. Handoko
    Member
    Posted 11 months ago #

    Hello.

    I want to correct my previous post. I said I'm using Better WP Security + BackWPup. That was wrong, the truth is I'm using Better WP Security + BackUpWordPress.

    @chirion34:

    I will suggest to disable the backup feature of Better WP Security and use BackUpWordPress. Here is how to do it:

    1. Login to your website.
    2. Goto menu > Security > Database Backup.
    3. Disable the checkbox (Enable Scheduled Backups).
    4. Click the Save Changes button.
    5. Goto menu > Plugins > Add New.
    6. Type BackUpWordPress and press Enter.
    7. Install the plugin and activate it.
    8. Goto menu > Tools > Backups.
    9. There you can change the default settings or add new schedule.

    Somethings you may need to know:
    - The BackUpWordPress plugin can perform database and/or files backup.
    - Can set the backup using schedules or perform it manually.
    - It also allow users to set multiple schedules.
    - Multiple schedules often do not work correctly.
    - That is it will perform the backup not on the schedule but several times a day.

    Note:
    If you have schedule issues (multiple backups performed everyday), it can be fixed by deleting all the schedules and re-create the schedule, you may need to use only 1 schedule.

    Suggestion:
    I set the schedule: database only for everyday. And full backup (database and files) manually. In most cases, we don't need to do full backup too often, once a month is enough.

    @chiron34:
    But then these other functions may not be working properly.
    What other things that is not working properly? Please tell us, it (BetterWPSecurity) has too many features, we won't able to guess if you don't tell us.

  12. szepe.viktor
    Member
    Posted 11 months ago #

    chirion34,

    I've been posting that for the author.

    If you need WP help please call me on skype: szepe.viktor
    viktor@szepe.net

  13. chiron34
    Member
    Posted 11 months ago #

    Handoko,

    I followed your checklist. However, on BackupWordPress activation, I got this error message:

    BackUpWordPress has detected a problem. wp-cron.php is returning a 403 Forbidden response which could mean cron jobs aren't getting fired properly. BackUpWordPress relies on wp-cron to run scheduled back ups. See the FAQ for more details.

    I went to FAQ and got the following:

    What do I do if I get the wp-cron error message

    The issue is that your wp-cron.php is not returning a 200 response when hit with a http request originating from your own server, it could be several things, most of the time it's an issue with the server / site and not with BackUpWordPress.

    Some things you can test are.

    Are scheduled posts working? (They use wp-cron too).
    Are you hosted on Heart Internet? (wp-cron is known not to work with them).
    If you click manual backup does it work?
    Try adding define( 'ALTERNATE_WP_CRON', true ); to yourwp-config.php`, do automatic backups work?
    Is your site private (I.E. is it behind some kind of authentication, maintenance plugin, .htaccess) if so wp-cron won't work until you remove it, if you are and you temporarily remove the authentication, do backups start working?

    If you have tried all these then feel free to contact support.

    Info:

    Are scheduled posts working? <strong>I don't know yet. This is first activation. Have to wait 24 hours.</strong>
    Are you hosted on Heart Internet? (wp-cron is known not to work with them). <strong>No</strong>
    If you click manual backup does it work? <strong>I did two manual backups. The first was just after activation and resulted in the error message. After reading FAQ, I did another manual backup. The error message did not disappear. Please note the great disparity in size between the two database files, which I detail below.</strong>
    Try adding define( 'ALTERNATE_WP_CRON', true ); to yourwp-config.php`, do automatic backups work? I am presently not in a position to do this.
    Is your site private? No

    Backup Info:
    2 backups completed Size Type Actions
    May 13, 2013 - 9:37 PM 11 MB Database and Files Download | Delete
    May 13, 2013 - 9:30 PM 116 MB Database and Files Download | Delete

    It's now half an hour since I did the last manual backup, so I thought I would run it again. I did. The error message is still there but the file size is still 11 MB, the same as the 9.37 test. Could this be only a glitch problem somehow connected with the 116 MB reading for the first manual backup?

    Handoko, what can you suggest that I could do here? Should I just let it run for 24 hours and see what develops. In the meantime, I can download backup files from my Theme, which is what I have been doing for the recent past.

    Re: But then these other functions may not be working properly. What other things that is not working properly? Please tell us,

    I was not actually saying anything was wrong. I was simply saying that I did not have the knowledge to know if any of the other Better WP Security functions were working correctly or not.

    kind regards,

    chiron34

  14. Handoko
    Member
    Posted 11 months ago #

    BackUpWordPress has detected a problem ...

    I do use BackUpWordPress but I'm not very proficient about it. I suggest you to start a new post on their support forum.

    The only issue I have with BackUpWordPress is multiple schedules aren't working on the scheduled time. But it won't happen if it has only one single schedule.

    So far I haven't get any error message from BackUpWordPress, and the backups are working correctly, I know because I ever restored from the backups several times and all of them are good.

  15. chiron34
    Member
    Posted 11 months ago #

    Handoko,

    I was on the point of installing BackWPup as the alternative to BackUpWordPress when I noticed that Better WP Security had a plugin update ready to install. After I completed the install, I reset the backup configuration and guess what? The backup function is now working again. At least it has been working normally for a few days now.

    So lets hope that everything will be OK from now on. Better WP Security developers may have quietly sorted this problem without creating any controversy.

    chiron34

    [ Moderator note: E-mail redacted, support is offered via the forums and sharing e-mail addresses here is actively discouraged ]

  16. Handoko
    Member
    Posted 11 months ago #

    I've just sent you an email. I like to solve computer-related problems, you may contact me anytime if you have it, I will be glad to if you simply say hello for keeping in touch.

  17. epeclarke
    Member
    Posted 5 months ago #

    Better WP Security was recommended to me by a friend, spent some time setting it up on a new WP install and ran into the same issue with the Backup feature.

    Emails sent without a Backup attachment.
    And no backups being created within the Backup Folder when accessed through FTP.

    After researching a bit online my solution was to disable the emails feature on the Backups Tab of the Plugins settings.

    Notice the final setting of this feature reads,

    "Number of backup files to retain. Enter 0 to keep all files. Please note that this setting only applies if "Send Backups by Email" is not selected."

    I simply followed this instruction and disabled the
    "Send Backups by Email" Checkbox

    But still provided an email

    and finally entered 0 in the last box

    Now the backup files are being created at my set interval in the backups folder, which I can access through FTP.

    Not a full solution but hope this helps someone.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic