WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Crazy problem with character encoding. (9 posts)

  1. Richarley
    Member
    Posted 6 years ago #

    Hi! My name is Richarley and I'm from Brazil. I have a big problem now with my blog (that i was still working and making some tests before let people know about): http://www.underweb.com.br/richarley .

    I have been seeing a weird style in some texts of my page for a while, so after reading a bit from your docs about the "Reading Options SubPanel" I decided to try changing the page encoding format from utf-8 to utf-16, and everything gone crazy, with some crazy chinese like symbols and because of that I just can't change anything. My homepage and my admin panel are down now. I just tried to re-upload all my files, but the problem persists. I just don't know what i can do know...

    Please help me!

  2. moshu
    Member
    Posted 6 years ago #

    I have no idea where did you read to change it to utf-16. Don't mess with things you don't understand!

    Can you login? If you manually overwrite the charactyer encoding in your browser (View > Encoding) you can access the pages. Change it back immediately to utf-8.

    You can never change encoding on an existing blog!

  3. Richarley
    Member
    Posted 6 years ago #

    No, I can't login... everything is down! :(

  4. moshu
    Member
    Posted 6 years ago #

    The last option would be to go to your database via phpMyadmin and in the wp_options table (or whatever your prefix is) find the blog_charset row and edit it manually back to UTF-8.

  5. Richarley
    Member
    Posted 6 years ago #

    It worked!! But not on wp-options (that was ok, with UTF-8), but on richarley_options (where i found the blog_charset row with UTF-16). Thanks a lot!!

  6. moshu
    Member
    Posted 6 years ago #

    And when you edit your sidebar.php file make sure you save it with the right encoding (utf-8). Even Notepad has that option > Save As... look at the bottom.

    THAT is the reason you have crappy characters in your sidebar: it is always the user, not the script.

  7. Richarley
    Member
    Posted 6 years ago #

    Well, not everyone have to know about this encoding thing. Now that you said to me i just saved with the right encoding with Notepad, but this option doesn't appear to me using the dreamweaver. By the way, utf-8 is my default encoding there too, but to know that i had to see at the program preferences...

  8. moshu
    Member
    Posted 6 years ago #

    DW should be used only in code mode - otherwise it will screw up your WP files.

    (and I posted about saving the files with proper encoding zillion times...)

  9. Richarley
    Member
    Posted 6 years ago #

    Sorry, but today was the first time that i visited this forum... Well, at least you help me to solve my problem.

Topic Closed

This topic has been closed to new replies.

About this Topic