WordPress.org

Ready to get started?Download WordPress

Forums

Crazy memory problems on both WordPress photoblogs (4 posts)

  1. cityeyes
    Member
    Posted 1 year ago #

    I've been using WordPress for quite a while now. I can't pinpoint exactly when I started using it, but it's been at least since 2009 - probably earlier.

    I run two blogs, one here, which is specifically a photoblog - the other here - which is my words and photo blog.

    Ignore the fact that all of my images are gone on the word/photoblog. Those were unintentionally deleted somehow a bit back and I'm in the process of fixing it.

    Now, onto my problem.

    I am having insane memory spikes when using the admin console of both sites. My limit on shared hosting is 512 megs, which I feel should be sufficient for both sites, but I'm spiking past that regularly when I mess around in the admin panel. I don't seem to run into a problem while browsing the site regularly, but the problems become so bad when I'm editing my content or browsing the admin panel that I can barely get anything done.

    I first noticed the problem when I started getting error 500 pages when browsing my site and took it upon myself to clear out unnecessary plugins and test out different themes. Problem is, I'm down to Akismet and *only* akismet on both blogs and I've tried multiple themes on both to no avail - I'm still getting the spikes.

    Now, this wouldn't be such a pain if it were only happening occasionally, but the spikes have made it pretty much impossible for me to do anything involving the upload of photos to my photoblog (or anything, really - since hitting my memory limit causes php stuff to error out, I'm often left stuck on "edit" pages unable to click any buttons).

    I've been searching for solutions and trying them out myself pretty much all day to no avail. I also checked my error log - it pretty much just told me that stuff was giving me errors due to a lack of memory.

    Does anyone have any suggestions? This isn't somehow normal behavior, is it?

    Here are screenshots of my memory use graph as well as the memory spikes in my log - they happen much less when I'm not actively trying to do stuff in admin.

    First
    Second

  2. r3born
    Member
    Posted 1 year ago #

    I am having the same problem - when I update content or publish new stuff, crazy memory spikes. I'm on a VPS with 1 MB RAM limit.

  3. cityeyes
    Member
    Posted 1 year ago #

    Glad to see I'm not alone. It really is a pain.

    I should have taken notes on which version the problems started with.

    Edit: OK, I fixed *some* of my problems by switching to a more up-to-date theme. It's not screwing up as much, but it still seems to be spiking.

  4. cityeyes
    Member
    Posted 1 year ago #

    Ok, I spoke too soon. Getting internal server errors like mad even with the default theme and no plugins activated aside from Akismet.

    I'm literally the only person on the site right now and it's still regularly spiking to 512 megs.

Topic Closed

This topic has been closed to new replies.

About this Topic