WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Crazy long delay when I click write post/page WP 2.5 (34 posts)

  1. davidinjp
    Member
    Posted 6 years ago #

    Upgraded to v2.5 smoothly. Everything is real nice (even my non-embedded wpg2 stuff), image uploader works good etc.

    Problem is that every time I click to write (new) or edit a post or page, it takes like 2 minutes for the edit page (where you input text) to load. I tried deactivating ALL plugins, restarted apache, disabled xcache, but nothing seems to fix this problem.

    After 2 minute wait I am able to write the post as I normally would, but there is another 2 minute hang when I click Save. However, the post is updated right away (as seen in another browser) when I do click save, it's just the edit page itself has this two minute hanging problem...

    Any suggestions to try to resolve?

  2. Jeremy Clarke
    Member
    Posted 6 years ago #

    If you are using Firefox or some other browser with plugins, have you tried disabling those? It sounds like a problem with your browser rather than wordpress (since as you say it's only your browser that won't reload).

  3. ingejanse
    Member
    Posted 6 years ago #

    This might help. Maybe you have a lot of categories, which should be converted to tags.

  4. davidinjp
    Member
    Posted 6 years ago #

    It is a server side issue. Same behavior in ff, safari, and IE.

    ingejanse, I took a look at the thread you linked, but my sole remaining photography category only converts to create a new tag, but still remains a category. I can't actually get rid of the category. I was able to delete the "default" category, but not my "photography" category which was set as the default for new posts before I upgraded to 2.5.

    Also tried changing themes to classic and default... no impact. This is an odd one. I have no php or other other event errors. Strange because everything else in the UI is super fast...

  5. rpali
    Member
    Posted 6 years ago #

    I too experienced this problem. Within 24 hours of upgrading to 2.5, my site was so bogged down, I could barely log in, much less actually doanything. I was also informed by others that viewing the site was a hit or miss affair (mostly miss).

    I reverted to 2.3.3 and was stunned to see no difference in behaviour. A quick action on the part of my host had me back in business. They told me processes were not ending properly. I can't say for certain it was 2.5, though the problem started soon after I upgraded. Now that I've reverted, the problem hasn't returned.

    Along with the image upload problem, I'm content to stay with a working 2.3.3 install for a while longer, until fixes for these problems are rolled out.

  6. davidinjp
    Member
    Posted 6 years ago #

    rpali, we have different problems. The site and everything in the admin UI performs very well, except for the write/edit post action itself. No other problems.

  7. shetakaey
    Member
    Posted 6 years ago #

    @rpali: I have written my host three times this week, and the third just now with a quote from you. I hope they fix this, because I'm about to go nuts.

    Originally, you said reverting to 2.3.3 didn't help... so what did your host do to make reversion functional for you? Were they unable to provide assistance on version 2.5?

  8. davidinjp
    Member
    Posted 6 years ago #

    Hmm, tried a re-install, checked the database, scanned apache and php logs... still nothing... someone else must have run into this problem upgrading. Please let me know if you exist! :-)

  9. scaldwell74
    Member
    Posted 6 years ago #

    I have this same problem but no one seems to be able to fix it

  10. sabinou
    Member
    Posted 6 years ago #

    Same here, write/edit slow as hell (Mind you, the notes ARE posted/edited in seconds, but our confirmation takes 2 minutes).
    I noticed it with version 2.3.3, and upgrading to 2.5 didn't change anything.
    I also moved my database from my current mutualized host to a dedicated box host, courtesy of a friend using the dedi box, and that didn't change the problem.
    Running an optimization of the DB in phpmyadmin didn't change it either.

    I guess, guys, we will have to wait until a smart guy finds the solution :-/

  11. davidinjp
    Member
    Posted 6 years ago #

    For me it didn't happen until I upgraded to 2.5, so it's something that was triggered by 2.5 since nothing else changed.

    I also went through and manually diff'ed every file from my site against the full 2.5 WP install. Everything is as it should be. So somewhere there is an offending bit of code in the 2.5 files.

    I did some tracing and resource monitoring too. The long delay may be as simple as bad HTML or CSS. I confirm there is no database activity after the initial click. It's something in PHP or httpd is chocking, although everything shows zero resource utilization.

  12. sabinou
    Member
    Posted 6 years ago #

    Maybe my info can help, on my side the techies of my VPS account told me they took a look at the logs of my sql server, and there was no abnormal behaviour, no extreme consumption of resources.

    I also noticed that the problem is worse for some pages, I use the kgarchives plugin that replaces the archive page with a one-page list of ALL the posts (without excerpt, just the title and they are sorted by category) and that page may take now 10 minutes to load.

    I wish I could help more tracking the bug !

  13. sabinou
    Member
    Posted 6 years ago #

    By the way, the matter is also discussed on that other thread : http://wordpress.org/support/topic/164497?replies=13 . Sharing the info is important, please, if you finally find a solution here, be kind enough to talk about that on the other thread too :)

  14. davidinjp
    Member
    Posted 6 years ago #

    The other thread (http://wordpress.org/support/topic/164497?replies=13) is an entirely different problem from my own.

    Once again, the only problem I have is that my Edit/Write pages take forever to load. There is no impact on the rest of the site or visitors to the website.

  15. rpali
    Member
    Posted 6 years ago #

    shetakaey,

    What I did when I saw 2.3.3 was also having the same problem was open a support ticket with my host. Everything suddenly started working again and a few moments later I received a message that said, in part: "Your Apache processes weren't dying off correctly/normally but I don't know why. I've restarted your account and things are loading fine now." She specifically stated there was no issue with the database. It was strictly with Apache. Very strange...

    davidinjp,

    Sorry about the mix-up. What you described sounded familiar so I ran with it. Possibly part of the reason is I first noticed the problem when trying to edit/post a new item. Then the media viewer was affected, and it spread from there until nothing worked.

  16. davidinjp
    Member
    Posted 6 years ago #

    No problem rpali. I just hope I can find someone else with the same problem. I can usually fix any problem on my own so this one is driving me nuts!! :=)

  17. HarryRAR
    Member
    Posted 6 years ago #

    I've got what I assume is the same problem, though not quite as bad: the little blue box on the right with save/publish buttons appears quickly, and then it takes about 7 seconds for the editing box to appear.

    Another blog on a subdomain of the same server is working fine, so that suggests it's not down to server settings; it happens whether or not I choose to use the visual editor and with all plugins deactivated.

    There's this suggestion, but I don't think it applies to me:

    http://wordpress.org/support/topic/164276?replies=5

    Somewhere I read a suggestion that having lots of categories (which I do) slowed down 2.5 badly, and I suppose I could convert most of them to tags if I thought it would help, but actually I *like* having them hierarchical, so I'd rather not unless I absolutely have to. And it was working just fine in 2.3.3.

    So, I'm out of ideas.

  18. homme20
    Member
    Posted 6 years ago #

    I have the same problem, but on my work PC was fine... thought it might be a vista thing, but that didn't seem to pan out.

    Bit of trial and error, wasn't the network wasn't any plugins but then thought maybe it's the virus checker, I disabled the virus checker, and it went all quick again!

    Added my site to my Kaspersky trusted web safe and re-enabled and all is quick agian.

    Might not be a fix for everybody but solved mine :-)

  19. HarryRAR
    Member
    Posted 6 years ago #

    Just because I found it again: this is the person who found that changing categories to tags helped.

    http://wordpress.org/support/topic/164713?replies=3

    If I can't find another solution soon, I may try it myself, but I'm not thrilled by the prospect.

  20. sabinou
    Member
    Posted 6 years ago #

    I suppose this is related, but I tested an ssh access with "mysqladmin processlist "
    And, unlike the short list I had with WP 2.3, I had a very very veeeeeeeeeerrrrrry long list.

    Maybe WP 2.5 is simply managing its requests very badly and that's a huge load for the mysql server, hence a delay to reply ? ?

  21. davidinjp
    Member
    Posted 6 years ago #

    Still did not resolve this one. I have ruled out:

    Not browser, or client side. Tried 3 browsers on two PC's
    Not mysql, zero activity there
    not plugins, deactivated all
    not the categories to tags thing, converted already
    the action after clicking write/post is instant on the back-end, just not sending to the browser for two minutes later
    there is no server or client side cpu utilization during the delay, just a small spike from httpd.exe of a few percent on server just when the write/post page finally does load

    This is something screwy, thinking I need to blow it all away and try a fresh config and import back to db. If that doesn't fix it, I will roll back to earlier WP

  22. hallsey
    Member
    Posted 5 years ago #

    I'm having the same problem you're having except I'm using an old 1.5 version. Two other small exceptions are that I only experience the deal when saving a post, not when loading a post nor when starting a new article, and also that I don't get confirmation from the host in two minutes. I've left it sitting there for an hour, and the little IE world just spins and spins and spins...

    The problem is particular to this host, as WP installations I've set up on other hosts with the same exact set of WP files do not have this problem. I'm all but positive it's not a WP problem but something at the hosting end, but I was hoping to find out more before I try to take it up with the hosting company.

  23. HarryRAR
    Member
    Posted 5 years ago #

    I ended up giving in and reluctantly converted all my categories to tags, which completely sorted out the problem. I'm still irritated I had to do it, but at least it's working properly now.

  24. velvetblade
    Member
    Posted 5 years ago #

    Just like everyone else, I have the same problem and have tried to sort it out through my server provider.

    It only happens with the write/edit posts requests and nothing else. Also, sometimes it takes so long to post that I get a blank page at the end of publishing or saving, but my browser states it is done. When I check the blog, it is posted if I hit publish.

    I have tried four different browsers, so that is not the issue. Was told it is a back end issue.

    I don't have many categories, so I don't believe that to be the problem.

  25. hallsey
    Member
    Posted 5 years ago #

    I have one category (and one post), so I don't think that's the problem either. :)

  26. davidinjp
    Member
    Posted 5 years ago #

    Well, converting all my categories to tags did not help, but upgrading to version 2.51 finally did help. I'm only guessing that the db upgrade did not go well on the original upgrade to 2.5.

    So this problem is resolved for me.

  27. LydiaLeibs
    Member
    Posted 5 years ago #

    I am having this identical problem after upgrading to 2.5.1. After much trial and error I determined the following. The problem is definitely related to categories and importing from a previous blog. If I start with a new data base there is no problem at all writing and posting. Then when I import the posts,pages etc. from my old blog at wordpress.com, the writing of posts is a little laggy. (30 second load time). If I import a 2nd time (in order to update the latest post and comments), the lag time increases to 2 minutes. If I wait sufficiently long, I will get an error stating that a script in the program has stopped responding. If I stop the script and view the source of the page I see that the program is running in a loop checking a list of my categories over and over again. I can "fix" it by deleting the Sql DB and starting all over again with a single import.

  28. gumbah
    Member
    Posted 5 years ago #

    What helped for me was the following:

    I used the upgrade guide (http://codex.wordpress.org/Upgrading_WordPress) and forgot to copy and overwrite the wp-settings.php file.

    Everything worked fine except for the "write post/page" part being really slow. I found out that on that page there was some kind of ajax loop (constantly calling admin-ajax.php).

    So make sure you copy and overwrite the wp-settings.php file because it contains the following (crucial) code:

    if ( !defined( 'AUTOSAVE_INTERVAL' ) )
    define( 'AUTOSAVE_INTERVAL', 60 );

    (line 340 in wp-settings.php)

    Hope this helps some of you!

  29. eliesheva
    Member
    Posted 5 years ago #

    I tried all these suggestions and nothing. I have the same exact problem as the original poster (and some of the others) where it is only slow when I click write or I try to save or post.

    I just updated to 2.5.1 and tried the wp-settings.php fix. Tried to deactivate plugins.

  30. graysky
    Member
    Posted 5 years ago #

    I was having the same problem of slow posting/editing, but fast for everything else. The problem for me was the "Google XML Sitemaps" plugin which generates a sitemap for search engines. I could see that the MySQL changes were written quickly, but then my site would be frozen.

    The fix was to uncheck the various options to notify search engines like MSN, Yahoo and Ask. I think one of them wasn't responding quickly, and the plugin was taking a long time to timeout. I left Google checked (since they are where most search traffic comes from) and that is fine. Now it is back to very speedy edits/posts. I haven't gone back to determine which specific service is the culprit.

    And I didn't convert my categories to tags, and this is on 2.5.1.

Topic Closed

This topic has been closed to new replies.

About this Topic