WordPress.org

Ready to get started?Download WordPress

Forums

SimpleSecure
Crashes on Submit (4 posts)

  1. G-Force
    Member
    Posted 10 months ago #

    Hello, I like your plugin but I'm having trouble getting it to work. I have:
    - installed the WordPress plugin,
    - installed the GPG plugin for Apple Mail, and
    - generated the public GPG key and linked it to the email address used on my SimpleSecure form.

    But after populating the form and pressing the Submit button, I receive the following error messages:

    string too short, not a MPIstring too short, not a MPIstring too short, not a MPI
    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/content/22/10468122/html/staging/wp-content/plugins/simplesecure/libs/GPG/globals.php on line 118

    Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/content/22/10468122/html/staging/wp-content/plugins/simplesecure/libs/GPG/globals.php on line 257

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/content/22/10468122/html/staging/wp-content/plugins/simplesecure/libs/GPG/globals.php on line 323

    I'd appreciate any insights you may have on resolving this. Thanks.

    http://wordpress.org/plugins/simplesecure/

  2. moulin
    Member
    Posted 10 months ago #

    Hey guys,

    Just tested your pgp plugin.
    public key installed with correct email address
    page code set with same correct email address.

    Did 4 WP tests using native php mail.

    On two occasions Senders email address?? (two of my own) receives the encrypted email instead of the correct email address above.
    I could decrypt using the secret key that belongs to the installed key.
    On two occasions no encrypted mail was received the first time it was sent??

    1. Can you help?
    2. Are you contemplating visualizing the key before it is sent. This gives comfort to remote users.

    Thanks

    Philip

  3. Jason
    Member
    Plugin Author

    Posted 9 months ago #

    Hey g-force - can you tell me what version of PHP you're running? I just got that myself for the first time to on php 5.5.3. I'm wondering if it's a bug in the GPG lib introduced since version 5.5.x

    moulin - that bug is fixed in simplesecure 0.0.3

  4. Jason
    Member
    Plugin Author

    Posted 8 months ago #

    This should be fixed in 0.0.4, please try and let me thanks

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.