WordPress.org

Ready to get started?Download WordPress

Forums

CRASHED updating Responsive theme (10 posts)

  1. mervb01
    Member
    Posted 1 year ago #

    I've lost the website - can't even get in - still got CPanel - was updating 'Responsive Theme

    error Message:
    Warning: require(/home/mervynbe/public_html/wp-content/themes/responsive/includes/functions.php) [function.require]: failed to open stream: No such file or directory in /home/mervynbe/public_html/wp-content/themes/responsive/functions.php on line 12

    Fatal error: require() [function.require]: Failed opening required '/home/mervynbe/public_html/wp-content/themes/responsive/includes/functions.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mervynbe/public_html/wp-content/themes/responsive/functions.php on line 12

    I've got a backup from about a week back.

  2. danny_getextra
    Member
    Posted 1 year ago #

    You need to take the functions.php from your backup and overwrite it in the newly updated one.

    Thanks

  3. mervb01
    Member
    Posted 1 year ago #

    Renamed the old functions.php to OLDfunctions.php and uploaded functions.php from the backup - didn't work, but I think you might be on the right track - any other ideas?
    thanks

  4. mervb01
    Member
    Posted 1 year ago #

    Found it - there are a number of missing folder:

    icons
    images
    includes
    js
    js-dev

    I'll see if i can down load these

  5. danny_getextra
    Member
    Posted 1 year ago #

    great, replace these and your good :)

  6. mervb01
    Member
    Posted 1 year ago #

    OK i transfered the include folder and all is back working - thanks for the help

  7. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    Glad to hear that problem was solved and for the future references, please be kind and post directly in Responsive's Support Forum.

    Just a very quick look back at the issue.

    When updating a Theme, any of them not just Responsive, things like missing folder, files and/or images can happen if the server does not respond in time.

    By looking at http://www.mervynbeamishartist.com it seems that you're on a very slow one. I am on very high speed and it took me almost a minute to load the site and that's way too much.

    Better hosting will prevent this from happening. Also see.

    Thanks,
    Emil

  8. mervb01
    Member
    Posted 1 year ago #

    Thanks for that - I did also post directly in Responsive's Support Forum.

    Strange about the speed, I've never had that problem reported before and the Host is usually quite good - I'll pass your comments on to them.

  9. Emil Uzelac
    Theme Review Admin
    Posted 1 year ago #

    Sorry, I haven't seen the post, but you got it going on, so that's important. Reduce your images on front page, that will speed the process as well and thank you so much for being extra patient and for using Responsive Theme!

    Thanks,
    Emil

  10. mervb01
    Member
    Posted 1 year ago #

    Thanks for that tip :) scaled it down 50%

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags