WordPress.org

Ready to get started?Download WordPress

Forums

All in One Webmaster
Crashed after update to 9.1 on WP multisite (5 posts)

  1. durangod2
    Member
    Posted 5 months ago #

    Hi, i updated the plugin on my miltisite network and i got this message:

    all-in-one-webmaster/all-in-one-webmaster.php has been deactivated due to an error: Plugin file does not exist

    Please advise... thanks

    https://wordpress.org/plugins/all-in-one-webmaster/

  2. durangod2
    Member
    Posted 5 months ago #

    Update, i was able to activate it and i see no errors in cpanel log so i dont know what the issue was.

    However question, on a multi site setup when i use subfolders NOT subdomains, do i use the individual website google and bing verify codes or the main NET verify codes on all.

    The websites themselves have their own domains and their own verify codes, but the blog sites is all under one domain. So the url for each multisite install is mydomain/site1 mydomain/site2 mydomain/site3 so would i use their own verify or the verify for the mydomain?

  3. wallyO
    Member
    Posted 5 months ago #

    Sub-folder setup would only require (at a minimum) one verification code located in head of the domain.com page.
    This plugin puts THAT verification code on ALL pages of domain.com in a NON multi-site install.
    I am unsure of its behavior in a multi-site install.

    Plugin file does not exist error occurs due to the plugin file-name changing from
    all-in-one-webmaster.php
    to
    all-in-one-webmaster-premium.php
    Plugin with new file-name activates fine as you discovered.

    What I noticed was that the settings data (in my case google-site-verification) was not transferred from the old version of the plugin to the new version of the plugin.
    SO.....
    Before you update copy all your entered data to a text file somewhere so the you can reenter it into the new version of the plugin after the update.
    If like me, you have already updated, you can recover your old settings data by deactivating and deleting the new version, re-upload the old version then activate it.
    The data remains orphaned in the wp_options table and it repopulates the settings fields of the old version of the plugin.
    Copy all your settings data to a text file somewhere so the you can reenter it into the new version of the plugin after you update.
    I had done the update on a dozen sites before I realised that all the google-site-verification fields in the new version were blank.

  4. durangod2
    Member
    Posted 5 months ago #

    Thanks WallyO, great information. I got lucky i just happened to be logged into my cpanel so i just grabbed the google and msn verify codes from the header file i have for the actual website (not the blog) and posted them. Thanks for the quick reply and GREAT INFO...

  5. Arpit
    Member
    Plugin Author

    Posted 5 months ago #

    Thanks wallyO for your support.

    Hi durangod2 - hope all issues have been fix for you. Let me know if you need any help.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.