WordPress.org

Ready to get started?Download WordPress

Forums

Wordfence Security
Cpanle error logs shows Wordfence has MySQL warning (5 posts)

  1. Bluemad
    Member
    Posted 1 year ago #

    Hello!
    When I'm checking my cpanel error logs, I can see there are lot of MySQL warning.

    These are few warning.

    PHP Warning: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: User xxxx_xxx already has more than 'max_user_connections' active connections in /home3/xxxx/public_html/wp-content/plugins/wordfence/lib/wfDB.php on line 56 
    
    [01-Mar-2013 15:15:40] PHP Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home3/xxxx/public_html/wp-content/plugins/wordfence/lib/wfDB.php on line 57 
    
    [01-Mar-2013 15:15:40] PHP Warning: mysql_ping() expects parameter 1 to be resource, boolean given in /home3/xxxx/public_html/wp-content/plugins/wordfence/lib/wfDB.php on line 48 
    
    [01-Mar-2013 15:15:40] PHP Warning: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: User xxxx_xxx already has more than 'max_user_connections' active connections in /home3/xxxx/public_html/wp-content/plugins/wordfence/lib/wfDB.php on line 56 
    
    [01-Mar-2013 15:15:40] PHP Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home3/xxxx/public_html/wp-content/plugins/wordfence/lib/wfDB.php on line 57

    http://wordpress.org/extend/plugins/wordfence/

  2. morcom
    Member
    Posted 1 year ago #

    Me too -

  3. Gabe
    Member
    Posted 1 year ago #

    Similar issue here. Error logs are now 1.5GB from last few months...

    [10-Mar-2013 19:28:01] PHP Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/username/public_html/sitename-com/wp-content/plugins/wordfence/lib/wfDB.php on line 57
    [10-Mar-2013 19:28:01] PHP Warning: mysql_ping() expects parameter 1 to be resource, boolean given in /home/username/public_html/sitename-com/wp-content/plugins/wordfence/lib/wfDB.php on line 48
    [10-Mar-2013 19:28:01] PHP Warning: mysql_ping() expects parameter 1 to be resource, boolean given in /home/username/public_html/sitename-com/wp-content/plugins/wordfence/lib/wfDB.php on line 52
    [10-Mar-2013 19:28:01] PHP Warning: mysql_connect() [function.mysql-connect]: User username_dbuser already has more than 'max_user_connections' active connections in /home/username/public_html/sitename-com/wp-content/plugins/
    wordfence/lib/wfDB.php on line 56

  4. José Luís
    Member
    Posted 1 year ago #

    I'm having this issue too. Apart from that, great plugin!

  5. morcom
    Member
    Posted 1 year ago #

    I have found that since I took off the "Enable Live Traffic View" option I have not had the problem.
    Think it happened when I ran some seo link tests and sitemap generation at the specific website.
    So I conclude thaty it must be tied up with volume of work required for traffic viewing when the incoming traffic builds over a certain level.
    Good luck to all - I'm happy with what I have now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.