WordPress.org

Ready to get started?Download WordPress

Forums

Simple Share Buttons Adder
Counter not working (15 posts)

  1. vcolfari
    Member
    Posted 11 months ago #

    Absolutely love the look of these buttons but I can't seem to get the counters to display (particularly for FB and Twitter). They were visible recently but now they show "0". Any ideas?

    http://wordpress.org/plugins/simple-share-buttons-adder/

  2. vcolfari
    Member
    Posted 11 months ago #

    Would really love to use these, but can't get the counter to work. Problems with wordpress 3.6?

  3. vcolfari
    Member
    Posted 11 months ago #

    Well, for some reason, I reinstalled this plugin after a few days and all the counters are working. Not sure how that happened. I installed/reinstalled several times before and that had no effect. If anyone else has this problem, try installing again after some time and see if it helps :p

  4. dannyjimmy
    Member
    Posted 9 months ago #

    For me only google plus was working.

    http://pbrd.co/1cw4CGj

    (this was on a post that has had 300K views.)

    I'll give your solution a try after some time passes. Definitely weird.

    Anyone else had experience getting the post counts working?

  5. lindamuller
    Member
    Posted 9 months ago #

    Same problem on our site: http://goo.gl/GvJA8v Only Google+ counters are working. I'm keeping my old counters [Hupso] on [along with Simple Share] for a while. Looks dumb but I don't want visitors to think no one is sharing our stuff! I love this plugin and hope there is a fix for the zero counts. Thank you for all your work - I appreciate it.

  6. Marc Queralt i Bassa
    Member
    Posted 8 months ago #

    Check if the php directive allow_url_fopen is active.
    If not active it will only show 0.
    I had the problem.

  7. Marc Queralt i Bassa
    Member
    Posted 8 months ago #

    Check if the php directive allow_url_fopen is active.
    If not active it will only show 0.
    I had the problem and I solved it that way

  8. dannyjimmy
    Member
    Posted 8 months ago #

    I used the following way to test if allow_url_fopen is enabled,
    http://stackoverflow.com/questions/13433660/how-to-check-if-allow-url-fopen-is-enabled-or-not

    and indeed my allow_url_fopen is already enabled:
    http://connectedfamilies.org/dev/test-allow_url_fopen/

    So I must need some other fix :-(

  9. Andrew Tibbetts
    Member
    Posted 8 months ago #

    All worked on the last post (last week). Only google+ works on today's.

  10. Marc Queralt i Bassa
    Member
    Posted 8 months ago #

    Attached you'll find the test I build to verify twitter was working fine.

    <?php
    function getTwitterShareCount($urlCurrentPage) {
    
    	// get results from twitter and return the number of shares
        $htmlTwitterShareDetails = file_get_contents('http://urls.api.twitter.com/1/urls/count.json?url=' . $urlCurrentPage);
        print_r($htmlTwitterShareDetails);echo'<br/>';
        $arrTwitterShareDetails = json_decode($htmlTwitterShareDetails, true);
        print_r($arrTwitterShareDetails);
        $intTwitterShareCount =  $arrTwitterShareDetails['count'];
        return ($intTwitterShareCount ) ? $intTwitterShareCount : '0';
    }
    echo '<pre>';
    echo '<br/>'.getTwitterShareCount('http://demomentsomtres.com/catala/');
    echo '</pre>';

    Put it in a folder of your web server and try to call it.
    Check previously your server is configured to show warnings.
    Hope it works

  11. Marc Queralt i Bassa
    Member
    Posted 8 months ago #

    You can do the same test using the other functions inside lib folder of this component.

  12. Andrew Tibbetts
    Member
    Posted 8 months ago #

    I'm thinking it might be the cache plugin I'm using. I have disabled it—we'll see if it was the culprit.

  13. Andrew Tibbetts
    Member
    Posted 8 months ago #

    It was the cache plugin.

  14. dannyjimmy
    Member
    Posted 8 months ago #

    I'm getting the "Only-Google-Plus-Works" problem, and have no caching plugins installed.

  15. Lilak Surfer
    Member
    Posted 8 months ago #

    Thanks @ Marc. I had the same "Only-Google-Plus-Works" problem and your solution was right. "allow_url_fopen" has to be active! After changing, everything work fine!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.