WordPress.org

Ready to get started?Download WordPress

Forums

Couldn't setup Word-Press on my Ubuntu LAMP (7 posts)

  1. rws-piyush
    Member
    Posted 3 years ago #

    I just have tried to install a new version 3.0.3 but I couldn't get success anytime. It takes some time and gives the following errors for certain DB tables:

    ----------------------------------------------------------------------
    WordPress database error: [Invalid default value for 'comment_date']
    CREATE TABLE wp_comments ( comment_ID bigint(20) unsigned NOT NULL auto_increment, comment_post_ID bigint(20) unsigned NOT NULL default '0', comment_author tinytext NOT NULL, comment_author_email varchar(100) NOT NULL default '', comment_author_url varchar(200) NOT NULL default '', comment_author_IP varchar(100) NOT NULL default '', comment_date datetime NOT NULL default '0000-00-00 00:00:00', comment_date_gmt datetime NOT NULL default '0000-00-00 00:00:00', comment_content text NOT NULL, comment_karma int(11) NOT NULL default '0', comment_approved varchar(20) NOT NULL default '1', comment_agent varchar(255) NOT NULL default '', comment_type varchar(20) NOT NULL default '', comment_parent bigint(20) unsigned NOT NULL default '0', user_id bigint(20) unsigned NOT NULL default '0', PRIMARY KEY (comment_ID), KEY comment_approved (comment_approved), KEY comment_post_ID (comment_post_ID), KEY comment_approved_date_gmt (comment_approved,comment_date_gmt), KEY comment_date_gmt (comment_date_gmt), KEY comment_parent (comment_parent) ) DEFAULT CHARACTER SET utf8
    ----------------------------------------------------------------------

    THERE ARE SOME OTHER TABLES ALSO LISTED SAME AS ABOVE WITH THE SAME ERROR MESSAGE FOR DIFFERENT FIELD LIKE "WordPress database error: [Invalid default value for 'link_updated']"

    After this when I see in to DB there are only 7 tables created and I also can't login to admin/front site because the setup is not done complete yet.

    Can anyone please tell me what this problem is trying to say is?

  2. Samuel B
    moderator
    Posted 3 years ago #

  3. rws-piyush
    Member
    Posted 3 years ago #

    Hi Samuel, thanks for the reply but the link you given me has only the steps which I already followed. The problem is after installation script it tells me "WordPress database error: [Invalid default value for 'comment_date']" like what I pasted in my original post.

  4. Root
    Member
    Posted 3 years ago #

    My LAMPP on Ubuntu is fine. This might be a WP 3.0.3 thing.

  5. mrmist
    Forum Janitor
    Posted 3 years ago #

    Is your Mysql install running in strict mode?

  6. rws-piyush
    Member
    Posted 3 years ago #

    @Root: Yes, its only happening when I tried to get WP 3.0.3 installed!
    @mymist: I just have checked variable in /etc/mysql/my.cnf, it's currently set to traditional. What it means?
    sql-mode = "TRADITIONAL"

  7. mrmist
    Forum Janitor
    Posted 3 years ago #

    Yeah that's what I meant. Various bits of WordPress don't work with that mode. http://dev.mysql.com/doc/refman/5.0/en/server-sql-mode.html lists other modes you can use instead.

Topic Closed

This topic has been closed to new replies.

About this Topic