WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Widget Pro
[resolved] "Could not recognize the response from Twitter" (22 posts)

  1. douglaswarnold
    Member
    Posted 1 year ago #

    Hi, Aaron

    I get this error message when trying to authorize the plug-in:

    "Could not recognize the response from Twitter"

    Any idea why that might be happening? I put in the correct OAuth Consumer Key and OAuth Consumer Secret.

    Thanks,
    Doug Arnold

    http://wordpress.org/extend/plugins/twitter-widget-pro/

  2. zbartrout
    Member
    Posted 1 year ago #

    Same issue.

  3. ryanmsteele
    Member
    Posted 1 year ago #

    just ran into the same issue as well

  4. Jacob Ajjarapu
    Member
    Posted 1 year ago #

    I had the same issue, but I got it working.
    When I i did the initial set up I forgot to declare a callback url.
    I added a callback url (same as site url) and updated the settings and then reset the keys. I plugged in the new consumer key and secret.

  5. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    What Jacob said is the key to this:
    "When I i did the initial set up I forgot to declare a callback url."

    Make sure you specified a *VALID* Callback URL (just use your site URL)

  6. david.hascup
    Member
    Posted 1 year ago #

    How do you go back and add the Callback URL? I cannot find it anywhere. I also deleted the plugin and reloaded. Came back with the KEY and SECRET already in it and not Callback URL field.

  7. Rootside
    Member
    Posted 1 year ago #

    You add the callback URL at https://dev.twitter.com/apps

    The app you have to create at dev.twitter.com is a permanent thing, you can go back and add or edit details.

  8. max@desertheart.com
    Member
    Posted 1 year ago #

    I've specified a valid callback url (my site's URL). I've reset the key. I've re-input the key on the settings page. The settings keep reverting to something else and it won't authorize.

  9. max@desertheart.com
    Member
    Posted 1 year ago #

    So, I found the problem was that the code and secret deal have to be erased, then you have to update options at the bottom of the page, then you have to input the new codes, then you have to update options again (I think) and THEN you have to click the authorize button. Geez.

  10. kristinachilds
    Member
    Posted 1 year ago #

    I have the same problem, but it worked fine before I installed the update.

    I have a valid callback URL, keys and secret are in. I even regenerated the keys thinking maybe a fresh key would help, but no dice. When I click "Authorize Account" it resolves to a blank screen.

  11. Ocala Website Designs
    Member
    Posted 1 year ago #

    @max, you are right, you have to erase the keys, save, and then re-add them in .... You also have to have the call back url it seems as well which I corrected first, but still had to do Max's suggestion.

  12. hutz
    Member
    Posted 1 year ago #

    Thanks for the info. Added the callback URL ("my domain") and it works just fine.

  13. elizabethannedesigns
    Member
    Posted 1 year ago #

    I've updated keys multiple times and do have a callback URL set, still receiving the "Could not recognize the response from Twitter" message. Frustrating! Any thoughts? Thanks

    //never mind - all done after the 3rd reset! Thanks!

  14. fightfansradio
    Member
    Posted 1 year ago #

    Still not working for me. What am I doing wrong??

  15. fightfansradio
    Member
    Posted 1 year ago #

    I've tried everything above plus created a new application and still nothing seems to work. Going to move on to another plugin I guess.

  16. benspy
    Member
    Posted 1 year ago #

    I have The solution:)go here

    You have the creat a new API : )Follow the instructions !

    Have a nice plug-in : )

  17. designqvist
    Member
    Posted 1 year ago #

    Hey, I've solved the problem with the help of this step by step-instruction:

    http://www.itworld.com/consumerization-it/347294/step-step-photo-guide-setting-twitter-widget-pro-wordpress

    For some reason I got space (blank) at the start of my consumer key and consumer secret when copying & pasting them into my WordPress screen. Don't know, but maybe you should have a look there, too.

  18. designqvist
    Member
    Posted 1 year ago #

    oh, I see I used the same site as benspy did... 8-)

  19. canciller
    Member
    Posted 1 year ago #

    Yes !!! got it...

    Ok ... this is what I did:

    1- Enabling the "php_curl" in WAMP resolve the message : "There are no HTTP transports available which can complete the requested request."

    2- "reset" the information (various times) on the "dev.twitter.com" the problem with the "You need to authorize Twitter Accounts" disappear (the blue button will work). Remember to update information and press the "Activate Account" on each attempt to "reset".

    3- At this point the account was succesfully activated (yayyyy !!) but widget didn't show on left footer :(

    4- I then go to "widgets" in the wordpress admin area and found that the previous "widgets" shown up instead of the Twitter (don't know why). I then proceed and remove all "inactive" widgets and voilá !!! the Twitter Widget Pro appears on the left footer.

    :D hope this info helps someone.

  20. jonnymccullagh
    Member
    Posted 1 year ago #

    I had this same problem and as Aaron says it was related to the callback URL. I was using domain mapping in a multi-site setup and the solution was to use the http://blogs.domain.com/blogname address rather than the mapped domain name http://www.blogname.com.
    Hope this helps someone else.

  21. Ryan Hellyer
    Member
    Posted 1 year ago #

    This had me super confused. I've tried installing this plugin multiple times and always failed - until reading this forum topic. I think it would be a good idea to provide a more comprehensive guide for us n00bs who can't figure out the Twitter application sign up process.

  22. Ryan Hellyer
    Member
    Posted 11 months ago #

    It seems that this problem still exists. Thankfully, this time around I knew where this forum topic was to help solve the problem :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic