WordPress.org

Ready to get started?Download WordPress

Forums

Could not establish a secure connection (3 posts)

  1. goofydg1
    Member
    Posted 6 months ago #

    I run a development wordpress site on my laptop through an xampp install. Ever since I updated to 3.7 I get an error message after I install a plugin or theme.

    could not establish a secure connection to WordPress.org. Please contact your server administrator.) in D:\xampp\htdocs\wp\wp-includes\update.php on line 267

    I've tried re-installing WordPress and updating xampp but the error remains. When I update multiple plugins, it only shows once at the end. If it's themes, it will show against every theme as it updates. Sometimes the update notice will also go away before I update theme and if I do a check again it won't come back for a while.

    any thoughts appreciated.

  2. Abhishek Ghosh
    Member
    Posted 6 months ago #

    Actually this error comes as MS Windows by default has no cURL installed so far my understanding goes. Either manually update (replacing files) or setup like *NIX.

    The only way to have a kind of smooth Linux like setup is to have WAMP installed and Install cURL on Windows, then enable Apache mod_rewrite, Curl etc. When I used Windows, that setup worked.

    As you have said "my laptop", then its not OSX, either Windows or Linux. For Linux only work on the Apache part.

    I do not know whether WAMP method will work on XAMPP. My Windows laptop, unfortunately has died, so I can not test.

  3. goofydg1
    Member
    Posted 6 months ago #

    I tried the curl install but it didn't resolve the issue. thanks for the input though.

Reply

You must log in to post.

About this Topic