WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Could not create directory. wp-content/upgrade/xxx.tmp (14 posts)

  1. Roy
    Member
    Posted 3 years ago #

    I know, plenty of threads about this, but not one with a sollution for me.
    When using 3.0(.1) (network enabled) I had no problems upgrading plugins. When I wanted to upgrade to 3.0.2 I got the error from the topic title. I upgraded manually and didn't give it a thought. Now I get the same error when I want to upgrade a plugin. No, I didn't change anything but the few WP files that were changed.
    So, the upgrade folder to 777, no success. wp-content to 777, same. wp-content and /plugins and /upgrade to 777, no succes. Deleted the upgrade folder, it gets recreated (740!), but the same error and in the end, deleted the plugin, tried to add a new one, same error.
    I'm no fond of 777 permissions, I've always used 747 without problems.
    Any suggestions I didn't think of?

  2. Roy
    Member
    Posted 3 years ago #

    Rah, in 3.0.3 the update core file only gives a white screen...

  3. Roy
    Member
    Posted 3 years ago #

    I've tried all options in this thread but without succes. Another website on another server works perfectly, so it has to be server-sided, but I have no clue what. It could be due to the multi-install, since I read of noone who solved the issue with a multi-install.
    Suggestions are more than welcome.

  4. James
    Happiness Engineer
    Posted 3 years ago #

    Try setting your FTP system to proftpd, or ask your hosting provider to change it.

  5. Roy
    Member
    Posted 3 years ago #

    Never heard of that, but I looked around a bit. Another sort of FTP server? Does it handle file permissions differently, or what's the difference? I'll look into it. Thanks.

  6. James
    Happiness Engineer
    Posted 3 years ago #

    Yeah, it's another FTP server.

    I'm not sure if it'll fix this issue, but there was incompatibility between the auto updater and pure-ftpd. In that case, switching to proftpd was the solution, and most server packages allow you to easily switch between the two.

  7. Roy
    Member
    Posted 3 years ago #

    I'm afraid that's no option with my host...
    Other suggestions?

  8. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Ask your hosting provider for assistance.

  9. Roy
    Member
    Posted 3 years ago #

    I'm not sure if it'll fix this issue

    Me neither, if that's the case WP should started to make conflicts with my FTP server between 3.0 and 3.0.1 and when I see what files are changed, I can hardly imagine that.

  10. Roy
    Member
    Posted 3 years ago #

    However the upgrade files weren't in the changelog, 3.0.4 solved this problem!

  11. Roy
    Member
    Posted 3 years ago #

    This issue actually wasn't solved when I thought it was a month ago, but the white screen of the upgrade option did leave then. Only now (when working on my girlfriend's WP) do I realise that it is actually Ask Apache Password Protect blocking access to the wp-content folder. I have used this plugin for such a long time that I don't even think about it anymore when there's a problem... Next time there's an upgrade I'll try to deactivate wp-content protection and see if that helps.

  12. johnnyoldboy
    Member
    Posted 3 years ago #

    2nd on disable apache password protect - worked for me and I tried a heap of other things. THanks Roy

  13. Parag
    Member
    Posted 2 years ago #

    3rd for Roy's suggestion! I was banging my head thank you!

  14. terjemk
    Member
    Posted 2 years ago #

    Same for me here. When I deactivatedt ask apache password proctet the problem was solved.

Topic Closed

This topic has been closed to new replies.

About this Topic