WordPress.org

Ready to get started?Download WordPress

Forums

MailPoet Newsletters
[resolved] Could not connect to SMTP host (3 posts)

  1. davydov-denis
    Member
    Posted 1 year ago #

    Hi everyone,

    i'm setting up newsletters in WordPress,
    but for some reason it can't connect to my host to send emails.
    That's what i have during the test:

    SMTP Error: Could not connect to SMTP host. |
    Warning: fsockopen()[function.fsockopen]: unable to connect to ssl://mail.mydomain.com:2525 (Connection refused) in...
    wysija-newsletters/inc/phpmailer/class.smtp.php on line 123

    the 25'th port gives the following error:
    SMTP Error: Could not connect to SMTP host. |
    Warning: fsockopen() [function.fsockopen]: SSL operation failed with code 1. OpenSSL Error messages: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol in .../wysija-newsletters/inc/phpmailer/class.smtp.php on line 123

    do you have any ideas what can be wrong?
    Authentication is turned on, secure connection - SSL.

    p/s/ yes, i do use the proper
    SMTP hostname, login and password.
    I also tested it from another Newsletter plugin (same settings) and it worked fine.

    http://wordpress.org/extend/plugins/wysija-newsletters/

  2. Ben
    Member
    Plugin Author

    Posted 1 year ago #

    Hello there,

    Get in touch with your hosting provider it seems that they are blocking the ports 2525 and 25.

    Ask them to unblock them, if they don't want to you can use our integration with SendGrid's webAPI which goes through port 80 and is not possible to block.

    Cheers,
    Ben

  3. davydov-denis
    Member
    Posted 1 year ago #

    Hi,

    thanks for your reply.
    Indeed, when i changed the port to 465 (that was a default one in another plugin), it worked.

    Funny enough, TLS with port 25 worked fine too. Although i'm not an expert with regards to difference between the two methods.

    Regards,
    Denis.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.