WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Core or Plugin update: "Could not create directory.: /httpdocs" (27 posts)

  1. TroyMcGinnis
    Member
    Posted 1 year ago #

    Hi Guys,

    I've been searching for the solution to this for a while and now I'm looking here to get some help. The issue I'm having is that on one of the WordPress sites that I manage, I have been receiving the following message when attempting to upgrade the Core WordPress files or any of my Plugins:

    Downloading update from http://wordpress.org/wordpress-3.5.2-partial-1.zip…
    
    Unpacking the update…
    
    Could not create directory.: /httpdocs
    
    Installation Failed

    I have tried running chmod 777 on the wp-content directory as well as the root public_html directory (which I know is not at all secure). This is the ONLY site that has been giving me issues out of approximately 20 sites.

    The servers are all VPS servers running the latest distro of CentOS with Apache, MySQL and the latest version of PHP.

    Any assistance would be greatly appreciated!

    -T

  2. JarretC
    Member
    Posted 1 year ago #

    Odd that it is trying to create /httpdocs when that is a directory that usually contains all of your site's files. Do you have your WP install setup in any special way that would cause it to try to create that directory?

    Usually when WP is doing an upgrade it will place files into /wp-content/upgrade

  3. TroyMcGinnis
    Member
    Posted 1 year ago #

    Jarret, no special setup with this install of WP. I have read lots of people mentioning that they were receiving errors that would state something like...

    Could not create directory.: /httpdocs/wp-content/plugins/...

    Not sure why its attempting to create the root html directory either. It's leaving me stumped.

  4. Puma85
    Member
    Posted 12 months ago #

    Do you have any update on this topic? I have the exactly the same problem. It worked fine before, but now it gives me this error.

    Is it maybe something server-related?

  5. TroyMcGinnis
    Member
    Posted 12 months ago #

    I have not found a solution to this yet. The WordPress install has just moved to a new server and the issue is persisting.

    I'm considering just doing a manual update but would really like to be able to get the auto updates working.

    Anyone else have any thoughts on this?

  6. TroyMcGinnis
    Member
    Posted 12 months ago #

    It looks like this issue is actually occurring for the core update as well as for the plugins (http://cl.ly/image/292R2c37152y). It could be a server issue, but I'm not sure what.

  7. Puma85
    Member
    Posted 12 months ago #

    Any difference is that I don't have that trailing / before httpdocs

    'Downloading update from http://downloads.wordpress.org/plugin/akismet.2.5.9.zip…

    Unpacking the update…

    Could not create directory. httpdocs'

    I'm now trying to find out what I changed lately... it's bin a while though since anything changed.

  8. Puma85
    Member
    Posted 12 months ago #

    Don't know if this helps, but when I change the address in wp-config, it creates the new folders to store the upgrade..
    for example, when I add system to the address as shown below, it creates nicely new folders and stores the upgrade files in there.
    'define('FTP_BASE', 'httpdocs/system/');
    define('FTP_CONTENT_DIR', 'httpdocs/system/wp-content/');
    define('FTP_PLUGIN_DIR ', 'httpdocs/system/wp-content/plugins/');'

    The installation error is then as follows:
    'Downloading update from http://downloads.wordpress.org/plugin/akismet.2.5.9.zip…
    Unpacking the update…
    Installing the latest version…
    Removing the old version of the plugin…
    Could not remove the old plugin.
    Plugin update failed.'

    but as soon as I change it back it gives problems again..

  9. TroyMcGinnis
    Member
    Posted 12 months ago #

    Looks like you're getting closer.

    That last error you're getting looks like a permissions issue. Try running chmod 777 on the wp-content directory then try the upgrade again. Make sure to change your permissions back afterward.

    I'll try defining the those FTP variables and post back here.

  10. Puma85
    Member
    Posted 12 months ago #

    problem remains the same. No difference

  11. shamratdewan
    Member
    Posted 12 months ago #

    usually it happens for write permission for apache on your server. can you give apache write permission as much as root on your server?

  12. Puma85
    Member
    Posted 12 months ago #

    I don't know, what is the difference?
    I use parallels panel to change the chmod permisions...

  13. shamratdewan
    Member
    Posted 11 months ago #

    for parallels the user name is something like "pcl" or close to it. more effective is to use ssh or rdp

  14. Puma85
    Member
    Posted 11 months ago #

    I'm sorry, but could you explain (maybe step-by-step)what I need to do.
    I don't understand what you're trying to say.
    thanks for you help!

  15. shamratdewan
    Member
    Posted 11 months ago #

    How many sites you have in your server? are all of them got the same problem? if not then obviously it wount be a server issue. However, to give it a try...
    First take backup as if you don't have backup so many thing happens. then may be follow this tutorials and give a try. http://ideasandpixels.com/mediatemple-dv-server-how-to-change-ssh-write-permissions

  16. Puma85
    Member
    Posted 11 months ago #

    Solved!!

    I found this link:
    http://www.hongkiat.com/blog/update-wordpress-without-ftp/

    And after changing the FS_method to direct, it worked perfectly!! :D
    Basically add this line to your wp-config.php file:
    'define('FS_METHOD','direct');'

    good luck!

  17. TroyMcGinnis
    Member
    Posted 11 months ago #

    Incredible. That did it!

    Thanks, Puma.

  18. Heiko Mamerow
    Member
    Posted 5 months ago #

    Thanks guys for lifesaving! :-)

  19. focet
    Member
    Posted 5 months ago #

    Hey guys! I've read all the comments here, and made the change in the config file, but I'm still getting this issue.

    My server is IIS 7, with PHP, and MySQL and WordPress all working fine, I just can't get the plugins to update or delete or install.

    Any help will be really appreciated.

    Thanks!

  20. Julianwave
    Member
    Posted 5 months ago #

    I followed the instructions from Puma85.No joy, still says could not create directory :(

  21. Andrew
    Forum Moderator
    Posted 5 months ago #

    Then it is unlikely you are experiencing the same issue that TroyMcGinnis did 8 months ago.
    You can create a new thread here: https://wordpress.org/support/forum/how-to-and-troubleshooting#postform

  22. focet
    Member
    Posted 5 months ago #

    Hey Julianwave - on what server did you install WP? I have it installed on IIS 7, I was able to resolve this issue by making sure that the wp-content folder had "full access" for IIS-IUSERS account in the server. It's a bit annoying to fiddle around with those settings, but that resolved it for me.

    You can also set file permissions in an FTP client to 765, but this won't work for IIS.

    I think this is all about permissions, and if that's the case then you can find a bunch of threads on how to set folder/directory permissions on your server. Good luck!

    -Focet

  23. Julianwave
    Member
    Posted 5 months ago #

    It turns out a load of files had been uploaded without my knowledge and the problem was simply that I'd run out of space.

    So, future visitors to this thread, learn from my mistake and before you do anything else check there is actually space on the server for your plugins to update!

  24. darkxploit
    Member
    Posted 4 months ago #

    Hello.. this is just a simple issue.. just ssh on the server.. download the plugins manually and unzip + copy it to the /var/www/yourwebsite/wp-content/plugins.. this will solve the problem on spot. Next time there is an update that screen to use ftp/ftps or "cant create folder" wont appear again^^^

    regards
    nitin j mutkawoa

  25. mhsoliman
    Member
    Posted 3 months ago #

    Thank you All,

    I had the same problem, But after following the the instructions provided by Puma85, Thank you.
    I still get the same problem, so changed the permissions of each folder under and tested the plugins after each change, here is the steps i found to resolve the issue:
    1. follow the instructions Puma85 provided: http://www.hongkiat.com/blog/update-wordpress-without-ftp/
    2. Change the permissions for the wp-content and plugins folders:
    sudo chmod 777 Your_wordpress_root_folder/wp-content
    sudo chmod 777 Your_wordpress_root_folder/wp-content/plugins

    3. Install the plug-in, it should work fine.
    To change back the permission for protecting the wordpress contents and plug-in, otherwise you can leave it as is if the security is not a big concern :
    4. change back the original permission :
    sudo chmod 751 Your_wordpress_root_folder/wp-content
    sudo chmod 751 Your_wordpress_root_folder/wp-content/plugins

    Hope this will help.

    Good Luck,
    Mohamed Soliman

  26. soeb.safi
    Member
    Posted 3 months ago #

    It worked :)
    Thanx, Puma

  27. ndundupan
    Member
    Posted 2 months ago #

    Thanks mhsoliman, it worked for me!

Topic Closed

This topic has been closed to new replies.

About this Topic