WordPress.org

Ready to get started?Download WordPress

Forums

Cookies making page load slow in browser. (6 posts)

  1. earrame
    Member
    Posted 4 months ago #

    Hello, I have been banging my head against this site for a couple weeks trying to figure out why it has been loading so slow. After using every optimization technique I could find I was able to show a page load time of under a second using pingdom.com, the problem being that my browsers (FF and Chrome) would hang on the site for up to 30 seconds before loading it in that less than a second.

    I discovered that it was just my browsers when I opened the site in a different computer. fast as lightening. I cleared my cache and cookies for the last month and woosh! that fixed the problem...until I loaded the page a second time (no matter what computer). If I disable cookies using FF web developer extension, the page loads in a blink. I enable it again and back to slooooow.

    I have optimized the database to no effect.

    Why is this happening?

    The site is http://featherfolio.com and the page that hangs the longest is http://www.featherfolio.com/galleries/shadow-boxes/

    Thanks in advance for checking into this very frustrating issue.

    P.S. I notice that the dashboard runs pretty slow too. is this related or is there another way to speed up the admin area?

  2. Keith Driscoll
    Member
    Posted 4 months ago #

    I'm not seeing any speed issues using Chrome or IE. Try logging out and see if you have the same problem.

  3. earrame
    Member
    Posted 4 months ago #

    Thanks Keith, You are correct, logging out makes the cookie issue go away. Why is that? Is there some issue with the admin side of things?

  4. Keith Driscoll
    Member
    Posted 4 months ago #

    Try clearing the cache in W3 Total Cache settings page. If that doesn't work you could try disabling plugins and re-enable one by one to find the suspect.

  5. earrame
    Member
    Posted 4 months ago #

    That was one of the first things I tried. I ran the site with no plugins at all except for the nextgen gallery and still had the issue. Clearing the cache doesn't do anything to prevent the page form loading slow when logged in and cookies are enabled.

  6. MarkRH
    Member
    Posted 4 months ago #

    Here's something you might try. While logged in, edit your profile and turn off the Admin Toolbar that displays at the top if you have it enabled.

    If that helps.. then I suspect your browser is trying to talk to a third party site (WordPress.org or something else) and that is what's causing the delay.

    Might be related to the blog checking for updates to WordPress and other plug-ins causing the delay (which probably only happens during an admin login). Just trying to think of procedures or tasks that only happen when logged in.

Reply

You must log in to post.

About this Topic