WordPress.org

Ready to get started?Download WordPress

Forums

124

[resolved] [closed] "Cookies are blocked or not supported" since update to 3.7.1 (105 posts)

  1. willem.deboer
    Member
    Posted 8 months ago #

    Since updating WP to 3.7.1, when users attempt to login to my WP site, they receive an error message:

    "Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress."

    Cookies are enabled. Never had the message before, site is unchanged since 3.7, and with cookies enabled in all browsers, you still see the message when logging in.

    I disabled themes and plugins, to no avail.
    Tried the other hacks in several threads, but no cigar. All they did was produce a white screen.

    Any one else experiencing this or have a suggested solution? All help is appreciated. I need to update my site with new artwork, but I can't login to the admin screen!

  2. alekseyn
    Member
    Posted 8 months ago #

    Having the same issue... Too bad the other topic got closed.

  3. esmi
    Forum Moderator
    Posted 8 months ago #

    @alekseyn: If you require assistance then, as per the Forum Welcome, please post your own topic. Then we won't have to go around closing topics because people have turned them into an unsupportable mess.

  4. willem.deboer
    Member
    Posted 8 months ago #

    After doing all of the below I still have the same problem.
    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder and wp-config.php & root .htaccess files - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    Please help.

  5. willem.deboer
    Member
    Posted 8 months ago #

    After disabling all themes except either Twenty10, 11 or 12 I only see a white screen. I am currently using theme "Appointment".

  6. willem.deboer
    Member
    Posted 8 months ago #

    Disabling all plugins makes no difference. Still the same error.
    Disabling all plugins and all themes except Twentie10, 11 or 12 gives me a white screen.

  7. esmi
    Forum Moderator
    Posted 8 months ago #

    Have you spoken to your hosts about this? Or checked your site's error logs?

  8. willem.deboer
    Member
    Posted 8 months ago #

    Yes. They confirm nothing changed on their side. What puzzled the engineer, and I know him very well and trust him, was the switching from http://www.domain.nl to http://domain.nl when you open a site. I can see WordPress creates cookies both with and without the www prefix in one session.

  9. esmi
    Forum Moderator
    Posted 8 months ago #

    What urls are entered in Settings -> General?

  10. willem.deboer
    Member
    Posted 8 months ago #

    I cannot login, therefore I cannot check .... Is there another way?

  11. esmi
    Forum Moderator
    Posted 8 months ago #

    No. WordPress cannot make any changes to site urls.

  12. willem.deboer
    Member
    Posted 8 months ago #

    That is not what I meant. Is there another way to check the url setting, as I cannot use the admin screen to access Settings => general.

  13. esmi
    Forum Moderator
    Posted 8 months ago #

    Is there another way to check the url setting, as I cannot use the admin screen to access Settings => general.

    As I said above, no. Well, not unless you start looking through the wp_options table of your database. But I would strongly advise against making any changes yourself in the database as the urls may be stored in serialized form in some places. Failure to change all occurrence - including the serialized ones - could stop the site in its tracks.

  14. willem.deboer
    Member
    Posted 8 months ago #

    OK, I see. So, what's next?

  15. esmi
    Forum Moderator
    Posted 8 months ago #

    Have you tried using another browser? Another computer?

  16. willem.deboer
    Member
    Posted 8 months ago #

    Any browser, any computer, Android phone, any network. And I have two separate sites that have the same issues. They were both running fine before 3.7.1.

  17. esmi
    Forum Moderator
    Posted 8 months ago #

    As are the vast majority of the other 7 million WP 3.7.1 sites. I'm sorry but this is definitely server specific. I'm also curious about the " switching from http://www.domain.nl to http://domain.nl". That's something that WordPress itself definitely cannot do.

    When did you last check your root .htaccess file? Have you tried changing the salts in your wp-config.php file?

  18. willem.deboer
    Member
    Posted 8 months ago #

    Root .htaccess file is bog-standard. I last checked it this morning. .htaccess in wp-admin has the following in it:

    order deny,allow
    allow from xx.xxx.xxx.xxx
    deny from all

    What is "the salts in your wp-config.php"?

    PhP version on the server is 5.2.17.

  19. esmi
    Forum Moderator
    Posted 8 months ago #

    The Authentication Unique Keys.

  20. willem.deboer
    Member
    Posted 8 months ago #

    I generated new ones, but no luck.

  21. esmi
    Forum Moderator
    Posted 8 months ago #

    Give me a few minutes. Trying to get some more eyes on this...

  22. willem.deboer
    Member
    Posted 8 months ago #

    Should I send you the url's in some sort of private message?

  23. Scriptrunner (Doug Sparling)
    Member
    Posted 8 months ago #

    WordPress will set one or two test cookies when you go to wp-login.php. If siteurl and home are the same, then just one cookie. So after you go to wp-login.php, check if you have any cookies named 'wordpress_test_cookie.'

    You can check your siteurl and home url via SQL. In my case, for example:

    mysql> SELECT option_value FROM wp_options WHERE option_name='home';
    +------------------+
    | option_value     |
    +------------------+
    | http://localhost |
    +------------------+
    1 row in set (0.00 sec)
    
    mysql> SELECT option_value FROM wp_options WHERE option_name='siteurl';
    +------------------+
    | option_value     |
    +------------------+
    | http://localhost |
    +------------------+
    1 row in set (0.00 sec)

    So since siteurl and home are the same, I only have one test cookie set.

    Name: wordpress_test_cookie
    Content: WP+Cookie+check
    Host: localhost
    Path: /
    Send For: Any type of connection
    Expires: At end of session

    Upon login, WordPress checks that the test cookie has been set and you'll get that error if not (assuming the form is sending the hidden param of testcookie=1, which it should)

    So first see if wp-login.php (just go to the page, you don't need to login) is setting the test cookie(s) for siteurl and home.

  24. kmessinger
    Volunteer Moderator
    Posted 8 months ago #

    Check validation, http://validator.w3.org/check?verbose=1&uri=http://www.communsense.nl/

    Line 466 has to do with cookies.

  25. willem.deboer
    Member
    Posted 8 months ago #

    @Scriptrunner:

    mydomain.nl 4 cookies
    http://www.mydomain.nl 2 cookies
    no wordpress_test_cookie

    I'l do the sql now, have never used my webhosts tools before.

  26. willem.deboer
    Member
    Posted 8 months ago #

    @kmessinger I re-uploaded a clean 3.7.1 yesterday after deleting everything on the server.

    Line 466 error:

    Line 466, Column 337: required attribute "type" not specified
    …tinuing to browse this site you accept this policy.</p></div></div> <script>

    The attribute given above is required for an element that you've used, but you have omitted it. For instance, in most HTML and XHTML document types the "type" attribute is required on the "script" element and the "alt" attribute is required for the "img" element.

    Typical values for type are type="text/css" for <style> and type="text/javascript" for <script>.

  27. willem.deboer
    Member
    Posted 8 months ago #

    SQL resultaat
    Host: xxx.xxx.xxx.xxx
    Database: xxxxxxxxxxxxxxxxxxxxxxxxx
    Generatie Tijd: 15 Nov 2013 om 09:42
    Gegenereerd door: phpMyAdmin 2.11.11.3 / MySQL 5.0.83-community
    SQL-query: SELECT option_value FROM wp_options WHERE option_name='home' LIMIT 0, 30 ;
    Rijen: 1
    option_value http://www.mydomain.nl

    SQL resultaat
    Host: xxx.xxx.xxx.xxx
    Database: xxxxxxxxxxxxxxxxxxxxxx
    Generatie Tijd: 15 Nov 2013 om 09:44
    Gegenereerd door: phpMyAdmin 2.11.11.3 / MySQL 5.0.83-community
    SQL-query: SELECT option_value FROM wp_options WHERE option_name='siteurl' LIMIT 0, 30 ;
    Rijen: 1
    option_value http://www.mydomain.nl

  28. willem.deboer
    Member
    Posted 8 months ago #

    @scriptrunner The other site did not have the www prefix for both 'home' and 'siteurl'. I have corrected that manually in the database and now the "flipping" of the url between http://www.mydomain.nl and http://mydomain.nl is gone. The cookie issue is still there unchanged.

    I had a look at the cookies generated on the other site; same result.

    domain.org 4 cookies
    http://www.domain.org 2 cookies

    No wordpress_test_cookie

  29. Scriptrunner (Doug Sparling)
    Member
    Posted 8 months ago #

    The test cookie is set by wp-login.php, and like you, when I go to the login page on your site, no test cookies are set. I also noticed that the wp-admin and colors-fresh css are not loading.

    Never the less, wp-login.php should set the test cookies, nothing special there and nothing regarding that has changed with WordPress 3.7.1 that I'm aware of. So to me it looks like that wp-login.php is the culprit.

    Can you verify that:

    setcookie(TEST_COOKIE, 'WP Cookie check', 0, COOKIEPATH, COOKIE_DOMAIN);
    if ( SITECOOKIEPATH != COOKIEPATH )
    	setcookie(TEST_COOKIE, 'WP Cookie check', 0, SITECOOKIEPATH, COOKIE_DOMAIN);

    is in your wp-login.php file?

  30. willem.deboer
    Member
    Posted 8 months ago #

    Affirmative. Logically, this could mean that the condition (SITECOOKIEPATH != COOKIEPATH) is not met, right?

124

Topic Closed

This topic has been closed to new replies.

About this Topic