WordPress.org

Ready to get started?Download WordPress

Forums

"Cookies are blocked or not supported by your browser." (24 posts)

  1. alekseyn
    Member
    Posted 9 months ago #

    when users attempt to login to WP site, they receive an error message:

    "Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress."

    Cookies are enabled. Site was running well until last weekend. Never had the message before, site is unchanged since 3.7, and with cookies enabled in all browsers, you still see the message when logging in.

    We disabled themes and plugins, to no avail.
    Tried the other hacks in several threads, but no cigar. All they did was produce a white screen.

    Any one else experiencing this or have a suggested solution? All help is appreciated. I need to update my site, but I can't login to the admin screen!

    The only solution that worked and let me into the admin area is

    function wp_validate_auth_cookie($cookie='',$scheme='') {
        return 1; // admin user id
    }

    but this opens the site wide open to all visitors being admins (which is OK to update or upgrade something really quick....

    The issue seems to be different from host to host and something within the core changed that results in this error... but what? It's all either about cookies or php...

  2. esmi
    Forum Moderator
    Posted 9 months ago #

    I think it's more like to be a server sessions or cookie issue than a core one. Have you spoken to your hosts about it. Or checked your error logs?

  3. alekseyn
    Member
    Posted 9 months ago #

    @amsgator thanks for that. non-www to www redirection is the first thing I did. Still no go.

    Disabling the test cookie check also did not work. Cookie is just not being set at all...

    Trying to install another instance of WP on the same server now to see if it works.

  4. amsgator
    Member
    Posted 9 months ago #

    Clear your cookies and cache. If you have the cookie still in the browser and you block the check it will freak out.

  5. MariaA
    Member
    Posted 9 months ago #

    I hade this ccokis problem i 2 weeks with brand new installation, I got my own tread and nobody answered me there. I am not that technical and it should not be like that - whrite som other skripts. And I cleared cookies an cash, cheked on other browsers and other computers - didnt work easer!

    It is Word Press problem with 3.7.1!

    Thanks to amsgator I inastalled 3.7 and its works! So it can not be host problem.

    I just wonder if some place I should swich off automatic uoodate? Or wp will ask me before uppgrade?

  6. Clodius
    Member
    Posted 9 months ago #

    I was having the same issue all last week, applied some of these fixes, then it worked for a while, then I got the white screen of death. I needed to revamp my site anyway so I blew it away and rebuilt it. Then lo and behold it happened again today. I was on Cloudflare but reverted back to my default name servers before trying to troubleshoot. And now the problem has gone away. Hmmmm...Now I'm not sure what to do, will it happen again?

  7. Clodius
    Member
    Posted 9 months ago #

    Follow up, just checked from another machine and the problem is still present!

  8. esmi
    Forum Moderator
    Posted 9 months ago #

    @Clodius: If you require assistance then, as per the Forum Welcome, please post your own topic.

  9. rossagrant
    Member
    Posted 8 months ago #

    This is a bit random chaps, but I've been following these threads on this issue for weeks as I too have this problem on my main site.

    I don't run varnish on my system and all plugins are so very much tried and tested that I didn't think it could be them.

    The thing that seemed to fix this issue on my 2 sites was to deactivate and then reactivate Akismet.

    I have absolutely NO idea whatsoever if Akismet could or would play a part with authentication for login in any way, but disabling and enabling the plugin has flushed something out of the system that was causing this problem.

    If you find yourself with this issue, I would recommend you deactivating all plugins and then re-enabling them ONE AT A TIME.

    Not sure what happens in that re-activating phase, but it sorted my problem out with this cookies issue.

    All now works great again after weeks of thinking it was a core WP issue.

    Hope that helps.

  10. karlrt
    Member
    Posted 8 months ago #

    My cookie problem seems to be related to cloudflare like @Clodius!

    I have had pagerules on: site.com/* to be totally cached while site.com/wp-admin set to bypass caching completely.

    Now i will do a third pagerule for wp-login.php not to cache anything, hope this helps!

  11. freedom1
    Member
    Posted 8 months ago #

    I've now got the same problem on some of my blogs.

    When I try to log in to my Control Panel I get the message "ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress."

    I've gone through the instructions for clearing cookies on http://support.mozilla.org/en-US/kb/websites-say-cookies-are-blocked-unblock-them with no success.

    I've tried a different browser too, but the problem persists.

    I use CloudFlare, and I've never had a problem before with logging in to my WP panel, but just in case I've added a Pagerule to bypass caching of wp-admin and wp-login.php but still I can't log in.

    I upgraded to the latest WP version a few days ago, but I have been able to login ok since then, so I assume it isn't this latest version that's causing the issues.

  12. WPyogi
    Volunteer Moderator
    Posted 8 months ago #

    Anyone except the OP in this thread - you should be starting your own thread if you need help as per the forum guidelines -

    http://codex.wordpress.org/Forum_Welcome#Where_To_Post

  13. freedom1
    Member
    Posted 8 months ago #

    Apologies, I'm one of the offenders in this.

    I have removed some Cloudflare pagerules so now my Admin login is not cached, and everything is back to normal.

  14. Clodius
    Member
    Posted 8 months ago #

    I know I'm breaking the law by replying to this thread but it is pertinent to what a member has posted.

    With regards to my issue it did resurface again today. This is after the 3.8 update too.

    @Rossagrant...Bullseye. I FTP to my plugins dir, renamed Akismet to Akismetxx, and boom, I got into the admin area. Big thanks to you!

  15. LinkAssist
    Member
    Posted 8 months ago #

    I'm replying only to post a workaround for this same problem I've had. The problem only shows up on one site of several - even though all are configured identically. When I try to login to the problem site, it clears the user name and password fields, and give me the "Cookies are not supported..." message. I leave the user name and password fields blank and hit reload. Firefox asks me if I want to resend data (Yes), and I'm whisked away to the admin area. Not a proper fix, but it beats a poke in the ribs.
    Meanwhile, the search for a 'real' solution goes on.

  16. rossagrant
    Member
    Posted 8 months ago #

    Hi guys!

    I've gotten to the bottom of this for sure now.

    Some themes that have the sidebar login widget developed before the latest WP update of 3.7 will more than likely have a line of code which states:

    <input type="hidden" name="testcookie" value="1" />

    Particularly if you use Buddypress.

    See this trac ticket here.

    http://buddypress.trac.wordpress.org/changeset/7485

    If you are using BP, you simply need to delete that line from your sidebar.php or BuddyPress navigation file containing that line of code.

    100% fixed all of my issues.

  17. Clodius
    Member
    Posted 8 months ago #

    BP doesn't apply to me unfortunately. Appreciate your efforts though, thx.

  18. Josť Freitas
    Member
    Posted 7 months ago #

  19. Ircsome
    Member
    Posted 5 months ago #

    @rossagrant ... thanks for doing the heavy lifting on this. Saved me hours.

  20. korythewebguy
    Member
    Posted 4 months ago #

    @rossagrant - You're the man!

    Taking <input type="hidden" name="testcookie" value="1" /> out of the code for the login widget solved the problem immediately.

    Much thanks!!

  21. patrickhait
    Member
    Posted 4 months ago #

    @rossagrant - Thank You!! I was using nice login widget, and have been struggling with this for a while. I commented that line out three times in the widget code, and all is good!

  22. LulusAtelier
    Member
    Posted 2 months ago #

    @Jose Freitas, I just happened to have cookie error issue, have a blank screen, want to thank you for referring the cookie-error-when-logging-in url. It turned out, in my case, I have the same issue but on my local mamp environment. The way it was solved it was by following Tara's advice: renaming my child theme via ftp or via mamp server by going to htdocs/content/themes/mychildtheme. That gave me access (finally to the admin screen and recognized my username and password.) Just wanted to thank you for the referral.

  23. Darren788
    Member
    Posted 1 month ago #

    I have the same problem, While searching the internet, i was able actually fixed it by using one of the solutions here, it might helps if anyone have same issue:

    [External link moderated. Never, ever, edit WordPress core files!]

  24. tradesouthwest@gmail.com
    Member
    Posted 2 weeks ago #

    I had a folder for my theme that had a hyphen in the name (three-by) where the slug for the theme, inside of the folder was called threeby, without the hyphen. Renamed the folder and it works like a charm now.

    I also went in to functions dot php and reordered my double quotes in a footer credits function so the double quotes were first in an echo statement and then the single quotations were encapsulating the hyperlink of the statement.

    So I think the first issue was the fix, in my case. Thought I would post both since there is no need to suspect the double quote order as apposed to the folder naming conventions issue. But you can look at both if it applies. It fixed mine.... on the other-hand I am using a cheap host and they could have been sitting on the session until I went into alter cookies using a function from the link above and that released the cookie, but it did not work the first try and I removed the cheat function (Jos Frietas thread) and it still did not work at that time.

    Note: my host is a Cloudflare host but they "tell me" CloudFlare is not 'automatically' initiated... I beg to differ that hosts use it when ever loads get big and it keeps me from editing real time in cPanel.
    [link: tradesouthwest.net/threeby]

Reply

You must log in to post.

About this Topic