WordPress.org

Ready to get started?Download WordPress

Forums

continued 500 / htaccess problem (11 posts)

  1. animalien
    Member
    Posted 5 years ago #

    Hello. I am having a weird problem. Every few days I go to my website and get an "Internal Server Error" - Or 500 error. I go into the .htaccess file of the site and notice it's been altered. Nothing big, one character is missing or a line merged together.

    It's easy to fix and continue on, but it keeps happening. I have installed a couple security plugins to try and prevent but it still happens. The error logs don't say anything about this so I don't know where to start.

    Anybody have an idea as to what's going on?

  2. Michael Fields
    Themer
    Posted 5 years ago #

    have you tried to change the permissions on your .htaccess? set it so that it is not writable by anyone. Should fix it.

  3. animalien
    Member
    Posted 5 years ago #

    I thought you have to leave it at 644 to work correctly?

  4. Michael Fields
    Themer
    Posted 5 years ago #

    I'm not an Apache expert, this is what my hosting company told me months back when I had the same issue... I just tried to set mine to 444 and wouldn't let me... kept reverting back to 644. Have you tried calling your host???

  5. Maciej Ku? (maciekkus)
    Member
    Posted 5 years ago #

    the same just happend to one of my blogs. really strange issue

  6. iridiax
    Member
    Posted 5 years ago #

    Two likely causes for 500 errors are problems with your web host (a good possibility if the errors are intermittent) or errors in your .htaccess.

    Also try temporarily disabling all plugins and see if the problem goes away.

    I go into the .htaccess file of the site and notice it's been altered. Nothing big, one character is missing or a line merged together.

    I don't know if you are doing so or not, but do not add any of your own code within the WordPress section of the .htaccess.

  7. animalien
    Member
    Posted 5 years ago #

    Well, I changed it to 444 and no problems since. I just checked it - it's still 444.

    Plugins were disabled and the problem still happened. Not sure why, but the current solution is solving.

  8. bradstinyworld
    Member
    Posted 5 years ago #

    I am having this problem too and really glad I am not alone. Is anyone else having this hosting with hostgator?

  9. Neziniux
    Member
    Posted 4 years ago #

    I am having the same problem, it started occasionally, once every few months and now the website goes offline every few days. A letter "s" appears every time at the bottom of .htaccess file, i keep it on deleting it but this cannot go on for ever. Rghhh!

    I will try permission 444 to see if it works.

  10. cellphoner
    Member
    Posted 4 years ago #

    Same problem here.
    This happens about twice a week with one of my blogs. (not hosted with hostgator).

    I changed the permissions to 444, but this didn't help - htaccess permissions are changed back to 644 and some random characters appear in the htaccess file, which cause internal server error.

    If anyone finds a solution or have an idea what causes it then please let us know.

  11. cellphoner
    Member
    Posted 4 years ago #

    It is getting worse every day.

    Now its happening multiple times during a day. I have to refresh the blog to make sure its working.

    I am running the latest version of wordpress, but this was also happening with earlier versions.

    Changing the htaccess permissions to 444 is not possible for me, because my hosting config does not allow it.

    Often there is a letter "s" added to the end of the .htaccess file.
    Can this be connected to somehow with wordpress search?

    Help!

Topic Closed

This topic has been closed to new replies.

About this Topic