WordPress.org

Ready to get started?Download WordPress

Forums

Posts By Tag
[resolved] Content short codes not displaying (6 posts)

  1. eapart
    Member
    Posted 1 year ago #

    This has been a fantastic plugin. I've been using it on a site to display specific posts in a sidebar. Recently, any short codes that were being used in a post are being displayed in the sidebar as the actual short code instead of what the short code should be displaying. I thought it might be a problem with another plugin but it seems to have the same problem with any short codes I use in a post and sometimes ignores them completely and displays nothing. I tried to add add_filter( 'widget_text', 'do_shortcode', 11); to the theme functions with no luck and tried adding it to the hooks in some of the other plugins I'm using with not luck there as well.

    The problem can be viewed at the bottom of this page under "Shop" in the sidebar: http://post-echo.com/artists/devereaux/

    Any help is greatly appreciated. Thank you!

    http://wordpress.org/extend/plugins/posts-by-tag/

  2. eapart
    Member
    Posted 1 year ago #

    I found a workaround for my issue by using the plugin shortcode in a text widget instead of using the plugin's widget.

  3. Sudar
    Member
    Plugin Author

    Posted 1 year ago #

    I think this is because the shortcodes are not handled when excerpts are requested.

    Are the shortcodes expanded if you display the excerpt of the post in an archive page?

  4. eapart
    Member
    Posted 1 year ago #

    It only displays the shortcodes if I use the widget in the sidebar and have it set to display the full content of the post. If the plugin is used anywhere else, it works great.

  5. Sudar
    Member
    Plugin Author

    Posted 1 year ago #

    It only displays the shortcodes if I use the widget in the sidebar and have it set to display the full content of the post. If the plugin is used anywhere else, it works great.

    No, I was asking whether in your theme, the shortcodes get displayed (without expanding) if you use excerpts in the archive pages.

  6. Sudar
    Member
    Plugin Author

    Posted 1 year ago #

    After some debugging, I found the bug. I have fixed it in v3.0.3 of the Plugin.

    Thanks for reporting this bug. Try out the latest version and let me know if you still face any issues with shortcodes inside post.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic