WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] content for home page (12 posts)

  1. MADinMelbourne
    Member
    Posted 4 years ago #

    I know this is a really stupid question, I give up trying to work out how to find my home page so that I can add content to it. Meanwhile my homepage just has NOT FOUND with a search bar - can somebody help me with really basic instructions please?

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    well....is this a new WP install? Have you made any blog posts?

    normally on a new WP install, the homepage has your blog posts on it.

    If you have no blog posts, nothing will show (although normally WP installs with a generic post)

  3. MADinMelbourne
    Member
    Posted 4 years ago #

    yes, I've made two blog posts which are not showing and five pages which are. http://www.madinmelbourne.com.au

  4. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    OK, that's a start...

    how are your settings in settings->reading?

    is it set up so your front page displays your latest posts? (assuming that is what you want?)

  5. MADinMelbourne
    Member
    Posted 4 years ago #

    not quite sure what you mean by settings->reading... I don't want MADinMelbourne to show right at the top of my page, so I've left site title and tag line blank. The wordpress address and url show as madinmelbourne.com.au.

    I want a page as my front page display... and I would like the posts to show - neither of them are right now. The titles of the posts are showing on the footer, when I click on them they all show NOT FOUND.

  6. MADinMelbourne
    Member
    Posted 4 years ago #

    just read my post, should have said, I would like the posts to stay at the footer obviously the content to show when they're clicked.

  7. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    from your admin area, you can go to settings->reading
    it's a menu

    within there you configure how you want your site to act. If you want a static page as your front page, you pick the static page. If you want your blog posts to show as front page, you select that option.

    Here's the step people forget.....if you set up a static front page you have to make a page through wordpress add new page for your blog posts to be on. Then assign that page to be your posts page in the settings->reading menu

  8. MADinMelbourne
    Member
    Posted 4 years ago #

    too cool, I've just breathed again - that was driving me crazy THANK YOU. Still can't find my posts tho, I've categorised them with three separate categories and none of them show. Any ideas? Also, do you know if it's possible to set a separate background for each page?

  9. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    well, 2 things I noticed.... first, do you have a page setup for the posts like we mentioned in settings->reading?

    Next thing, in your footer, the links to your posts look like this:
    http://madinmelbourne.com.au/http:/madinmelbourne.com.au/wearartthou

    that aint right!

    It's a permalinks issue most likely....go to settings->permalinks and temporarily set them to default and save. Test your site, then if all is well, set back to custom.

    As for the backgrounds issue..... I'm sure it's possible, but I dunno off hand

  10. MADinMelbourne
    Member
    Posted 4 years ago #

    the links at the bottom are all for pages, the posts aren't visible anywhere... the pages should the link you've attached tho, that's how I created them. Ok, going back to reading the settings again.

  11. MADinMelbourne
    Member
    Posted 4 years ago #

    ok, when I defaulted the permalinks each page came up with the chrome oops message for every page. I custom set /http:/www.madinmelbourne.com.au and have access to the pages again. Set a static post for both pages and posts just like you said and the posts are listed in the footer. They still show up as NOT FOUND, and I can't view them when I edit the post either. Thanks for your patience.

  12. MADinMelbourne
    Member
    Posted 4 years ago #

    it's a permalinks issue most likely....go to settings->permalinks and temporarily set them to default and save. Test your site, then if all is well, set back to custom

    all is not well and I give up for today.

Topic Closed

This topic has been closed to new replies.

About this Topic