WordPress.org

Ready to get started?Download WordPress

Forums

content encoded RSS feed problem (10 posts)

  1. steph-angel
    Member
    Posted 8 years ago #

    Hi... I've recently noticed a problem with my rss feed. It seems a little slow to update & bloglines keeps informing me that my feed is invalid.

    I've checked the feed here and I get this message... 'Avoid content:encoded'

    ???

  2. steph-angel
    Member
    Posted 8 years ago #

    Doh... I'm guessing my website address would be a help!!!

  3. klklaser
    Member
    Posted 8 years ago #

    I had a similar problem with bloglines, or at least I first noticed it after an upgrade to WordPress 2.0.2. After the upgrade from 1.5.2 to 2.0.2, a newly published post a day or two later did not show up on a bloglines feed that has a few subscribers. This was unacceptable, and I didn't have time to try to track it down. I got out the backups of the 1.5 dbase and the blog files, and rolled back the installation.

    After the rollback to 1.5.2 is when I first noticed the feedvalidator.org CDATA warning, "Avoid content:encoded", which may be similar to your "bloglines" issue. It may present in WordPress 2.0.2, but I didn't specifically check it before deciding to rollback.

    Feedvalidator.org says it's a warning only, not an error. The warning in 1.5.2 can be eliminated by changing the RSS feed in Options > Reading > Syndication Feeds to "Summary" only instead of "Full Text".

    However, existence of the warning and keeping the "Full Text" option on the Syndication Feed doesn't prevent bloglines from carrying my feed and my most recent post in my 1.5.2 rollback; the failure to carry it with 2.0.2 could have been a temporary glitch on blogline's end that caused my single 2.0.2 post to not show: if so, it's a coincidence and not causation.

    This means there are two separate issues I was dealing with at the same time. It might be something that others here using 2.0.2 might want to check at bloglines (for the appearance of 2.0.2 posts) and the separate issue of feedvalidator.org's "Avoid content:encoded" warning.

    There are two old Trac entries regarding the content:encoded or CDATA issue, and I remarked off the str_replace(']]>', ']]>', $content); in what is, in 1.5.2, four separate include directory files, but it seemed to have no effect on the feed validator warning.

  4. farrell
    Member
    Posted 8 years ago #

    I've got this same "content:encoded" problem on both of my WordPress blogs (www.farrellkramer.com/blog) and (www.talkingcommunications.com.)

    At first, I thought it was a problem with a plugin or FeedBurner, but now I believe it's WordPress. However, I have validated my feeds before -- I think a week ago -- and this problem didn't pop up.

    I wonder if there's been some change to what constitutes a "valid" feed. Or perhaps something else changed.

    Any thoughts?

  5. franto
    Member
    Posted 8 years ago #

    i have same problem with my blog: http://blog.franto.com, it's not aggragated by Flash aggregator MXNA (http://weblogs.macromedia.com/mxna)

    it is in WP 2.0.1

  6. Varsity
    Member
    Posted 8 years ago #

    I'm getting a headache with content:encoded too, when I try to apply an XSLT to my feeds. Is it safe to do away with the thing and dump the CDATA into description?

  7. darnpc
    Member
    Posted 8 years ago #

    Can add my feed to list as well upgraded from 1.5 to 2.0.2 and now getting same issue.

    http://www.darnpc.com/wordpress/wp-rss2.php?cat=3

  8. bobsie
    Member
    Posted 8 years ago #

    I get the same issue from FeedValidator, which is preventing syndication of my site http://www.bob.seldo.com

    The errors are here:
    http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fbob.seldo.com%2F%3Ffeed%3Drss2

    Avoid content:encoded
    wfw:commentRSS should be wfw:commentRss
    content:encoded should not contain style attribute
    content:encoded should not contain onclick attribute

    All the help from FeedValidator for these errors says to edit them out. But I don't know how...?!

  9. tanster
    Member
    Posted 8 years ago #

    I encountered the two errors

    1) Avoid content:encoded
    2) wfw:commentRSS should be wfw:commentRss

    I solved #1 with klklaser's tip above, which is to change Options > Reading > Syndication Feeds from “Full text” to “Summary.”

    I solved #2 by changing the WordPress file wp-rss2.php (in the root directory) from wfw:commentRSS to wfw:commentRss, based on this.

    Error-free now! :)

  10. Besz
    Member
    Posted 8 years ago #

    Hi.

    Tanster or anyone, is there an actual fix or solution for this other than to disable full text syndication feeds?

Topic Closed

This topic has been closed to new replies.

About this Topic